こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

win10で有線・無線ネット接続が急にできなくなる

Win10home(バージョン 1803)のノートパソコン(dynabook AZ65/DB)が今朝から急にwifiによるネット接続ができなくなりました。右下のタスクトレイのアンテナマークが消え、コンピュータアイコンにX印があります。

この時点で、設定のネットワークにはイーサネット及びWiFi表示がありませんでした。添付写真をご覧ください。

デバイスマネージャーでは、無線・有線アダプター正常表示、LANアダプターの無線・有線ともに有効ですが、ステータスが「接続されていません」になってます。
サービス一覧にあるWLAN AutoConfig をスタートさせると1068エラーがでます。

ワイヤレスLAN機能が有効にならないため、アンテナマークが出ないようだったので、下記サイトの通りレジストリを変更して再起動すると、アンテナマークがひょうじされました。
https://www.drivereasy.com/knowledge/how-to-fix-error-1068-on-windows-solved/

しかし無線ルーターに接続すると、アンテナマークにビックリマーク表示で「インターネットアクセスがない」とでます。内蔵無線LANを無効にして別途、USB子機
を付けても同じ症状です。(無線ルーターにはほかに数台のパソコンがネット接続できている状態です。)

有線LANで直接ルーターに接続しても、インターネットアクセスなしのままです。なぜか、無線・有線ともにIP自動取得ができず、固定IPにするとルーターとpingが通りますが、ネット接続はできません。

Windows Defenderのファイルウォールを無効にしたり、ウイルスバスターを削除したりしましたが、改善がありません。

現状、DHCP自動取得機能が働かないのと、インターネット接続が完全に遮断されている状況です。

なにか解決策はありますでしょうか。よろしくお願いします。

投稿日時 - 2019-02-13 16:53:03

QNo.9587426

困ってます

質問者が選んだベストアンサー

ipv6の無効化は試されているかもしれませんが、
https://teratail.com/questions/106131

投稿日時 - 2019-02-14 21:26:09

お礼

ご回答ありがとうございます。
イーサネットのプロパティーから、インターネットプロトコールバージョン6(TCP/IPv6)のチェックを外して、有効・無効を試しましたが改善しませんでした。

ありがとうございます。

投稿日時 - 2019-02-15 10:16:23

ANo.9

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(9)

ANo.8

少なくともip的にはインターネットに出られていますね。
dnsの解決ができていないためにwebの閲覧ができていません。
ルーターのルーティングの問題ではありません。
クライアント側のdnsの名前解決をする機能が正常ではありません。
nslookupで手動でdnsを引いてみて下さい。

http://lan-pc.pc-beginner.net/net_cmd/nslookup.html

投稿日時 - 2019-02-14 21:19:57

お礼

度々、ご回答いただき、ありがとうございます。

nslookup www.yahoo.co.jp と入れたのですが、アプリケーションエラーが出て「アプリケーションを正しく起動できませんでした。(0x0000276)」と出ました。

nslookup自体が起動できないので、nslookupが正しく起動できないで検索しました。下記サイトに行きつきました。

https://answers.microsoft.com/ja-jp/windows/forum/all/%E3%82%A2%E3%83%97%E3%83%AA%E3%82%B1%E3%83%BC/f55aea9b-07a8-42c9-890b-e619e24a58ce

アプリケーションファイルやファイルシステムの破損の可能性があると思い、Dsimコマンドをサイトの説明通り実行して完了しました。

その後、sfc /scannow を実行すると52%で終了して、「リソース保護は要求された操作を実行できませんでした。」で終わります。セーフモードで実行しても同じでした。

Win10proへのアップグレードも試しましたが、「インストール時、何も引き継がない」しか選択できない状態でした。その下の欄に「インストール先が違うため、引き継ぎはできません」の表示がありました。

そのためアップグレードは断念しました。ここまで時間をかけて色々試しても解決ができないので、初期化することになりそうです。

本当にありがとうございました。

投稿日時 - 2019-02-15 10:03:18

ANo.7

ping 8.8.8.8
は返って来ますか?
あと
tracert 8.8.8.8
実行した結果で最初に返ってくる
ipアドレスはデフォルトゲートウェイのものですか?

あとアプリケーションをそのままに取りうる方策としてはWindows10のアップグレードインストールで改善するかどうかでしょうか。

それでも改善しない場合
残念ながら、バックアップを取得して、再セットアップするということになると思います。

投稿日時 - 2019-02-14 18:28:12

お礼

度々、ご回答ありがとうございます。
ip 192.168.0.55
subnet 255.255.255.0
gw 192.168.0.1
dns1 8.8.8.8

上記設定でご指示通りした結果です。pingでの応答はありますが、tracertの結果、リソースがないと出ます。

現状、この設定だと右下タスクバーの有線接続アイコンはX印無しの正常表示になっています。有線LANアダプタのインターネットの状態はIPv4 インターネット、IPv6インターネットアクセス無しです。

勿論、この状態でもインターネット接続はできておりませんでした。

C:\Users\shiba>ping 8.8.8.8

に ping を送信しています 32 バイトのデータ:
8.8.8.8 からの応答: バイト数 =32 時間 =49ms TTL=119
8.8.8.8 からの応答: バイト数 =32 時間 =28ms TTL=119
8.8.8.8 からの応答: バイト数 =32 時間 =39ms TTL=119
8.8.8.8 からの応答: バイト数 =32 時間 =28ms TTL=119

?? の ping 統計:
パケット数: 送信 = 4、受信 = 4、損失 = 0 (0% の損失)、
ラウンド トリップの概算時間 (ミリ秒):
最小 = 28ms、最大 = 49ms、平均 = 36ms

C:\Users\shiba>tracert 8.8.8.8

へのルートをトレースしています。経由するホップ数は最大 30 です

1 <1 ms <1 ms <1 ms リソースがありません。

C:\Users\shiba>

投稿日時 - 2019-02-14 20:48:15

ANo.6

dhcpクライアントに問題が発生した事例がありました。
https://qiita.com/kno2502/items/6fea9430a830157e2aca

ただ、状況を拝見すると、有線にせよ無線にせよ固定でipアドレスを認識するも、インターネットに出られていないですね。
dnsが引けてないようですので、グーグルの提供するdnsアドレス8.8.8.8
を設定してみて、ping www.yahoo.co.jp
の答えが返って来るか。
返ってこなくともipアドレスの解決がされているかの確認が取れます。

別HDDに OS初期化した場合に
LANが機能していることからもwindows起因のように思えます。

現象が発生しだしたタイミング以降のWindowsUpdateの更新をアンインストールしてみてはいかがでしょうか。

投稿日時 - 2019-02-14 07:38:53

お礼

ご回答ありがとうございます。

ご提示いただいたサイトの通りコマンドを実行しましたが、改善しませんでした。

DNS1を8.8.8.8でIPアドレスおよびディフォルトゲートウェイは固定にしました。ping www.yahoo.co.jpは「ホスト名が見つかりませんでした」とでます。

Windowsアップデート履歴を見ると一番直近では2019年1月30日に(KB4100347)が入っていました。10日以上前の物なので、削除してもどうかなと思いましたが、削除しました。結局、改善しませんでした。

レジストリもバックアップを取って、自動バックアップされているレジストリにすると自動修復の繰り返しで起動しませんでした。

バックアップを戻して起動するようになりましたが、相変わらずインターネットアクセスなしのままです。

ほぼお手上げ状態です。 ありがとうございました。

投稿日時 - 2019-02-14 16:47:48

ANo.5

結局のところ、認証情報のやり取りができない状態なので固定IPにしてルーターまでアクセス可能でも、WANまで通信ができない(ルーターのDNSまで届いてない)と考えられます。
DHCPでIPを振ってもらおうとしているとき、有線でつなごうとしたときにローカルリンクアドレスが表示されるかどうか、Wi-fiに接続しようとしたときはSSIDが見えてセキュリティコードまで受け付けるのかというのも判断材料になります。

トラブルシューティングツールで診断はしてみましたか?
https://dynabook.com/assistpc/faq/pcdata2/017319.htm

今出ている情報で考えられるのは、
1.Windowsの不具合
→直前にアップデートがあったのであれば、一つ前のバージョンに戻してみる。
2.ネットワークドライバの不具合
→ネットワークドライバを再インストールすると直る可能性がある。
3.ネットワークアダプタの不具合
→ネットワーク部品の物理的な故障。修理案件。
4.システムの破損、HDDの劣化
→システムの復元で通信ができていたころまで戻しても直らない、ネットワークドライバを入れなおしてもダメなら、ほかの機器の物理故障を疑います。これも修理案件になるでしょう。

投稿日時 - 2019-02-13 23:50:37

お礼

ご回答ありがとうございます。

ネットワークアダプターのトラブルシューティング診断結果は「何も異常が見つかりません」で終わります。

Windowsアップデート履歴を見ると2019年1月30日に(KB4100347)の更新が最後でした、それから10日以上経過しているので、可能性は低いと思いましたが、削除して再起動しても変化なしでした。

ネットワークドライバ(デバイスマネージャで表示されている有線・無線LANの事であれば)は無線・有線ともに削除して、ハードウェアの変更スキャンから復活させましたが、変化なしでした。

内蔵LANアダプターの物理的故障を疑い、内蔵無線LANを無効にしてから、USB無線LAN子機(Win10でドライバー自動認識済み)を付けてみましたが、同じ症状でルーターと接続はされるのですが、ipconfigでは169.254.XXX.XXXのアドレス表示です。

システム破損はかなり可能性が高いような気がします。そもそも無線LANのアンテナマークが表示されない事から始まり、レジストリをいじると無線LANのアンテナマークが表示され、Win10の設定からネットワークに入いるとイーサネット、Wifi表示が復活しました。(添付写真では一覧に表示されていなかったのですが)

レジストリがおかしいのかなと思うのですが、その大元の原因はシステムの破損か、HDD劣化でしょうかね。

もう少しレジストリ修復などの操作をして頑張ってみます。
ありがとうございました。

投稿日時 - 2019-02-14 10:52:19

ANo.4

イーサネットのプロパティにて接続に必要な項目(例えば「ネットワーク用クライアント」や「インターネットプロトコル」)がオフになっているということはありませんか。
http://www.enjoy.jp/cs/tech/internet/network/ten/images/ethernet-p002.gif

投稿日時 - 2019-02-13 18:48:54

お礼

ご回答ありがとうございます。
無線lan、有線lanともにプロパティからインターネットプロトコールはチェックが入って有効です。

Microsoft Network Adapter Multiplexor Protocol 以外、全部チェックが入っています。正常動作するパソコンのネットワークアダプターのプロパティーと比較しても、違いがありませんね。

ありがとうございます。

投稿日時 - 2019-02-13 19:36:08

ANo.3

ルータの設定画面に入って、インターネット接続状態を確認して下さい。
   
方法はレジストリまで構うのであればわかると思いますが、念のため。
コマンドプロンプトで「ipconfig」ここでデフォルトゲートウェイのIPを読んで、ブラウザでそのIPアドレスにアクセス。
パスワードは、設定した時のパスワードを覚えていますか?
   
ルータも壊れることがありますから、LANケーブルの断線、ルータの故障も疑いましょう。
パソコンの設定はまず狂わないから、焦ってパソコンをいじるのは最悪です。
逆に設定がおかしくなってドツボに嵌まります。

投稿日時 - 2019-02-13 17:33:09

ANo.2

HDDの故障かも。

投稿日時 - 2019-02-13 17:29:11

お礼

ご回答ありがとうございます。

問題のパソコンのSSDのクローンを他のSSDに作成して、そのSSDで操作しています。HDDチェックはしていませんが、可能性はありますね。

クローンなのでなんでも平気で変更できるため、購入状態に戻すと問題なくネット接続できます。 ただ今入っているソフトを削除したくないため、初期化は避けたいわけです。

ありがとうございます。

投稿日時 - 2019-02-13 19:44:07

ANo.1

ルータの先がWANにつながっていないのでしょう
ルータ再起動で回復しない場合はルータの接続先(モデム他)の状態の確認が必要

投稿日時 - 2019-02-13 17:07:26

お礼

ご回答ありがとうございます。
事務所の無線ルーターには、他のパソコンも有線・無線で問題なくつながっておりました。事務所で問題解決できず、家に持ち帰って無線ルーターにつないでも同じ現象です。

どのルーターにつないでも同じ現象なので、パソコン側の問題だと思っています。

ありがとうございます。

投稿日時 - 2019-02-13 19:46:56

あなたにオススメの質問