こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

Windows 101703,1709でのプチフリ

2年ほど前に自作したPCで困っています。
未だに原因がわからないのでこちらを利用させていただきました。
語彙力のない読みにくい長文で失礼します。

CPUinteli7 6700K
メモリTeamDDR4-2400 8GB*4枚
マザボMIS Z170A Gaming Pro
SSDintel 600p 512GB(NVMe PCIex4、マザボ上のm.2スロットに接続、OSや普段使うソフトウェア用)
HDDWD WD Black 2TB(マザボ上SATA接続、データ用)
グラボMSI GTX960 Gaming4G (PCIex16接続)

主要なパーツはこの通りです
1607から1703にアップグレードするのをきっかけにSSDを現在のものに変ました。また、現在のOSはWindows10 pro 1709、セキュリティソフトはESET Internet Security、ドライバ類はMSIのホームページにある最新のものを使用しています。
メモリチェックやWindows上でのCHKDSK、純正ツールでの診断なども問題ありません。しかし次のような現象で困っています。語彙力がなく読みにくい長文ですいません。

フルHDディスプレイ2枚でのデュアルディスプレイなのですが、いつの間にかデスクトップアイコンの配置が乱れていたり、自分で配置を戻そうとしアイコンをドラッグアンドドロップしても、マウスボタンを離した位置とは違う位置にアイコンが移動してしまうことがあります。これは特にメインディスプレイとサブディスプレイ両方にアイコンを置くとひどいです。自分で移動させた覚えがなくてもdesktop.iniがサブディスプレイの端っこの方まで移動していることがよくあります。
また、この現象で困っている時にサブディスプレイを切断したらメインディスプレイのデスクトップ上でアイコンがルーレットのようにグルグル回りだし操作不能になりました・・・(再起動したら止まっていましたが)

また、Shift押しながら再起動(shutdown.exeの-oオプションや、設定アプリの"PCの起動をカスタマイズする"でも同様)
で詳細起動オプションを表示させても、オプションの選択肢にPCの電源を切るしか表示されません
(本来 続行、ディスクの使用、トラブルシューティング、電源を切る、の4つのはずですが)
これではUEFI設定に入ったりブートデバイスの指定ができないのでWindowsとUEFI上で高速スタートアップを無効にしています。

稀にですがエクスプローラーでPCを表示したとき、接続しているドライブなどはすべて表示されているのにアドレスバーのプログレスバーがゆっくり進んでいき、その時にエクスプローラー上で何か操作をしようとしても、カーソルがビジー状態に変わりプログレスバーが進行しきるまで応答なしになることがあります。(進行しきったら通常通り操作可能です)

そして一番困っていて一番文章で説明しにくい問題なのですが、特に負荷のかかる操作をしていなくても、カーソルの動きがカクついたりしばらく止まったり延長が発生しているときのような動き方をしたりします。(いわゆるプチフリーズですかね・・・)マウスはエレコムのM-H2DLを有線で接続しています。カーソルの動きが止るときは画面の描画も止まっているのですが、プチフリーズ時に動画や音楽を再生していると音が単純に止まるのでなくビーッと伸びる様な感じの乱れ方をします。ストリーミング再生などで回線速度が足りてないときのような止まり方とは全く違います。止まると言うよりか極端にスローで再生しているような状態になって一気に通常の速度に戻るというような感じです。

このような現象は現在のSSDにOSを何回再インストールし直しても同じように発症します。
しかしUbuntuをUSBからLive起動してしばらく使ってみると、カーソルの動きがもたつく事は稀にありましたが音声が乱れるなどのWin10 170X系の様なプチフリは起きませんでした。
そこでSandisk製の64GBのUSBメモリにWindows10 EnterpriseLTSB(バージョン1607)をインストールして、ドライバや普段使っている常駐ソフトウェア類もインストールし、ある程度使ってみましたがこのような問題は発生しませんでした。(さすがに3.0でもアクセスが集中すると応答なしになったりカーソルがもたついたりしますが170X系のようなプチフリはありません。)
7、8時代はESETが原因でトラブルが発生した経験があったので、USBのWin10Enterprise1607上でESETのセキュリティスキャンをしながらVLCメディアプレーヤーでDVDを再生しましたが1度も映像が止まったり音声が乱れることはありませんでした。(メディアプレーヤーが応答なしになって操作不能になっても映像音声は止まりませんでした)

まだ自作歴6年なので見落としている点があるかもしれませんが、IntelSSDの不良または相性、もしくはWindows10 170X系の問題だと思います。
しかし、ググっても私と同じ現象で困っている方は見つけられませんでした。
同じ現象で困っている方や、なにか原因を推測できた方がいましたら是非ご教授ください。

それと現在のBIOSのバージョンが1.4だったので、MSIのページを見たところ新しいBIOS(1.E)があり、アップデート項目にNVMeの互換性向上等と書いてあったので更新しました。しかしプチフリは治りませんでした。それどころか電源を入れてからMSIのロゴが表示されるまでにものすごく時間がかかるようになりました。更新前2秒位だったのが7秒くらいかかります。またm.2スロットは1つしかないのにm.2でRAIDを組むオプションやIntelSerialIO、IntelSGX、セキュリティの項目にTPMなどが追加されました。(初期値ではSerialIOは無効なのですがこの状態でWindows上でドライバをインストールしようとしてもエラーが出ます。項目が追加される前のBIOSののときはインストールできたのですが・・・)今時ファームウェアは最新のものを使えばいいと考えていましたがやはりそういうわけにはいかないのでしょうかね・・・BIOSは以前のバージョンに戻すべきでしょうか。

また、無知な質問で申し訳ありませんが、IntelSerialIOとは何でしょうか。今まで気にせずにドライバをインストールするだけでしたがこの機会にどなたか教えてください。
長文失礼しました。

投稿日時 - 2017-12-03 19:08:14

QNo.9404044

困ってます

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.4

>1607から1703にしてから一気にこのような症状が発症するようになったので何か関係があるのかと思い

当方のPCは1607から1703にしましたが、何の問題も起きていません。と言うことはWindowsバージョンとは関係ありません。PC自体のトラブルでしょう。

投稿日時 - 2017-12-03 23:21:29

補足

私もそれを考えて1607(Enterprise)をUSBにインストールしてみたのですがそっちではこのような問題は発生せず、1709をSSDにクリーンインストールするとすぐにこのような現象が起こります。
また、1607の頃に使っていたSata接続のSSDをまだ手放していなかったので、先程それに1709をインストールしてみたところやはり同じような問題が発生しました。
おそらくWindows10 1709と私のPCのハードウェア(もしくはそのドライバ)か何かと相性の問題があるのでしょうか

投稿日時 - 2017-12-04 01:15:55

ANo.3

プチフリはSSD等が登場し始めた頃には結構聞いた話ではありますが今はあまり聞かないですね。

Windows10 の プチフリ/フリーズ問題のチェックポイント
https://freesoft.tvbok.com/win10/problems/check_pc_freeze.html
SSDがプチフリするんだが、windows10が問題なのか、ryzen環境が問題なのか、それとも.......
http://teisupekku.jugem.jp/?eid=165
Windows10プチフリ問題の解決 (Crucial C400+ASRock 990FX Extreme4)
http://www.bluesky-blog.net/2016/12/windows-freeze/
Windows 10 Creators Update を適用した後からプチフリが出始めたので対応してみた
http://kimamanilife.com/archives/1080
検索する限りでは色々情報は出てきますが質問者さんの環境に近そうなものはないので解決には至らないかも知れないですね。

>1709をクリーンインストールして、ドライバ類や更新プログラムを
>インストールした頃にはもう発症してしまいます。
どのドライバや更新プログラムを入れた時点で発生するか?一つ一つ確認するって言うのもありますがあまりやり過ぎるとSSDへの総書き込み量を無駄に増やすだけで寿命を縮める一因になっても困りますね。

投稿日時 - 2017-12-03 23:07:25

補足

たくさんの情報をありがとうございます。
何も考えずにいろんなバージョンやエディションを何度もインストールしていたので、いま確認したところ総書き込み量が7000GBを超えていました(汗)まだ1年目なのに以前の3年ほど使用していたSSD並です
しかしSMART上やintelのSSDツール上ではまだ100%正常となっていたので安心しました。
話を戻しますが先程、LANケーブルを外して更新プログラムをインストールしないようにし、以前に使っていた(1607をインストールして使っていた頃の)SATAのSSDに1709をインストールしましたが、チップセットとUSBとGPUのドライバと、intelのSSDツールをインストールした時点でもう起動オプションは表示されなくなっており、デスクトップアイコンも散らばっていました。(インストール直後にまず確認すべきだったと反省しています。)

投稿日時 - 2017-12-04 01:35:59

ANo.2

>IntelSerialIOとは何でしょうか。
検索してみましたがよくわからないですね。
http://memonotealpha.net/blog/archives/1407
https://solutions.vaio.com/1617
など見る限りではタッチパッドやタッチパネルに関係したもののようですが…

面倒ですが一番良いのは1709(または1703)をクリーンインストールし直して見る事です。それで改善がみられるなら何かソフトウェアやドライバの影響の可能性がありますし改善しないなら何かハードウェアに起因している可能性も出てきます。

投稿日時 - 2017-12-03 21:59:21

補足

1709をクリーンインストールして、ドライバ類や更新プログラムをインストールした頃にはもう発症してしまいます。

投稿日時 - 2017-12-03 22:41:23

お礼

私の環境ではSerialIOは必要なさそうですね。
ありがとうございます。

投稿日時 - 2017-12-03 22:51:28

ANo.1

質問は一つだけにして下さい。

投稿日時 - 2017-12-03 21:10:38

補足

申し訳ありません。1607から1703にしてから一気にこのような症状が発症するようになったので何か関係があるのかと思い長文になってしまいました。
SerialIOについてはおっしゃる通り別にするべきでした。

投稿日時 - 2017-12-03 22:39:26

あなたにオススメの質問