こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

ラズパイ3で接続中のwifiのssidを確認

raspberry pi3でwifiに接続してネット通信させているのですが、この接続中のwifiのssidが何なのかを調べるcuiコマンドはありますでしょうか?

部屋内に複数のアクセスポイントを立てているためどれに繋がっているか調べたいです。

どうぞ、ご教示の程、宜しくお願い致します。

投稿日時 - 2017-07-14 13:16:45

QNo.9351778

すぐに回答ほしいです

質問者が選んだベストアンサー

wpa_supplicant.confの設定

マルチメディアファイルは削除されたか見つかりません。

投稿日時 - 2017-07-18 12:10:49

お礼

回答頂きありがとうございます。

wifi治りました(^^)

wpa_supplicant.confの画像を見ていて、

”ctrl_interface....”
これが
"kctrl_interface...."

これになっていることに気づきました。修正後、今までエラーを出していた

$ sudo ifdown wlan0
$ sudo ifup wlan0

このコマンドが正常に動作することを確認できました。

また、各種設定ファイルを変更後ifconfigでIPアドレスをDHCPで取得できていることを確認できました。

https://github.com/KenjiMaehara/raspberryPiTCPClient/commit/0ddaac334319689b012bfda3edfab3034645e2f5


システム関係の設定ファイルをいじる前には必ずバックアップを作っておけば良かったなと反省しております。


大変助かりました。

投稿日時 - 2017-07-19 16:28:27

ANo.6

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(8)

ANo.8

interfacesの設定
eth0はすべてコメントアウト
wlan0は#見にくいですが。

私の使っているラズパイの無線設定です。
OSは最新で、GUIなし版です。

マルチメディアファイルは削除されたか見つかりません。

投稿日時 - 2017-07-18 12:18:08

ANo.7

dhcpcd.confの設定

マルチメディアファイルは削除されたか見つかりません。

投稿日時 - 2017-07-18 12:11:56

ANo.5

無線LANアダプタの状態確認
lsusb

マルチメディアファイルは削除されたか見つかりません。

投稿日時 - 2017-07-18 12:08:58

ANo.4

wpa_supplicant.conf 
network={
ssid="Buffalo-A-6098"
#psk="4vheeeg737sby"
  psk= ←ここがありません。 最初にあった長ったらしいものをコピペして下さい。

  key_mgmt=WPA-PSK
proto=WPA2
pairwise=CCMP
group=CCMP
priority=2
}

dhcpcd.conf
domen serverは、ISPから提示されたアドレスを記述して下さい。

投稿日時 - 2017-07-18 01:53:24

お礼

回答頂きありがとうございます。

色々と助かります。


教えて頂きました修正を実施して見ました。
https://github.com/KenjiMaehara/raspberryPiTCPClient/tree/ATxmega128Branch20170321/raspiFiles


ただ、この修正を実施して再起動後でもifconfigでの wlan0の結果は

$ ifconfig

=======(中略)================

wlan0 Link encap:イーサネット ハードウェアアドレス b8:27:eb:1a:f2:7b
inet6アドレス: fe80::4a0:1444:841c:65ee/64 範囲:リンク
UP BROADCAST MULTICAST MTU:1500 メトリック:1
RXパケット:3 エラー:0 損失:3 オーバラン:0 フレーム:0
TXパケット:0 エラー:0 損失:0 オーバラン:0 キャリア:0
衝突(Collisions):0 TXキュー長:1000
RXバイト:445 (445.0 B) TXバイト:0 (0.0 B)


固定IPアドレスが設定されていないようです。


また、


$ sudo ifdown wlan0
ifdown: interface wlan0 not configured

$ sudo ifup wlan0
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.


やはりwlan0の再起動でも、このようなメッセージが出て、wlan0が起動していないようです。


他に方法などありましたら、ご教示宜しくお願い致します。

投稿日時 - 2017-07-18 10:25:59

ANo.3

固定IPアドレス設定

/etc/network/interfaces
auto wlan0は#でコメントアウト

/etc/dhcpcd.conf 追加
static ip_address=X.X.X.X/24
#Gateway
static routers=X.X.X.X
#Domain
static domain_name_server=X.X.X.X
static domain_name_server=X.X.X.X

/etc/wpa_supplicant/wpa_supplicant.conf
なにもないですね。

network={
SSIDは手動設定
ssid="   "
#psk="   "
PSKはコピペです。
psk=

追加
ここの暗号化は自分の環境に合わせて下さい。
key_mgmt=WPA-PSK
proto=WPA2
pairwise=CCMP
group=CCMP
priority=2
}
どうでしょうか。

投稿日時 - 2017-07-17 17:53:52

お礼

回答頂きありがとうございます。

教えて頂きました修正を実施して見ました。
https://github.com/KenjiMaehara/raspberryPiTCPClient/tree/ATxmega128Branch20170321/raspiFiles


ただ、これでラズパイを再起動しても、ifconfigやっても固定したipアドレスは出てこない感じです。


$ sudo ifdown wlan0
$ sudo ifup wlan0

このコマンドの結果も現在は前回と同様という感じです。

他に方法ありましたら、教えて頂きますよう、宜しくお願い致します。



現在私のラズパイ3で起こっている現象を映像で取って見ました。
もしよければ見ていただけると助かります。


現在ラズパイ3のwifiが動作しない現象について
https://youtu.be/ZDlW48esIrs @YouTubeさんから

投稿日時 - 2017-07-17 23:00:58

ANo.2

dhcpcd.confのwlan0、domain_name_serverのコメントアウトを外して再起動かけてみては。

投稿日時 - 2017-07-17 12:22:26

お礼

回答頂きありがとうございます。


/etc/dhcpcd.confファイルをsudo nanoで見て見たのですが、


wlan0、domain_name_server

このような行が見当たりませんでした。

試しに、

”interface wlan0”

という行を追加して見ました。


ネットワークインターフェースを設定した際のコマンドなど - 午後から→オーバークロック http://nemupm.hatenablog.com/entry/2014/09/20/035935



上記のサイトを参考に、

$/etc/init.d/networking restart
というのをやって見たところ、


/etc/init.d/networking restart
[....] Restarting networking (via systemctl): networking.serviceFailed to restart networking.service: Access denied
failed!



このようなエラーが出てくる感じで、wlan0の認識そのものがなくなっているような感じがします。
raspberry piを再起動してもwlan0はdhcpでipを取ってきてないような感じです。(そもそもssidで接続できてないです。)



また、


$ sudo wpa_passphrase Buffalo-G-6098 4vheeeg737sby

このコマンドで無線LANのAPのSSIDを登録しようとしたのですが、
次のような表示は出るのですが、

network={
ssid="Buffalo-G-6098"
#psk="4vheeeg737sby"
psk=952d304d24fbbf3c245102116de831980f8ad2a2fb90d33a2dc0a5da62f8568f
}



/etc/wpa_supplicant/wpa_subblicant.confをsudo nanoでやって見たところ、上のSSIDが全く登録されていないことに気づきました。

SSIDの登録はどうすればいいでしょうか?



私のgithubのサイトに

/etc/wpa_supplicant/wpa_subblicant.conf
/etc/dhcpcd.conf
/etc/network/interfaces

このファイルを用意しました。

https://github.com/KenjiMaehara/raspberryPiTCPClient/tree/ATxmega128Branch20170321/raspiFiles



もしよければ、他に確認した方が良いことなど教えて頂きますよう、宜しくお願い致します。

投稿日時 - 2017-07-17 15:51:52

ANo.1

cat /etc/wpa_supplicant/wpa_supplicant.conf
ここにありませんか。

投稿日時 - 2017-07-17 04:57:09

お礼

回答頂きありがとうございます。

wifiは今まで使用できていたのですが、ラズパイ3が自分が用意しているAPのSSIDに接続したくて


sudo nano /etc/wpa_supplicant/wpa_supplicant.conf

これや

$ sudo nano /etc/network/interfaces

このファイルあたりを編集したあたりからwifiの動作がおかしくなったような? 気がしています。



$ sudo ifup wlan0 このコマンドでwifiを有効にしようとしたのですが、次のようなエラーが出てきます。

wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Failed to bring up wlan0.

投稿日時 - 2017-07-17 09:10:52

あなたにオススメの質問