こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

viberをAndroid2.3で使っている人いま

viberをAndroid2.3で使っている人いますか? ip電話にAndroid4.0が必要に思えないのですか、ホームページにはAndroid4.0以上が推奨されています。
どうなんですかね、、、

投稿日時 - 2016-12-04 16:59:22

QNo.9263843

困ってます

質問者が選んだベストアンサー

そのアプリは知りませんが、OSのバージョンの条件については心当たりがあります。

アプリを作成する際のライブラリの要件にOSのバージョンが含まれていることが多々あります。
最新のOSに対応するためには開発環境のバージョンアップも必要で、ライブラリも新しくする必要があります。
ビルド(実行ファイル生成)時に対象となる実行環境を指定することになると思うのですが、Androidは2.xと3.xまではスマホとタブレットと別れており、4.xになってスマホとタブレットという区分けがなくなりました。
だから、Android2.x対応アプリは4.x以上のバージョンでも使えることが多いですが、4.x以上となっているアプリは2.xでは実行に支障が出ることが多いため「非対応」とされるのが一般的です。

インストール時にもストアアプリやGooglePlay開発者サービス(というアプリ)のバージョンにも依存していることがあります。
で、それらのアプリの最新バージョンはAndroid2.xはサポートされていなかったはず。
今年の前半か昨年にそういう発表があったと思います。

だから・・・最新のアプリをAndroid2.xスマホで使うのは・・・現実的ではないかと・・・

投稿日時 - 2016-12-04 18:13:20

お礼

なるほど、i p電話なんで、そうでもないかと思っていたのですが、
区分けがあるんですね

投稿日時 - 2016-12-04 18:46:19

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(1)

あなたにオススメの質問