こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

クロームでJAVAが使用できない

昨日までクロームでJAVAを使用していたのですが、今日になって出来なくなりました。
「このプラグインはサポートされていません」のメッセージです。
IE、及びファイヤーフォックスでJAVAが使用できていることを確認して念のために[JAVAの構成]からブラウザで有効になっていることを確認。
クロームの機能のabout:pluginsでプラグインのリストを確認したところJAVAがありませんでした。
JAVAを一度アンインストールして再インストールしなおして、IEとファイヤーフォックスで動作を確認してJAVAの構成で有効を確認後に、クロームでabout:pluginsをしましたがJAVAはリストに無くて使用することもできません。
JAVAの再インストールはjre-7u80-windows-x64とchromeinstall-8u45をそれぞれクリーンインストールから試してみました。
IE、ファイヤーフォックスでは動作しますが、クロームではプラグインのリストにも表示されません。
WINDOWS7プロフェッショナル64bit クロームは 42.0.2311.90 mです。
使用しているセキュリティソフトはMSEです。ブロック機能などのあるファイヤーウォール系のソフトは使用していません。
どなたかアドバイスお願いいたします。

投稿日時 - 2015-04-17 10:50:10

QNo.8957308

すぐに回答ほしいです

質問者が選んだベストアンサー

私も焦りましたが、Chrome 42からNPAPIプラグインが無効(Disable)になったのが原因です。

NPAPIプラグインを有効(Enable)にするには、chrome://flags/#enable-npapi を開き「NPAPIを有効にする」の項で[有効にする]を選択してください。

すると、chrome://plugins/ (←about:plugins)に「Java(TM) - バージョン: 11.45.x.xx」が表示され、[有効にする]を選択できます。

投稿日時 - 2015-04-17 11:23:15

お礼

ありがとうございます!まさにそれでした。
検索しても出てこなかったのは新しいバージョンでの症状だからだったんですね
感謝です!

投稿日時 - 2015-04-17 11:44:45

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.3

Google社が、従来のNPAPI形式のプラグインを段階的に廃止して、新しいPPAPI形式のプラグインに切り替える方針なの(今までサードパーティーのプラグイン開発者は何やっていたのか…)で。

根本的には、こうなったら、Oracleに直訴して、PPAPI形式のJavaプラグインを作ってもらう(Java 9で暫定対応、Java 10で正式対応とか言われたらどうしよう)しかないです。

投稿日時 - 2015-04-17 17:34:47

ANo.2

こちらの記事にplugin関連の内容があるようです。
9月には現在の機能は無効にして、Googleの開発した方式に移行することが推奨されているとの内容です。
(Chromeを更新したらUnity WebPlayerが動かなくなった件)
http://blog.studiok-i.net/unity/1090.html

投稿日時 - 2015-04-17 11:42:10

お礼

ありがとうございます!
9月からまた大きな変更になるんですね。この情報をあわせて九月まで覚えておこうと思います

投稿日時 - 2015-04-17 11:45:41

あなたにオススメの質問