こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

qt creatorのプロジェクトでビルドエラー

現在Debian Linuxが搭載されているBeagleBoneBlackにqt creatorをインストールしてプログラミングしています。

windows8.1のPCにもqt creatorインストールしていて、こちらでhello worldのテストのプロジェクトを作成して動作できることを確認しており、このプロジェクトをDebian Linux側にも移してビルドしてみたのですが、エラーが発生してしまいます。

https://sourceforge.jp/projects/cc1101driver/scm/svn/tree/2497/trunk/20140717/tes0721_02/


こちらが現在のqt creatorのプロジェクトです。




tes0721_02.proというプロジェクトファイルをDebian Linux側で開くとつぎのようなエラーが表示されます。

Configure Project

No valid Qt versions found.

Please add a Qt version in Tools > Options > Build & Run(Qt Creator > Preferences > Build & feRun on Mac OS) or via the maintenance tool of the SDK.


このエラーの解決方法をご教示頂きますよう、よろしくおねがい致します。

投稿日時 - 2014-07-24 13:25:45

QNo.8690585

すぐに回答ほしいです

質問者が選んだベストアンサー

そのメッセージは理解しましたか?

投稿日時 - 2014-07-24 21:31:15

お礼

回答頂きありがとうございます。

BeagleBoneBlack側のQt creatorでこのエラーに従って

Options > Build & Run


この項目の"Qt Versions"をのぞいてみたところ、

Qt 4.8.2 in PATH(System) /usr/bin/qmake-qt4

この行に赤のびっくりマークのアイコンが付いている状態でした。


この現象は、このQt Creatorには現在有効なコンパイラなどがインストールされていない状態ということでしょうか?

またコンパイルできるようにするにはどのようにすれば良いのかご教示頂きますよう、お願い致します。

投稿日時 - 2014-07-27 08:27:23

ANo.1

このQ&Aは役に立ちましたか?

11人が「このQ&Aが役に立った」と投票しています

回答(1)

あなたにオススメの質問