こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Ubuntuの削除(MBR)の修復ができない

 はじめましてLinuxの初心者です。
 Ubuntu13.10をXPとdual bootし正常に動作していたのですが、削除する必要ができたので
インストールdiskを使用し回復コンソールから
 >ficmbr
>fixboot
>exit
をしました。上記の途中で、"CドライブにMBRを書き込む"等、それらしい表現がでたので
正しく操作しているものと思っていましたが、EXIT後の再起動で、GRUBの選択画面がでて
しまいました。数度試みましたが同じです。

 どのように対処したら助けていただけると幸いです。システムは以下です。
  CPU  Pentium(R) D 2.66
MB GA-8I865GMK-775
GB GeForce 6600Agp 8x
  Ubuntu 13.10 の32bit版
よろしくお願いします。
 

投稿日時 - 2014-04-20 19:15:16

QNo.8562263

すぐに回答ほしいです

質問者が選んだベストアンサー

> 「ficmbr 」は質問時の単なるタイプミスでしょうか。
コマンドはタイプミスのないように気を付けてください。(読んでいる側は、記述内容を信じていますので・・・)
タイプミスではなくてホントに ficmbr と入力したのであれば入力ミスですので、
回復コンソールでは fixmbr と入力してください。
なお、fixmbr および fixboot は、パラメータを省略しないで適切に入力してください。
---
まずは基本に忠実に行なってみてください。
・ デバイスを正しく認識するために map コマンドで確認してください。
・ diskpart コマンドで boot partition をactiveにしてください。
・ fixmbr device_name を実行してください。
「Fixmbr」
http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/bootcons_fixmbr.mspx?mfr=true
・ fixboot drive を実行してください。
「Fixboot」
http://www.microsoft.com/resources/documentation/windows/xp/all/proddocs/en-us/bootcons_fixboot.mspx?mfr=true
---
以上です。

投稿日時 - 2014-04-20 19:58:42

補足

 kteds様、解決しました。mapコマンドでXPのドライブを確認したところ、Dドライブ、disk1でデフォルト設定と異なっていました。ただ、diskpartでPartitionをアクティブにする件、同コマンドを入れたところ、Partition作成、削除の画面になりほかの動作をさせることができませんでしたのでActiveにはしていません。
 また、2つのコマンドの順序ですが、ググルとまちまちでしたが、内容からfixbootを先にしました。正しいかどうかはわかりません。
 結局、2つのコマンド入力で、正しくドライブやPartitionを指定することでうまくいきました。本当にありがとうございました。

投稿日時 - 2014-04-21 22:58:28

お礼

kteds様、早速の助言ありがとうございます。"ficmbr"はタイプミスです。さらに日本語としておかしなところがありました申し訳ありません。
 助言に従ってトライしてみます。
 

投稿日時 - 2014-04-21 05:41:37

ANo.1

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(2)

こちらのサイトが参考に、なります。
http://www.1004.ubuntu-d.com/_uninstall/rebuild_bl_xp.html

デュアルブートでWindows 本体が動かなくなるトラブルが数多、起きてます。
WindowsXP のデータのバックアップは必ず取って置きましょう。

ついでながら、Linux をUSBメモリに入れると、本体を何ら、いじる事なく
安全に運用できます。
Ubuntu,Puppy Linux なら操作したデータをUSBメモリに保存出来ます。

USB Boot 機能の無いパソコンでもBoot 機能を追加出来る、ソフトがあります。

色々のLinux ディストリビューションをUSBメモリに入れて、動かすのは、
面白いですよ・・・

投稿日時 - 2014-04-21 11:21:57

お礼

 R2011T様、助言ありがとうございます。リンクはわかりやすいですね。ただ、私のミスで、ターゲットドライブがDであったとは・・。こんな不注意な輩は私だけなのでネット検索してもなかったのかもしれません。
 また宜しくお願いします。

 教えていただいたUSB立ち上げ、まずは14.04で試してみます。

投稿日時 - 2014-04-21 23:09:20

あなたにオススメの質問