こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

iPhoneアプリ開発

MacBook CoreDuo 2.0GHz/1GB/120GB/DVDCombo/BT/AM/MA255J/A

OS X 10.6.8


上記のPCにXcodeをインストールして、アプリの開発の練習をしたいです。


Xcode 3.2.6 and iOS SDK 4.3 for Snow Leopardを上記のPCにダウンロードしましたら、

数分使えたのですが、少ししましたら問題が発生したためXcodeを開くことができません。
と出てしまいました。


上記のPCに合う、Xcodeのバージョンを教えて頂けないでしょうか?


よろしくお願いいたします。

投稿日時 - 2013-08-13 09:24:01

QNo.8217537

すぐに回答ほしいです

質問者が選んだベストアンサー

>上記のPCに合う、Xcodeのバージョンを教えて頂けないでしょうか?

お入れになったXcode 3.2.6が最適バージョンです。
「Apple ソフトウェア・インストーラ・アップデート 1.0(参考URLからダウンロード出来ます)」は
インストールされていますでしょうか?
Xcodeを一度アンインストールして、インストーラアップデートを入れてから、Xcodeを再度インストールしてみてください。

投稿日時 - 2013-08-13 09:56:35

お礼

ご回答ありがとうございます!

回答いただきました以下の意味が私の知識不足のため、わかりません。

詳しく教えてください。

よろしくお願いいたします。

「Apple ソフトウェア・インストーラ・アップデート 1.0(参考URLからダウンロード出来ます)」は
インストールされていますでしょうか?

投稿日時 - 2013-08-13 11:27:35

ANo.1

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(3)

2013年9月の時点で、Xcodeは、4.6.2あたりが現行版です。これは、Mountain Lionでないと動きません。

なお、Xcode5が、有料登録開発者向けにプレビユーで出ていますが、これは、1月以内に、リリース版になるものと思われます。
OSは、やはり、Mountain Lionでないと動きません。

Xcode 4.0が、リリースされたのが、2010年6月で、それで、3.2.6は、お蔵いりになりました。

 今日、 Xcode 3.2.6が、どうのこうの、というのは、Xcodeの進化の歴史を書く、歴史家ぐらいのもので、
ほとんどの人は、そんな古いツールは使っていません。のみならず、そういう古いツールは、新しいiOSを
サポートしておらず、Objective-Cも古いままなので、あなたの投資する時間のかなりは、無駄になるでしょう。

 不幸なことに、 MA255では、これ以上のOS-Xのアップデートはできないようですが、xcodeでソフトウェアを開発するのであれば、たとえ練習でも、古い機械で古いツールを使うのは、おすすめできません。

投稿日時 - 2013-09-05 20:52:19

ANo.2

#1です。
失礼しました。
URL添付し忘れてましたね・・・
こちらから「Apple ソフトウェア・インストーラ・アップデート 1.0」をダウンロードの上インストールしてください。
http://support.apple.com/kb/DL1512?viewlocale=ja_JP&locale=ja_JP

投稿日時 - 2013-08-13 12:24:45

補足

アンインストールができないです。

ターミナルに
sudo /Developer/Library/uninstall-devtools --mode=all
と入れたら、not found となってしまいました。

アンインストールの方法を教えていただけないでしょうか?

よろしくお願いいたします。

投稿日時 - 2013-08-15 22:26:33

お礼

ありがとうございます!

帰宅後に行ってみます。

投稿日時 - 2013-08-13 12:46:54

あなたにオススメの質問