こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

Aviutlでx264出力をしようとするとエラー

aviutlの拡張編集を使って動画を編集し、いざmp4(x264)にて出力しようとすると

-----------------------------------------------------------
アドレス"0x76a4b727"で例外"0xe0434f4d"が発生しました

発生モジュール:KERNELBASE.dll
オフセットアドレス:0x0000b727
備考:OUTPUT_PLUGIN_TABLE::func_config()[拡張 x264 出力(GUI) Ex]

正常な動作が出来ない可能性がありますが処理を継続しますか?
-----------------------------------------------------------

といった内容の表示が出て止まってしまいます。
同様のエラーはぐぐったらいくつかヒットしたのですが


解決策(1).NET Framework 2.0 Service Pack 2がインストールされていない
→当方window7のためNET Framework 2.0および3.5が最初から入ってる
(バッチファイルにて確認ずみhttp://www.atmarkit.co.jp/ait/articles/1210/26/news086.html

解決策(2)DirectShow File Readerのプラグイン優先度を一番下にする
→一番下にしても、そもそもDirectShow File Readerを使わずL-SMASH works File Readerにしていても同様に発生

解決策(3)Wavelet系のプラグインを消す
→Waveletが何かわからず対処していない


当方スペック
OS:windows7 64bit
メモリ:8GB
CPU:AMD A10-6700 APU with Radeon(tm) HD Graphics 3.70GHz
GPU:ASUS HD 6670

撮影環境
Bandicam1.8.9.370
ビデオ:MPEG-1(VBR)
Full Size, 30.00fps, 80q
オーディオ:MPEG-1 L2
48.0KHz, Stereo, 192kbps

http://nicowiki.com/aviutl_h264.html#a4ca08e0 を参考に
Aviutl ver 10.0
・拡張 x264 出力(GUI) Ex
→x264guiEx_2.01v2を入れました

・Microsoft Visual C++ 2008 SP1 再頒布可能パッケージ (x86) / (x64)
Microsoft Visual C++ 2010 再頒布可能パッケージ (x86) / (x64)
→OS64bitですが一応全部入れました

・x264CLI(x264.exe)
→windows x86-64 - 8bitを入れました

・Nero Digital Audio 1.5.4.0
→NeroAACCodec-1.5.1を入れました

・L-SMASH Works
→L-SMASH_Works_r661_plugin-setを入れました

・ResizeFilter (11/10/20)
→ResizeFilter_111020を入れました

・UVダウンサンプリングフィルタVer1.0.0
→入れていません

・MPEG-2 VIDEO VFAPI Plug-In 0.7.8(12/12/29)
→m2v_vfp-0.7.8を入れました

・DirectShow File Reader プラグイン for AviUtl 0.26a
→ds_input026aを入れました(競合しているのかと思い抜いても試しました)

・MP4Pluginミラー→*
→入れていません

以上の設定で行っています。
どなたか回答よろしくお願いしますm(_ _)m

投稿日時 - 2013-08-11 13:17:15

QNo.8215122

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

2人が「このQ&Aが役に立った」と投票しています

回答(1)

ANo.1

>発生モジュール:KERNELBASE.dll

サンプリングレート(上げると音質が良くなるかと192kHzに)を、24bit 48kHzでキャプチャし直したら正常にエンコード出来た事例。
参考URL

参考URL:http://rigaya34589.blog135.fc2.com/blog-entry-346.html

投稿日時 - 2013-08-11 14:58:27

補足

回答ありがとうございます。
編集元になる動画の音のレートをいじって撮影しなおしという意味でよろしいでしょうか。
動画を張らずに何もない状態で出力しようとしても発生するため、元の動画を取り直しても改善しないと思います。

投稿日時 - 2013-08-11 16:34:53

お礼

自己解決致しました。
結局x264guiEXではだめだったため、MP4Pluginに同封されている古いx264gui(EXではないもの)を使用したところエラーなく設定・エンコードができました。

お騒がせしました、回答いただきありがとうございました!

投稿日時 - 2013-08-11 21:25:47

あなたにオススメの質問