こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

eclipse android

eclipseでandroidのアプリの開発を考えております。
参考サイトを読みながら、installer_r20.0.3-windows.exeをインストールし、eclipseの新規ソフトウェアのインストールからandroidを導入するため、リポジトリーの追加にて、
名前:android
ロケーション:ttps://dl-ssl.google.com/android/eclipse/(ttp://dl-ssl.google.com/android/eclipse/も試しました)
としましたが、エラーになります。
どうしたら上手くいくのでしょうか。

関係あるかわかりませんが、PATHの環境変数は、
C:\Program Files (x86)\Java\jdk1.7.0_09;%JAVA_HOME%\bin
としてあります。
C:\androidsdk\tools;C:\androidsdk\platform-tools;
にするとeclipseが起動しなくなりました。

全くの初心者のため、わからないことだらけです。
調べれば分かることなのかもしれませんが、どなたか教えていただけると助かります。

投稿日時 - 2012-11-13 20:57:20

QNo.7796226

困ってます

質問者が選んだベストアンサー

先ほど確認してみましたが、更新のアドレスを以下にしてアクセスしてみてください。

https://dl.google.com/eclipse/plugin/4.2/

また、4.2をお使いなら、事前に以下のっ更新アドレスにアクセスして本体のアップデートを確認しておいてください。

http://download.eclipse.org/eclipse/updates/4.2


それとPATHですが、C:\Program Files (x86)\Java\jdk1.7.0_09;%JAVA_HOME%\bin……って、ちょっと変ですよ? そもそも、C:\Program Files (x86)\Java\jdk1.7.0_09のパスが%JAVA_HOME%に設定されているはずで……。JAVA_HOME変数はちゃんと用意されていますか? であるならば、JDKのパスは不要と思いますが、そのへんちゃんと確認しておいたほうがよいでしょう。(それと、PCは64bitなのにJDKは32bitを使っていますか? このへんも確認したほうがいいですよ)

また、現在はAndroidの開発ツールをインストーラでインストールしたら、PATHの設定など自分で行う必要はないはずですよ。どうも古いバージョンの情報などがごっちゃになっているような気もします。

投稿日時 - 2012-11-17 17:20:41

お礼

ありがとうございます。
サイトなどを参考に進めていたつもりでしたが、きちんと理解できていなかったようです。
確認してみます。

投稿日時 - 2012-11-25 20:08:48

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.2

そりゃttp://なんていう書き方では繋がらないのは当たり前。

それとそれで繋がらないならADTそのものはzipでも配布されているしSetting Up the ADT Bundleも配布されているし
質問者はまともに公式サイトすら読まないの?

投稿日時 - 2012-11-15 01:51:47

補足

いずれもhttp://として入力しましたがつながりませんでした。
コピペしたので中途半端になったみたいです。
投稿する際の確認不足でした。

投稿日時 - 2012-11-15 20:54:12

「エラーになります」とありますが、どういうエラーですか。開発関係では、「エラーになります」ではなく、実際に出たエラーメッセージをペーストするようにしてください。でないと具体的な状況がつかめませんので。

もし、何かのパッケージが足りない、というようなエラーだとしたら、事前にEclipse本家サイトのアップデートをすべてかけておいてください。ソフトウェアの更新で、

http://download.eclipse.org/releases/バージョン名

こういうアドレスの項目があるはずです(バージョン名には、使っているEclipseのバージョンの名前がはいります)。eclipse.orgのものをすべてアップデート&インストールされていればインストールできるようになると思います。

それ以外のエラーが出ているとすると、状況がわからないのでなんともいえません。


それと、PATH環境変数は書き換えちゃダメです。あれは追記するものです。既にある値に新しい値を付け加えるだけです。既にある値を消してしまうと、必ずインストールされているどれかのプログラムに不具合が生じます。

投稿日時 - 2012-11-14 08:07:14

補足

ご回答いただきありがとうございます!

リポジトリーの追加で、名前とロケショーンを入力後OKを押すと、
作業対象の欄に赤バツ丸が表示され、「ロケーションは絶対パスでなければなりません」とメッセージが出ます。
また、名前・バージョン欄には「選択されたサイトがありません」と表示されます。

PATH環境変数は書き換えちゃだめなんですね、ありがとうございます。
では、
C:\Program Files (x86)\Java\jdk1.7.0_09;%JAVA_HOME%\binC:\androidsdk\tools;C:\androidsdk\platform-tools;
とするのが正しいのでしょうか。

ソフトウェアの更新ですが、Eclipseのヘルプから更新をかけようとしたのですが、「更新の確認」ならありました。実行すると、「No updates were found」とメッセージがでます。
また、現在のバージョンは、
Version: 4.2.1
Build id: M20120914-1800
となっています。

色々書いてしまい申し訳ありません。
よろしくお願いいたします。

投稿日時 - 2012-11-14 20:33:47