こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

【Windows7】インターネットアクセスなし

症状
右下のネットワークアイコンがインターネットアクセスなしと表示されて!マークが出る。
この状態では、外部から当該PCにアクセスできず、当該PCからLANおよび外部ネットワークに接続できない。

この症状は、ネットワークアダプタを再起動(→無効→有効)することによって一時的に改善される。

一時的に改善されるが、数十分~3日の間でインターネットアクセスなしになる。

同一LANネットワークにて他PCは正常に運用されている。
他PCは全てWInXP機。

当該PCは
OS:Windows7 ulimate 64bit

IPアドレスはサーバを運用しているため固定

確認したこと
同一LANポート、ケーブルにて他PCは正常動作。
したがってネットワーク機器の異常ではない。

ウィルスソフトとの相性が原因であるとの情報もあるので
ウィルスソフトの停止
当該PCにはAVAST!がインストールされている

Windowsファイアウォールの停止

ネットワークインターフェースカード(NIC)の省電力機能の停止

ネットワーク関連処理のNICによるCPUの代替処理の停止
例:○○○オフロードを無効に設定→ネットワークカードの構成の詳細に設定項目が4つくらい存在

NICの交換(始めはオンボードのものを利用していました)

全て試しましたがダメでした。。。。
サーバを運用しているのでネットワークの切断がこうも頻発すると使い物になりません。
ネットで調べてみた限りでは根本的な解決方法は見つかりませんでした。
因みにデフォルトゲートウェイに0.0.0.0は追加されたりはしていません。

どうか、解決方法をご教示ください。
お願いします。

投稿日時 - 2012-10-22 10:34:54

QNo.7760518

すぐに回答ほしいです

質問者が選んだベストアンサー

LANのドライバがおかしいか、LANアダプタの故障を疑います。
他のLANアダプタを増設して動作確認するんが良いと思いますね。

投稿日時 - 2012-10-22 10:49:12

補足

上述したように
LANアダプタはオンボードのものから増設のものに変更しました。

ネットで調べていると、
この現象はWIN7固有の問題で結構多く報告されています。
ですから、NICカードの不良は考えにくいです。
もちろんWIN7対応のものを購入しましたよ。
ブログで報告されている方で、自己解決された方もいるようですが
どうにも根治したようには思えないんですよね。
ある程度、期間をおかないと発症しない場合もありますので。

投稿日時 - 2012-10-22 11:07:08

お礼

Intel(R) 82579V Gigabit Network Connection

の構成の設定を見直して一定期間障害なく運用できましたので
ここに設定内容を記させていただきたいと思います。

リンク速度タブ
速度とデュプレックス→オートネゴシエーション

詳細設定タブ
TCP/IPオフロードのオプション→IPv6を除きすべてチェック
ギガビットマスタースレーブモード→自動検出

パフォーマンスオプション
・アクティブインターフレームスペーシング→オン
・フロー制御→受信/送信 有効
・割り込み加減率→最大

リンクを待機→オフ
割り込み加減→オン
受信側スケーリング→オン
大量送信オフロードIPv4→オン
大量送信オフロードIPv6→オフ
有線/VLAN→有線/VLAN有効

電力の管理タブ
チェックを全部はずします


特に注意すべきは

詳細設定タブの
「リンクを待機」項目で

リンク速度タブ
「速度とデュプレックス」
はデフォルトで
「オートネゴシエーション」
になっているにもかかわらず

「リンクを待機」項目は
デフォルトで
「自動検出」(または「オン」)になっている点です。

リンクを待機の説明には

速度を自動的に検出、ネゴシエートする設定の
銅製インテルギガビット・アダプターではオフです。

と書いてあります。

投稿日時 - 2012-12-01 15:03:35

このQ&Aは役に立ちましたか?

5人が「このQ&Aが役に立った」と投票しています

回答(10)

ANo.10

>Realtek RTL8169/8110 Family PCI Gigabit Ethernet NIC (NDIS 6.20)
ひょとしてPCI接続ですか? PCI-eでないなら帯域不足でせっかくのGigabit が生かせません。他のPCIスロットを使っている場合は帯域を分け合うので不具合が出やすいです。

>オンボードIntel(R) 82579V Gigabit Network Connection
こちらの方が増設NICよりはるかに信頼性は高い筈ですがマザーの設計にもよります。また82579Vは適切なドライバーが当たりにくいという不具合があるようです。
インテルのHPより最新ドライバーをあててみてください。
インテル® ドライバー・アップデート・ユーティリティー(自動)がうまくいかないなら型番から検索。

できれば インテル Gigabit CT Desktop Adapter EXPI9301CT  に換装することをすすめます。
RTL8169/8110 の3倍くらい(?)の価格しますが・・・PCI-Eに空きがあることを確認
(サーバー用をすすめたいところですが)

>NICの省電力はOFFにしています
コントロールパネルの電源オプションからの設定もOFFにしているということで良いですね(確認)

投稿日時 - 2012-10-23 11:58:00

補足

ご指南ありがとうございます。
NICはオンボードとOSの相性が悪いのかな?とおもい
急場でヤマダで購入したものです。

が、同様の症状が続いています。
不具合(設定等?)が解消されれば、オンボードのものに戻そう
とは考えています。

予算の都合がつけば、いいNICもほしいですね。

インテル Gigabit CT Desktop Adapter EXPI9301CT

ですか。参考にいたします。

投稿日時 - 2012-10-23 15:23:36

ANo.9

とりあえず使用されているNICが何なのか書かれた方がよいかと思います。
「移行前のXPは大丈夫だった」とか「NICを交換し試してみたがダメだった」と書かれても使用されているNICが何か私たちにはわかりませんから。

投稿日時 - 2012-10-22 23:04:53

補足

了解しました

増設
Realtek RTL8169/8110 Family PCI Gigabit Ethernet NIC (NDIS 6.20)

オンボード
Intel(R) 82579V Gigabit Network Connection

投稿日時 - 2012-10-23 03:59:28

ANo.8

No.6です。

>DBサーバ、WEBサーバ運用で数千件のデータをHTML形式で送信する場合が結構あります。

NICの銘柄によっては切れまくります。できればサーバー用のデアルポート以上のNICでチーミング(複数のポートで負荷分散や冗長化)するのがベストだと思います。オンボードや価格の安いNICは不具合が出やすいです。

ハブも一般に量販店で売られているものはトラブルが出やすいです。当方でも特定のHPに接続できなかったり時々著しい速度の低下があったのでブロードコム製IC使用のスイッチングハブにしたらトラブル皆無になりました。
(国産のハブや価格の安いNICはほとんどがrealtek製のICを使ってます→メーカー名で検索すると色々とトラブルが・・・)

>サーバシステム移行前のXP機では異常がなかったのですけど。。。

サーバーとクライアント機では負荷のかかり方が違うと思います。特にWindows7は省エネを考慮したOSですから、その機能に対応していないNICのドライバーでは不具合が出るケースがあります。
それで(6)で提案したように電源オプションでPCI-Eの省エネ機能をオフ(デフォルトはリンク状態の電源管理→適切な省電力になっていると思います)にして様子を見て下さい。

関係なさそうですがビデオカードやドライバーがNICに悪影響を与えていたというケースもあったようです(真偽不明?)

Serverは機能が最小限(サウンドやビデオカードが無い)の専用機とサーバーOSで運用するのが安定性があってベストだと思います。当方も一万円台の安サーバー機にしたらトラブル皆無になりました。

投稿日時 - 2012-10-22 23:00:44

補足

>サーバシステム移行前のXP機では異常がなかったのですけど。。。

説明が不足していました。
以前は、同一システム(DBサーバ、WEBサーバ)をXP(PRO)機で運用していたんです。
試験的な運用でしたがキューブタイプのベアボーンで、
マシンが壊れてしまったため自作で組みなおし、環境を再構築して
データだけ移行しました。
LANネットワーク周りの機材に変更はありません。

NICの省電力機能はオフにしています。

投稿日時 - 2012-10-23 04:08:00

ANo.7

このような場合、ネットワークアダプタを交換(新設)すれば、まず直ってしまうのですが、それも試したのにダメだとすると、
もしかして、PCの外の原因ではないでしょうか。
つまり、繋いでいるスイッチハブが安物で高負荷に耐えられずにおちてしまう。という。
ハブやルーターは外見上正常に見えても、内部的に不具合がある場合がありますよ。
全然普通に機能しているのに、特定の人だけアクセスできないとか。

投稿日時 - 2012-10-22 15:38:06

補足

ほかのPCに繋ぎかえたら平気なんですよねぇ。。。

投稿日時 - 2012-10-22 17:35:11

ANo.6

これだけの情報で判断は難しいのですが以下をお試しください。

電源オプションの詳細設定
PCI-Eの省電力設定をオフにして様子を見てください。

あとNICの銘柄がわからないのですが電力の設定を確認してみてください。
省電力設定をOFF等

serverの運用でしたらNICは信頼性のある銘柄(インテルかブロードコム等)にしたほうが良いでしょう。あとNICのドライバーは本家(Windows updateからでなく)から最新をダウンロードしてください。
経済性の高い(安物ともいう)NICの場合はクライアント利用なら問題がない(分からないだけ?)ですが負荷がかかると問題が出る製品が多いです。業務用serverのNICは価格の桁が違います。

投稿日時 - 2012-10-22 14:01:57

補足

DBサーバ、WEBサーバ運用で数千件のデータを
HTML形式で送信する場合が結構あります。

NICに相当負担かかってますか?

何かりミッターのようなものがあるのでしょうか?

それも含めて、サーバシステム移行前の
XP機では異常がなかったのですけど。。。

投稿日時 - 2012-10-22 17:33:52

ANo.5

そもそもネットワークのエラーログはどうなっているのでしょう、それを見れば何が起きて停止したのかは判るはずですが、PC側、サーバー側に残っているはずなのですが。
あとはPC側でプロセスモニターや、ネットワークモニターなどのツールをつかえばおおよその予想は出来ると思います、サーバーを使っているということなので、サーバーの状況がどうなのかも判らない状態で、判断は無理ではないでしょうか?

投稿日時 - 2012-10-22 13:32:33

補足

エラーログはイベントビューアからみればよいのでしょうか?

イベントビューアの警告では

当事例の発症のためDNSサーバにアクセスできず
いろんなアプリ(NTPやAVAST!)のオンライン情報取得がタイムアウトしている


イベントビューアのエラーでは

Microsoft Antimalware で署名を更新しようとしてエラーが発生しました。
エラーの説明: 更新プログラムを検索中に予期しない問題が発生しました。更新プログラムのインストールおよびトラブルシューティングについては、ヘルプとサポートを参照してください。

が繰り返し報告されています。

投稿日時 - 2012-10-23 04:21:38

ANo.4

難解な問題だと思いますが,とりあえず切り分けのために
service管理の network で始まるserviceをすべて,「開始」,「自動」に設定 -> PC再起動 で様子を見てはどうでしょうか。
改善効果がなければデフォルトに戻してください。
添付画像参照。

投稿日時 - 2012-10-22 12:19:45

補足

ありがとうございます。試してみます。

投稿日時 - 2012-10-22 12:36:20

ANo.3

XPと混在しているからだろうか。

http://weba03.blog96.fc2.com/blog-entry-1136.html

USBの差し込み口やケーブルの場合もあるようだ。
参考まで。

投稿日時 - 2012-10-22 12:07:09

ANo.2

こんにちは

サーバと言うことですから24時間稼働されてますよね?
その状態で不定期にネットワークが切断され、NICの再起動をかけるまでその状態が継続すると言う事ですか?
ネットワーク構成とサーバ機の構成が書かれていないので推測の域をでませんが、
1. サーバ機以外のPCから何らかの攻撃を受けている事は考えられませんか?ファイアウォールのログは確認しましたか?
2. 同様に、サーバに接続している全てのPCについてフルウィルススキャンを行ってみましたか?
3. イベントビュアーにエラーが記録されていないか確認してみましたか?
4. 原因がどうしても突き止められなければBIOSのアップデートも検討してみてください

投稿日時 - 2012-10-22 11:30:30

補足

avast!のログを見る限り、攻撃は受けていませんでした。

投稿日時 - 2012-10-22 11:57:39

あなたにオススメの質問