こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

HPビルダーV9 初期化後のビジュアルサイトビュー

ホームページビルダーV9を使用しています。(OSはwindowsXP SP2)
このソフトにてホームページ(以下、HP)を作成し問題なくアップできていたのですが、別理由でPCを初期化する必要があったため、HPのデータをフォルダごとバックアップしました。
初期化後、再度HPビルダーV9をインストールし、HPデータもPC内に戻しました。そして、ページを更新してアップしようと思い、「ページの公開」をクリックしてビジュアルサイトビューを表示すると、今までと大きく異なる表示になっていました。indexファイルのみが表示されており、そのほかのファイルは全て下の「リンクされていないHTMLファイル」に表示されています。
なぜでしょうか?

今までインターネット上で問題なく機能していたHTMLファイルなので当然すべてリンクでつながっています。実際HPビルダー上でindexファイルをプレビューしてもリンク先に飛ぶことができます。
どうすれば正しい表示にできるでしょうか?
このままアップすればどうなるかもわからなくて困っています。
ちなみにファイルのアイコンにはすべて「*」がついています。(インターネット上にあるファイルは全て初期化前にアップしたもののため。)

よろしくお願いいたいます。

投稿日時 - 2011-11-07 22:09:01

QNo.7119786

困ってます

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.2

・パソコン初期化してビルダーインストール後に、修正プログラムを適用し最新版にしてある
(つまり「ヘルプ」→「バージョン情報」で見ると、Version 9.0.3.0と表示されている)
・ビジュアルサイトでリンクエラーが全く無い(「リンクされていないHTMLファイル」はある)
・「リンクされていないHTMLファイル」のページは、indexファイルと同じフォルダ内に保存されている
(サブフォルダなどはありません、とのことでしたので)

以上全てを満たしているのであれば・・・

サイトを開いている状態でないとビジュアルサイトは表示されないはずなので、
indexファイルのみが「サイト」内のファイルとして認識されているか、
ビルダー内では「サイト」としてできているけれど変な形で認識されているのではないかと思います。

既に 3. サイトを新規作成する
(作成したページを使ってサイトを作成しよう)
の部分は済んでいるとのことですが、
http://www-06.ibm.com/jp/domino01/swhc/esupport.nsf/all/hpb1466
もう一度やり直してみると、どうでしょうか?

サイト名の指定では、別の名前にしておいて、
やり直した新しいほうでビジュアルサイトがきちんと表示されるようになったのを確認してから、
古いほうを削除するとよいでしょう。

ファイル・フォルダ構成が実際にどうなっているのか正確にわかりませんので、
上記のことをやっても上手くいかないかもしれません。

リンクエラーが出ている場合は、
サイトを開いている状態でリンクを貼り直すことで、正常な状態に戻ることがあります。

投稿日時 - 2011-11-14 02:55:02

お礼

新しいバージョンに更新したりと、教えていただいたことをやってみましたが、改善いたしませんでした。
もう公式のサポートも受けられないようですし、新しいバージョンのビルダーを購入した方が早いかもしれませんね・・・
それで同じエラーが出ても公式サポートが受けられますし。


今回はいろいろとご回答ありがとうございました。

投稿日時 - 2011-11-21 21:40:54

ANo.1

パソコンを初期化したことで、
作成したサイトがホームページビルダー内で”サイト”として認識されなくなっていることが原因ではないかと思います。

以下を参考に、サイトを再作成してみてください。

公式FAQ「パソコンを初期化した後にホームページ・ビルダーを再セットアップする方法について」
http://www-06.ibm.com/jp/domino01/swhc/esupport.nsf/all/hpb0939

1. ホームページ・ビルダーをインストールする

2. 今まで作成したデータをパソコンへ戻す
は既に済ませていることと思います。

V9をお使いとのことですが、
「エクスポート」「インポート」でデータを戻したのでしょうか?

「エクスポート」「インポート」機能を使わなかった場合、
3. サイトを新規作成する
(作成したページを使ってサイトを作成しよう)
の部分は、お済みでしょうか?
http://www-06.ibm.com/jp/domino01/swhc/esupport.nsf/all/hpb1466
これをやっておかないと、
パソコンにホームページのデータを戻しただけでは、ホームページビルダー内で”一連のサイト”として認識されなくなることがあります。

「サイト」→「サイト情報を更新」→「サイトの再構築」で、サイトの再構築を行なっても元に戻らない際は、
上記をお試しください。

以前と同じフォルダ構造であれば(パソコンに戻す際、フォルダ構造を前と変えていなければ)これで元に戻ると思います。
前に作った時に、サブフォルダを作っていた際は特にご注意ください。

投稿日時 - 2011-11-08 02:26:24

補足

お返事ありがとうございます。
教えていただいた1~3はインストールした際に一緒にやってしまっているようです。
(サブフォルダなどはありません)。
ですので何も解決しませんでした。

そして「サイトの再構築」を試してみたのですが、
メニューから「サイトの再構築」を選択すると途中でフリーズしてしまいます。(何度やっても出る)。
5分以上待っても解除されず、結局強制終了をする羽目になります。

どうしたらよいでしょう・・・
重ねてよろしくお願いします。

投稿日時 - 2011-11-09 23:02:53

あなたにオススメの質問