こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

[自作パソコン]windows7 急に読み込めなく

こんばんは。

私は自作PCを先日作りまして、現在そのパソコンをサーバーにするべく設定やソフトのインストール等を行っております。


まずはあまり関係無いかもしれませんが、一応自作パソコンのパーツ関係を記載させて頂きます。

形式; Mini-ITX
MB; ASUS AT3N7A-I R2
CPU; Intel Atom 330 (オンボード)
メモリ; SILICON POWER DDR2 800 (CL5) 2G x2枚
HDD; Western Digital バルグ品 2TB
内蔵DVDドライブ; ソフマップで2000円で購入したバルグ品。
PCケース; SILVERSTONE SST-SG05B

という様な構成で作り上げました。



まず症状について書きます。
上記で組んだPCにWindows7 64Bit Ultimateをインストールしました。
その際、毎度毎度「初めてコンピューターを使用するための準備をしています」という箇所で2~3時間程は毎回必ず待たされます。
初めての時は何らかの初期不良か、接続不良かと思いました。

これが終わると後はスムーズに動きます。
ただAdminを表示、ログインできる状態にしてインストール時に作ったアカウントを消す行動をインストする度に毎回設定するのですが、
これを行うと必ずWindows7を起動する際、ロゴが表示されている時間が異常に長く感じるようになりました。

また、2-3日はこの状態でも使っていられるのですが、
これが切っ掛けなのかは分かりませんが、TVと接続しているVGAケーブルを起動中に取り外し、
再起動を行うと毎回エラーが起きて、Windows自体にログイン、
というか、Windowsの全てのデータが消された?ような状態になり、Windows起動出来なくなってしまいます。

VGAケーブルが直接の原因かは不明ですが、とりあえずこの状態にはあきあきしてます。
もしかしたらHDDの初期不良かなと思い、専門の検査ツールを導入し検索しましたが悪い物は一切表示されず。 逆に焦りました。

全くこの辺の事は専門外でして、どなたか専門的に詳しい方がいましたら助けて下さい。
現在もデータが飛び、再インストール中ですがやはり「初めてコンピューターを使用する~」の所で数時間止まります。
その後は問題なさそうですが。。 今にもデータが飛んでしまいそうで怖いです。


またネットで検索していた所、HDDがIDE形式でないとインスト出来ない?という様なブログを見た気がします。。
ですが結局HDDの形式の変更にIDEという文字が見当たらなかったため、
現在はBIOSでAHCIに設定しインストールしております。

またインストールの際は内蔵DVDドライブ (2000円でソフマップで購入したバグク品)を使ってインストールしております。
これも原因の1つなのでしょうか。

もうここまでなってしまうと私の知識では限界です。
どなたか力を貸して頂きたいです。
宜しくお願いいたします。

投稿日時 - 2011-08-30 01:55:21

QNo.6976850

すぐに回答ほしいです

質問者が選んだベストアンサー

>ただAdminを表示、ログインできる状態にしてインストール時に作ったアカウントを消す行動をインストする度に毎回設定するのですが、
自動的に起動するアプリケーションやドライバが最初のユーザープロファイルを使用している気がします。この場合は削除してしまうと動作が不安定になると思います。

>これが切っ掛けなのかは分かりませんが、TVと接続しているVGAケーブルを起動中に取り外し、再起動を行うと毎回エラーが起きて、Windows自体にログイン、
信号が流れているケーブルを稼働中に抜かないでください。DCC等で双方向に通信していると思われますのでデータ欠損などが発生してもおかしくはありません。

HDDの接続形式はシリアルATAでもIDEでも構いませんが、インストール後に設定を変更することは出来ません(正常に起動しなくなります)
内蔵DVDドライブを使用してインストールすることも問題ありません。

投稿日時 - 2011-08-30 02:45:00

お礼

EF_510さま、ご回答ありがとうございます。

>>自動的に起動するアプリケーションやドライバが最初のユーザープロファイルを使用している気がします。この場合は削除してしまうと動作が不安定になると思います。
なるほど。。
やはりどうしても削除してadminでログインしたい場合はどうしたら良いのでしょうか
何か特別な設定が必要になるのでしょうか??


>>信号が流れているケーブルを稼働中に抜かないでください。DCC等で双方向に通信していると思われますのでデータ欠損などが発生してもおかしくはありません。
なるほどー!
やはり急に抜いてはいけないのですね
これが直接に的に影響しているかは、今となっては確認出来ませんが、
少なからず影響していると考え、次回からこのような事をしない様に気をつけたいと思います。


>>HDDの接続形式はシリアルATAでもIDEでも構いませんが、インストール後に設定を変更することは出来ません(正常に起動しなくなります)
変更はしてはいけないという情報は聞きましたが、最悪起動出来なくなってしまうのですねー。。
これも今後とも気をつけていきたいと思います。

投稿日時 - 2011-08-30 12:12:53

ANo.2

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(7)

ANo.7

>>>また、WindowsHomeServerでも動作は確認されているようなので装置にディスプレイを接続しない運用であればHomeServerの方が何かと便利です。
>なるほどー。
>ディスプレイは接続しないでリモート関係で操作したいと考えているのですが、
>Windows7等に比べてWindowsHomeServerはどのような機能があるのでしょうか?
>やはりサーバーOSの方が軽くてサーバー向けに設計されていると思うので、そっちの方がいいのかもしれませんねー。

WindowsHomeServer(以下WHS)は基本的にディスプレイなしで運用します。ただし、自作でOSをインストールするときはディスプレイが必要です。終わったら外してしまって構いません。
Windows7と同じくリモートデスクトップを使用して接続します。Administratorアカウントも最初から有効です。
基本はWindowsServerですが、家庭で使用する際に便利な機能を追加し、不要な機能はばっさり削っています。
基本はファイルサーバとして使用するのですがメディアサーバの機能も持っています。

参考URLの文書に詳しく記載されていますので検討してみてください。

ここまで来たらLinuxなどのOSも選択肢に入れて良いかもしれません。

参考URL:http://download.microsoft.com/download/1/E/F/1EF906C4-8FCE-4FEF-9B62-5CA06601B0DE/WHS2011.pdf

投稿日時 - 2011-08-30 23:01:08

お礼

なるほどー。。

ちなみに先ほどパーティションを20GBに区切ってOSをインストールしてみましたが、
やはりいつもの所で止まってしまいました。

何が原因なんでしょうねー。


WindowsHomeServerですが、少し興味が出て来ました。
ですが本格的なサーバーは初めてでして、
これは基本的に、OSのインストールが終わってしまったらリモートアクセスを導入してそこから操作して使うという形になるのでしょうか?

>>ここまで来たらLinuxなどのOSも選択肢に入れて良いかもしれません。
そうですねー。 Linuxも実は1度個人的に扱った事があります
ですが、やはり基本的にコマンドなので。。 正直自信がないんですよー。


うーん。。 しかし何で「初めてコンピューターを使用するための準備をしています」の所でこんなに時間が掛かるんでしょうか、
HDDは一度 Western Digitalの公式ツールで不良セクタ等を検索を掛けましたが、
一切問題は無かったんですよね、 相性とかもあるのかもしれないしPCはやはり難しいです。

投稿日時 - 2011-08-30 23:31:43

ANo.6

Windows7での事例が多いのであれば…そういったサイトの管理者に
ブログなり、メールなりで相談してみるのも手です。

あるいは、PT2に関わる、スレとかWikiとかを探して
そういうところで相談するほうが、効率的な可能性があります。

まぁ、今更WHSを買い直すというのも癪な話ですから
どうにもならないということになれば、最終手段として
Windowsを使わずに録画サーバーを建てるという手もあります。

うちは、暫定的にAtom330 M/BにPT2を挿して
Ubuntu10.04LTSで録画実験機として動かしていますが…
ソフトウェアの整備は、完全とは言えないし…
手間はかかりますから、オススメできるとは言いませんが
動き出してからは、HDDを食いつぶす事故以外、安定して動いています。

一ヶ月後に分配器を買って2tuner運用に切り替えたのが先週。
未だ分波器は入れていなくて、BSとかは動作検証するしていません。


ともかく、Linuxでも同じようなトラブルが生じるのであれば…
それはハードウェアの問題と考えられるはずです。

まぁ、それを言うと、Linuxをインストールより先に
UbuntuのLiveCDからMemtest86+を実行したり
UbuntuをインストールせずにLiveCDのまま動作させて
ハードウェアの安定動作を確認する手もあります。


たとえば、aftが使われているWD20EARXのパーティション作成を
XP PCで行なった場合には速度低下が知られています。
そういった点で、手違いが無いかも要確認だと思います。

というか、私、先立って2日がかりでWD20EARXの不良セクターチェックをした上で
積ん録用RAID5を構築しました。問題無かったのですが…
そういったテストを行なっていないのであれば、行なうべきです。

うちは、以前の1TBx4のRAIDは2年前後で4基中1基が壊れているので
HDDについては、購入時から運用する間ずっと
いつ壊れても不思議では無いものだと考えるべきだと思います。

低価格で販売されているバルクのHDDというものも
本来は、動作検証を自分で行なってから使う前提で売られているものです。
(工場納入と同等の部品扱いですから、そういうものなのです)

投稿日時 - 2011-08-30 21:59:46

ANo.5

お礼部分に書かれたことを読みましたが、インストール時にPT2は挿したままでしょうか?
もしそうなら、最初は抜いておくことをオススメします。
また、ボード自体があまり頑丈ではない(?)イメージを受けましたので動作中にVGAケーブルを抜き差しするなどは論外です。

また、WindowsHomeServerでも動作は確認されているようなので装置にディスプレイを接続しない運用であればHomeServerの方が何かと便利です。
この場合、Administratorアカウントは最初から使えますので楽になると思います。

Windows7で最初のアカウントを削除した運用はやったことがないので判りかねます。

参考URL:http://nurumayu.way-nifty.com/kame/2009/07/pt2-bs110cs-ea3.html

投稿日時 - 2011-08-30 15:32:55

お礼

EF_510さま 回答ありがとうございます!

実はPT2用に組んだ自作パソコンなのですがPT2はまだ手元に無いんです
買おうと思っているのですが、自作パソコンが思いのほか楽しくそっちにばかり投資してしまいまして。。

>>また、ボード自体があまり頑丈ではない(?)イメージを受けましたので動作中にVGAケーブルを抜き差しするなどは論外です。
やはりそうなんですねー!!
全く無知で、ゲーム機とTVを繋いでいるケーブルを抜く様な気軽な感覚でやってしまいました。
これからは気をつけたいと思います。


>>また、WindowsHomeServerでも動作は確認されているようなので装置にディスプレイを接続しない運用であればHomeServerの方が何かと便利です。
なるほどー。
ディスプレイは接続しないでリモート関係で操作したいと考えているのですが、
Windows7等に比べてWindowsHomeServerはどのような機能があるのでしょうか?
やはりサーバーOSの方が軽くてサーバー向けに設計されていると思うので、そっちの方がいいのかもしれませんねー。

投稿日時 - 2011-08-30 21:34:50

ANo.4

No.3の続きです。
「初めてコンピューターを使用するための準備をしています」という箇所は通常は長くても2~3分程度でしょう。
インストールが終わって最終的に環境をチェックしているだけなので時間がかかるはずはないです。
なぜそんなに長時間かかるのか解りませんが、インストール時にWin7をインストールする領域として30GB程度を作成して、そこにインストールしているわけですよね。
もしも領域を作成しないで2Tバイト全部をWin7インストール領域に割り当てているようでしたら、領域を小さくしてインストールしてみてはどうでしょうか。
---
ジャンパ設定の件は特に何もしていないのであれば通常の使用ですので問題ないです。

投稿日時 - 2011-08-30 14:49:25

お礼

8ive22tyさま、度々回答ありがとうございます!

>>なぜそんなに長時間かかるのか解りませんが、インストール時にWin7をインストールする領域として30GB程度を作成して、そこにインストールしているわけですよね。
思いっきりパーティションも分けず、2TBのHDDに当てていました。。
別のパソコン(HDD 250GB程)で同じディスクを使ってインストールした時はすぐに終わったので本当に不思議に思ったのですが。。

なるほどー。。確かにそれが原因なのかもしれません。。
2-3時間掛かっても、不気味でしたが特に印象的な不具合も無くサクサク動いていたので、
(VGAケーブルの件でデータは飛んでしまいましたが)

今後はもっと視野を広く捉えて行きたいと思います!

投稿日時 - 2011-08-30 21:26:03

ANo.3

> 毎度毎度「初めてコンピューターを使用するための準備をしています」という箇所で2~3時間程は毎回必ず待たされます。

原因は判然としませんが、コンピュータのスピードとは思えません。
その段階で2~3時間待たされるとは、インストール時点から明らかに異常ですね。
---疑問な点がありますので確認です。
(1)BIOS設定で「SATA Mode Select」(デフォルトでは「SATA Mode」)を
「SATA Mode」でインストールしてみても同じように待たされるのですか?。
もちろんWin7の場合は「AHCI Mode」でもかまわないのですが「SATA Mode」でのインストールも試してみましたか。
(2)Western Digital HDDのジャンパー設定などで何か特別の設定をおこなっているということはありませんか。(型番が書いていないのでジャンパの有無などがわかりませんが、ごく一般的な設定で試してみる)
 

投稿日時 - 2011-08-30 08:08:44

お礼

8ive22tyさま、ご回答ありがとうございます。

>>その段階で2~3時間待たされるとは、インストール時点から明らかに異常ですね。
やはりそうですよね、
数時間待てばその後は通常通り起動は出来ますが。。 やはり何らかの不具合がありそうだなー、とは思っておりました。

>>(1)BIOS設定で「SATA Mode Select」(デフォルトでは「SATA Mode」)を
「SATA Mode」でインストールしてみても同じように待たされるのですか?。
一度SATA Modeでインストールを試みましたが、やはりいつもの所で止まってしまうんですよね、

またWindowsXPなど、7以外のOSをインストールする場合は特に異常も無く完了するのですが。。
ですがどうしてもWindows7を使いたいんです。

またバルグ品のHDDですが、型番が「WD20EARX [2TB SATA600]」という物です。
ジャンパー設定とはなんでしょう? 全くその辺無知です。
多分そういった設定は行っていないので、普段はいつも一般的な設定で使っていると思います。

うーん、データ欠陥の原因は何となく つかめたのですが、
やはりインストール時のこの原因はまだ謎なんですよねー。。

投稿日時 - 2011-08-30 13:27:11

ANo.1

>HDDがIDE形式でないとインスト出来ない?
これはXPの場合にAHCIのドライバーが標準では入っていないために起きる現象であってWin7では関係有りません。

問題の解決とは全く無関係ですが、64bitでサーバーとして使うんだったらWindowsHomeServer2011を入れる方が安く上がって高機能です。(実売一万以下)

投稿日時 - 2011-08-30 02:36:15

お礼

nerimaokさま、ご回答ありがとうございます。

なるほど、これはXPの場合なのですね、
ちなみにWindowsHomeServerも検討したのですが、
PT2を使ったテレビサーバーとして使いたいと思っているのです

その場合やはり情報が出回っているのがwindows7等でしたので、7を導入しております。

投稿日時 - 2011-08-30 11:43:36

あなたにオススメの質問