こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

iOS開発に必要な環境

こんにちは、

iOS開発、つまりipadやiphoneなどのアプリの開発に必要な環境についてお尋ねしたいと思います。
使用しているOSは、Leopard(10.5)なんですが、この環境でiOS4(そしてiOS5)用のアプリケーションを開発できますか?Xcode 4はLeopardで動作しますか?それで開発されたアプリケーションはちゃんとiOS4で使えるのでしょうか?

詳しい方がいらっしゃいましたら、教えていただければありがたい。

投稿日時 - 2011-08-02 11:51:45

QNo.6915840

困ってます

質問者が選んだベストアンサー

Snow Leopard(Mac OS X 10.6)以上が必要です。OS X 10.7 Lionがリリースされましたが、まだApple Storeなどで購入可能です。Lionは、Snow Leopardのアップグレードでなければ、インストールできないので、しばらくSnow LeopardとLionの併売は続くでしょう。

開発環境のXcodeは、Snow Leopardで動かせるのが、3.2.6 + iOS SDK 4.3。Xcode 4はLionのみ動作対象です。Lionリリース前、App Storeで、Snow Leopardで動作するXcode 4が600円で販売されていましたが、現在ダウンロードできません。代わりにLion版が無償でダウンロードできるようになっています。

ADC(Apple Developer Connection)
http://developer.apple.com/devcenter/ios/index.action
こちらで、無料会員登録すると、Xcode 3.2.6、Xcode 4いずれも無償でダウンロードできます。

ところでMacintoshの機種はなんですか?Intel CPU搭載のMacintoshでなければ、Snow Leopard、Lionをインストールできず、かつXcode 3以降のインストールもできません。

投稿日時 - 2011-08-02 12:34:05

お礼

やはり、Snow Leopardが必要でした。ありがとうございます。
Intel CPU搭載のMacです。Xcodeをインストールする上、iOS SDKもインストールする必要があるということですよね。わかりました。すでにXcodeに含まれていたと思いました。参考になりました。

投稿日時 - 2011-08-02 14:45:16

ANo.1

このQ&Aは役に立ちましたか?

2人が「このQ&Aが役に立った」と投票しています

回答(1)

あなたにオススメの質問