こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

無線LANが使えません。

今まで使えていた無線LANが使えなくなってしまいました。
CATVでネットに繋いでいて、
デスクトップだけを使うときはCATV会社から与えられたモデムとパソコンをLANケーブルで繋いでネットして、
ノートPCとデスクトップを併用して使う場合はモデムの後に無線LANルーターを入れて、そこからデスクトップにLANケーブルで、ノートPCには無線LANで繋いでネットをしていました。
いつものように2台のパソコンを併用して使うために無線LANルーターをモデムの後に挿入したところ、無線LANが使えなくなっていました。
コレガの無線LANルーターを使っていて、いつも無線LANの調子が悪くてもhttp://192.168.1.1/にアクセスして設定を行えば無線LANも正常に使えるようになるのですが、今回はこのサイトにすらいけません。
ipconfigでIPを調べたところ、グローバルIPとプライベートIPが一緒になってしまっています。
無線LANルーターを介さなければこれで普通だと思うのですが、無線LANルーターを介してもこうなっています。
(ちなみに無線LANルーターを介しても、デスクトップのほうはネットが出来ます。)
無線LANルーターがただ単に故障したのかと思ったのですが、ノートパソコンのほうで接続可能な無線LANネットを表示するという項目には自分のルーターの名前があります。
接続してみると、「限定された接続」とか「識別されていないネットワーク」といった項目が出て、ネットには繋がりません。
無線としての電波は出ているようなので、動いてることは動いてる感じはします。
いつもはこのようなときにはhttp://192.168.1.1/に行って無線LANのパスワード設定画面で保存を押して確定すると限定された接続とかが消えて、ノートパソコンでもネット出来るようになっていました。
でも今回はhttp://192.168.1.1/にも行けませんし(プライベートアドレスが割り振られていないので当たり前ですが・・)以下のことをしても改善されません。
・モデムとルーターの電源を切ってみる。
・有線ケーブルがちゃんと刺さっているかを確認する
・無線LANルーターとデスクトップだけを接続してhttp://192.168.1.1/に行けるか確認する。(出来ませんでした)
・無線LANルーターを初期化する。

一番困ってるのは、無線LANルーターを介しているのにプライベートIPアドレスがちゃんと割り振られていないことなんです。
これさえ割り振られれば設定画面にいけると思います。
パソコン側(特に有線接続しているデスクトップ側)の設定が何か間違ってしまったのか、無線ルーターのプライベートIPを割り振る機能が壊れてしまっているのか、だと思うんですが何か解決法をご存知の方がいましたら、教えていただきたいです。

ちなみに関係あるかわかりませんが、心当たりがあるといえば、デスクトップの電源を切ったときに(今まではスリープとかログオフとかが多かったです)30項目以上の更新をしていたことくらいです。この後におかしくなったような気もします。ちなみにXPです。

投稿日時 - 2011-07-04 14:34:09

QNo.6853578

困ってます

質問者が選んだベストアンサー

・無線LANルーターとデスクトップだけを接続してhttp://192.168.1.1/に行けるか確認する。(出来ませんでした)

この現象からすると、ルータのDHCPサーバ機能に不具合がでたのだと思われます。一番簡単なのは、ご自分でプライベートアドレスを管理なさって、デスクトップPCとノートPCに、それぞれ異なるプライベートアドレス(192.168.1.*:*部分を2~254で指定)で固定で設定することで解決できると思います。ちなみに、他のパラメータは、
サブネット:255.255.255.0
デフォルトゲートウエイ:192.168.1.1(ルータのアドレス)
DNS:192.168.1.1

アドバイスとして、いちいちケーブルの付け替えという面倒なことをせず、デスクトップ1台でご利用されるときも、無線LANルータの配下に接続れば、わずらわしさから開放されると思いますよ。

ちなみに、
>ipconfigでIPを調べたところ、グローバルIPとプライベートIPが一緒になってしまっています。
ひとつのインタフェースに2つのIPアドレスが割り振られることはありません。また、”169”から始まるIPアドレスは、DHCPの要求がタイムアウトして、IPアドレスが自動的に割り振られなかった場合に付与される特殊なIPアドレスです。

投稿日時 - 2011-07-04 15:00:22

補足

詳しい回答ありがとうございました。DNSの欄は優先と代替とあって、優先のほうに上記のDNSを入れて、代替は空白にして試したんですが、ネットに接続できませんでした。
ルータ機能が初期化してもオンにならないので、故障かもしれません・・・

投稿日時 - 2011-07-04 18:09:45

お礼

ルータ機能をオフにした場合のIPアドレスというものを見つけまして、上記のようにやったところ、無線LANも使えるようになりました!ありがとうございました。

投稿日時 - 2011-07-04 19:40:17

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.4

コレガの無線LANルーターという事ですが、型番は何でしょう?
これが一番必要な情報だと思いますけど…

基本は、
1) モデムの電源を切って(コンセントを抜く)しばらく放置
2) 無線LANルーターを、初期化(工場出荷仕様)に戻す。

結構あるのが、2)の失敗。
コレガ製のルーターは、初期化ボタンの長押しの時間がやたらと長いので注意が必要。
マニュアルで確認してください。
※ファームウェアのバージョンでも違う場合があります。
あと、ルーターの設定スイッチも確認してください。
※マルチAP機能ON/OFF、ルータ機能ON/FFのディップスイッチがあると思います。
 マルチAP機能はOFFで、ルータ機能ONになっているか確認してください。
 マルチAP機能はONでもいいですけど、今回は意味がないので、OFFが推奨です。
 ルータ機能は、必ずONです。OFFだと2台目以降は今回の様な現状になります。

通常は、ルーター本体の電源がオンの状態で、背面にある初期化ボタンを15秒以上押し離し
ルーターが再起動し、Status LEDが点滅→消灯になるまで待ちます。
※この際は、なるべくLANケーブルはすべて外してからしてください。

一度ルータの電源を落として(コンセントを抜いて)
LANケーブル等をつなぎ、再度電源を入れて下さい。


それで、有線LANで接続したデスクトップPCから 192.168.1.1 にアクセスして
ログオンできるか試すしかないでしょう。
それでも駄目なら、無線LANルーターの故障という事でしょう。

> ちなみに無線LANルーターを介しても、デスクトップのほうはネットが出来ます。
ちなみにDHCPが壊れていたら、これは標準設定ではあり得ないので
無線LANルーター本体裏のディップスイッチでルータ機能がONになっているか確認した方がよいです。
取り外しや取り付けが多いと何かの拍子に、スイッチがOFFになったという事も考えられます。
ONになっていても、一度OFFにしてから、再度ONにしてみてください。(むろん電源を抜いた状態で…)

投稿日時 - 2011-07-04 17:44:33

補足

説明不足ですみません。CG-WLBARGSXを使っています。
今説明書に記載してあったように初期化してみたところ、ルータ機能がオンになっていると点灯しているランプが消灯になっています。ルータ機能がオフのようですが、オンにするやり方が記載されてないんですよね・・・
初期化したあともこれがオンにならないということは壊れてるのかもしれないです。。
あとコマンドプロンプトでipconfigを実行したところ、一番上のIPアドレスはグローバルIPと同じで、これより下のIPアドレスはすべてfe80::21f・・・のような形になっていたり、2002:db70:d14e・・・のような形になっていたりします。
説明書がhttp://www.corega.co.jp/prod/wlbargsx-u/pdf/wlbargsx_a.pdfです。

投稿日時 - 2011-07-04 18:06:44

お礼

ルータ機能がオフのときのIPアドレスがあったので、それを元にパソコンのIPを固定して、サイトに接続し、ルータ機能をオンにすることで、無線LANを復活させることが出来ました。
大変お騒がせしてすいませんでした!

投稿日時 - 2011-07-04 19:42:03

ANo.2

ルータを初期化いても同じならルータの故障と思います。

投稿日時 - 2011-07-04 14:57:01

補足

結果的にそんな感じがしてきました・・・

投稿日時 - 2011-07-04 18:07:11

ANo.1

無線LANルーターのルーター機能を止めて使ってみて下さい。

投稿日時 - 2011-07-04 14:52:00

補足

たぶんhttp://192.168.1.1/に行かないとルーター機能をオフに出来ないかもしれません・・

投稿日時 - 2011-07-04 17:45:57

あなたにオススメの質問