こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

ubuntu 10.04でのlibgtk2.0

ubuntu 10.04でlibgtk2.0-dev, libxml2-devをインストールしようとしているのですが
端末で

sudo apt-get install libgtk2.0-dev を打つと

パッケージ libgtk2.0-dev はデータベースには存在しますが、利用できません。
おそらく、そのパッケージが見つからないか、もう古くなっているか、
あるいは別のソースからのみしか利用できないという状況が考えられます

というエラーメッセージがでてインストールする事ができません。

sudo apt-get install libxml2-dev でも同様のエラーメッセージが表示されます。

どなたか対策方法をご存知ないでしょうか?

投稿日時 - 2011-07-03 20:36:08

QNo.6852069

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(1)

ANo.1

最初の確認項目は、事前にapt-get updateを行なったか?

前回のupdateから時間が経ることによって
当時のファイルが削除され
新しいパッケージに差し替えられることがあります。

また、たまたまメンテナンスの瞬間に出くわしたり
一時的なリポジトリに不整合がある瞬間に出くわすこともあるかもしれません。

なお、うちの10.04LTS(AMD64)ではインストール済で…
/var/cache/apt/archives/libgtk2.0-dev_2.20.1-0ubunut2_amd64.deb
が存在しています。
またlibxml2-devは、この数分前、普通にインストールできました。

32bit版がどうなっているかは知りません。

投稿日時 - 2011-07-03 22:49:51