こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Sambaで共有フォルダが表示できない

Red Hat 8.0にWindows XP Professionalとの共有設定を下記手順で行いましたが、Windows側に共有フォルダ(tmp)が表示されません。Sambaも起動し、両者をクロスケーブルで接続しています。Windows側のIPアドレスも静的なものに設定し直しました。

1.テキストエディタで[global]セクションのworkgroup = WORKGROUP(Windows側のワークグループ名)に変更しました。

2.Windows側と同じユーザ(feruza)を作成しました(uid=501、gid=501、groups=501)。
設定は、下記URIに記載された方法で行いました。
http://www.nurs.or.jp/~sugi/samba-config.htm

3.パスワードの送信方法を揃えました。

【Windowsのコマンドでipconfigの結果】
Windows IP Configuration

Ethernet adapter ローカル エリア接続:
Connection-specific DNS Suffix:
Autocconfiguration IP Address:192.168.0.3
Subnet Mask:255.255.255.0
Default Getway:192.168.1.1
Ethernet adapter ローカル エリア接続:
Media State:Media disconnected

【Linuxでの/sbin/ifconfig の結果】
eth0 Link encap:Ethernet HWaddr 00:C0:9F:17:35:55
inet addr:192.168.0.2 Bcast:192:168:0:255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:18 errors:0 dropped:0 overruns:0 frame:0
TX packets:26 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:1725 (1.6 Kb) TX bytes:3054 (2.9 Kb)
Interrupt:10 Base address:0xecc0 Memory:fe100000-0

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP BROADCAST RUNNING MULTICAST MTU:16436 Metric:1
RX packets:83 errors:0 dropped:0 overruns:0 frame:0
TX packets:83 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:5363 (5.2 Kb) TX bytes:5363 (5.2 Kb)

投稿日時 - 2011-06-13 21:15:37

QNo.6807429

困ってます

質問者が選んだベストアンサー

サクサク質問閉じるのはどうかと……

>Connection-specific DNS Suffix:
>Autocconfiguration IP Address:192.168.0.3
>Subnet Mask:255.255.255.0
>Default Getway:192.168.1.1

手元のWinXPでは…こんな表示ですが……
>Ethernet adapter ローカル エリア接続:
> Connection-specific DNS Suffix . :
> Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
> Physical Address. . . . . . . . . : 00-24-8C-47-A2-DD
> Dhcp Enabled. . . . . . . . . . . : No
> IP Address. . . . . . . . . . . . : 192.168.1.2
> Subnet Mask . . . . . . . . . . . : 255.255.255.0
> Default Gateway . . . . . . . . . : 192.168.1.254
> DNS Servers . . . . . . . . . . . : 192.168.1.250
> 192.168.1.254
> Primary WINS Server . . . . . . . : 192.168.1.250

IP Addressの前に「auto」なんちゃらとか付いていません。
あと…IPアドレスが192.168.0.3/24なのにゲートウェイが192.168.1.1なんてのは設定おかしいです。
まぁ、どうせゲートウェイは使わないでしょうからヘンでも構わない…かも知れませんけど……。
# ちなみにウチの環境では192.168.1.250がDebianマシン、192.168.1.254は無線LANルータ。
# WINSサーバは…いまいち正しく動いていないような気がしないでもない…。

で……
>Media State:Media disconnected
LANケーブル繋がってない。って言ってますが……
使用しているPC、そこそこ古いタイプ…だったようですのでAUTO-MDIX対応なんてことはない…かと思いますが……クロスとストレート、大丈夫ですか?
# HUB使って普通に2台だけ接続…の方が問題は少ないと思いますけど。

投稿日時 - 2011-06-14 01:20:13

補足

smbアカウントを作成したところ、共有フォルダが表示されるようになりましたが、開こうとすると、

\\Feruza2にアクセスできません。このネットワークリソースを使用するアクセス許可がない可能性があります。アクセス許可があるかどうかこのサーバの管理者に問い合わせてください。

ネットワークパスが見つかりません。

と表示されます。smbアカウントとWindowsアカウント、smbアカウントのパスワードとWindowsアカウントのパスワードは一致させてあります。smbアカウントとWindowsのコンピュータ名、smbアカウントのパスワードとWindowsのコンピュータ名のログインパスワードを一致させようとすると、

Failed to find entry for user feruza03
Failed to modify password for user feruza03

と表示されます。

投稿日時 - 2011-06-23 22:19:43

お礼

回答ありがとうございます。

ゲートウェイ直します。

クロスケーブルを使用しています。Windows同士(XP ProfessionalとVista Business)では接続できています。以前は98Second Edition、2000 Server、XP Professionalも接続していました。

ハブを購入し、試す方向で検討します。

投稿日時 - 2011-06-19 02:14:37

ANo.1

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(1)

あなたにオススメの質問