こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Windows 7が起動しない

自作機で、CPUはintel core i7 950、3GHz、メモリーは24GB、Windows 7、ultimate 64です。

3カ月ほど前に作って今日昼頃まで快調に動いていましたが、昼頃にWordのファイルが壊れ、原因を調べるために、それまで切換器で切り換えていたモニターを直結にしたところ、電源を投入すると「Reboot and select proper boot device or insert boot media in selected boot device and press a key」というメッセージが出てそこで停止して、Windows 7が起動しなくなりました。

どうすればWindows 7が起動するでしょうか。

boot device priorityは
1st boot device CDROM:PM-PIONEER B(パイオニアのBlu-rayドライブです)
2nd boot device SATA:SM-ST31000528(intelのssdです)
3rd bood device removable Dev.
にしています。

CDドライブには何も入れていません。

投稿日時 - 2011-05-20 21:13:17

QNo.6751518

困ってます

質問者が選んだベストアンサー

「select proper boot device 適切な起動ドライブを選択しろ」
って言われてますよね。
「SATA:SM-ST31000528(intelのssdです)」
って間違いですよね。
「優先HDDはSM(セカンダリーのマスター)のST31000528(SeagateのHDD)」
と言っているように思いますが。
intelのssdとSeagateのHDDをつないでいるのですかね。
boot device priorityで設定するのは、
光学ドライブ/ハードディスク(SSD含む)/リムーバブルディスク
の順番です。
複数HDD(SSD)の場合、別項目でHDDの中での順番設定があるのでは。
そこが、「1st Seagate HDD - 2nd intel SSD」なのでは。

普段Blu-rayドライブから起動しないなら
1stをHDD(SSD)にしたほうがよろしいかも。
極微妙に起動が速くなったり、起動トラブルが減ったりするかも。
(まあ、どうでもいいんですけど)

投稿日時 - 2011-05-21 00:59:05

補足

早速の御回答有り難うございます。

>「優先HDDはSM(セカンダリーのマスター)のST31000528(SeagateのHDD)」
>と言っているように思いますが。

すみません。ST31000528は仰るとおりSeagateの1TBのHDDでした。箱を見て書いたつもりだったのですが間違えていました。
これはRAID 0でデータ用ドライブにしています。

osはintel のssd(X25-M、128GB)に入れています。これは2台でRAID 0にしています。

RAIDはLSIのSAS 9240-8iで組んでいます。

>複数HDD(SSD)の場合、別項目でHDDの中での順番設定があるのでは。

すみません。この意味が分かりません。マザーボードはASUSのP6X58D-Eですが、BIOSを見ても別項目でboot device priorityの設定項目があるようには見えません。

と、ここまで書いて念のためにBIOSを開いてみて、驚きました!
最初の質問を書いたときよりもboot device priorityが次のようになっていて、1つ増えて4つになっていました!
1st boot device SATA:SM-ST31000528(上で言ったように、seagateのhddです)
2nd bood device removable Dev.
3rd boot device CDROM:PM-PIONEER B
4th boot device RAID:(Bus 04 Dev 0)

1st~3rdは、最初の質問を書いた後で順番を変えたのですが、その変えた順番どおりです。でも、その末尾に4th boot driveが付け加わっていました!信じられません!
これはどういうことでしょうか。かなりBIOSが不安定になっているということでしょうか。

それと、seagateのhddが「SATA:SM-ST3100052」と「SATA:型番」のスタイルでの表示になっているのに、intel ssdが「RAID:(Bus 04 Dev 0)」と「RAID:()」表示になっているのはなぜでしょうか。

それで、boot device priorityを次のように変更しました。
1st boot device CDROM:PM-PIONEER B
2nd boot device RAID:(Bus 04 Dev 0)
3rd boot device SATA:SM-ST31000528(上で言ったように、seagateのhddです)
4th bood device removable Dev.

このboot device priorityで起動するとうまく行くかと思ったのですが、やはり「Reboot and select proper boot device or insert boot media in selected boot device and press a key」と表示されました。それで、BIOSを開いてみると次のようになっていました。

1st bood device removable Dev.
2nd boot device SATA:SM-ST31000528(上で言ったように、seagateのhddです)
3rd boot device CDROM:PM-PIONEER B(パイオニアのBlu-rayドライブです)

「removable Dev.」は付いていないので1stになっていても関係ない(問題ない)と思うのですが、RAID:(Bus 04 Dev 0)がなくなったこととSATA:SM-ST31000528がCDROM:PM-PIONEER Bより早い順番に上がってきているのが不思議です。

たくさんお尋ねして申し訳ありません。
よろしくお願いします。

投稿日時 - 2011-05-21 02:15:26

お礼

>複数HDD(SSD)の場合、別項目でHDDの中での順番設定があるのでは。
>そこが、「1st Seagate HDD - 2nd intel SSD」なのでは。

これでした!!!
仰るとおりでした!!!
これを直してsave、exitしたら、そのままWindows 7が起動しました。以後、全く問題ありません。

BIOSのBootタブの中に「boot device priority」の他に「hard disk drives」という項目があり、その中が
1st drive  [SATA:SM-ST31000528]
2nd drive  [RAID:(BUS D4 ev 0]
となっていたので、これを
1st drive  [RAID:(BUS D4 ev 0]
2nd drive  [SATA:SM-ST31000528]
にしてsave、exitしたら、そのまま何の問題もなくWindows 7が起動しました。

その後BIOSを開くと「boot device priority」の画面で[RAID:(BUS D4 ev 0]が消えている(存在しない)ということがなく、いつもちゃんと表示されています。しかも、[SATA:SM-ST31000528]は決して現れません。

直りました!!!
これも全て mako2_u 様のお陰です。
ST31000528をintelのssdのRAIDだとか、Windows 7が起動しない原因はCG-PC4KVMだとかとんでもないことを思っていた自分を、あれもこれも、懇切丁寧に、手取り足取りお教えいただきました。

何とか闇から脱出できました。
何と御礼を申し上げていいか分かりません。
本当に有り難うございました。

投稿日時 - 2011-05-21 13:16:33

ANo.2

このQ&Aは役に立ちましたか?

2人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.4

> どうすればWindows 7が起動するでしょうか。
まずは、余計なことをしないでスタートアップ修復を行なって、状況の変化を見てください。
---
Win7は起動しなくてもインストールDVD(または作成済の修復CD)は起動できるわけですから、
diskpartユーティリティで全てのHDD or SSD デバイスにアクセスしてデバイスの状況を確認してみてはどうですか。
その結果、ブートpartitionが解るはずですのでboot情報を作成しなおせば起動するかも。(つまり、上記のスタートアップ修復と同じ作業になりますが・・・)

投稿日時 - 2011-05-21 09:26:53

お礼

スタートアップ修復というのがあるんですね。
今回のトラブルはNo.2の方の御礼に書かせていただいたように何とか解決しましたが、今後何かあった場合の対策の重要な選択肢にスタートアップ修復を入れさせていただきます。
有り難うございました。

投稿日時 - 2011-05-21 13:24:26

ANo.3

No.2です。

>ST31000528は・・・RAID0でデータ用ドライブにしています。
>osはintelのssd・・・これは2台でRAID0にしています。
>RAIDはLSIのSAS 9240-8iで組んでいます。
えっ、RAIDボード積んでるの?
それでintel SSD2台はRAIDボード接続でRAID0?
ST31000528も2台?RAIDボードに?オンボードに?
boot device priorityにSM-ST31000528ってでるんなら、
オンボードに接続(2台?)でRAID0として認識されてなくて
SMの1台だけがRAIDじゃなく単独ドライブで
認識されているってことか?
よくわからん。
>驚きました!
>4th boot drive RAID:(Bus 04 Dev 0)が付け加わっていました!
>信じられません!
いやいや、RAIDボードを積んでいるんだから、
「増えたこと」じゃなくて元の「無いこと」に驚かないと。

要は、RAIDボードを見失っていて立ち上がらないってことでしょう。
RAIDボードの認識が不安定なのが治れば解決しそうですね。
マザーのBIOSが不安定っていうより何かハード的不安定かも。
電源不足とか地震でRAIDボードの挿しとか何かが緩んでるとか。
RAIDボードを挿すスロットを変えてみるのもいいかも(空きあれば)。
マザー自体が不安定ならBIOS設定のリセットかな。
このマザーってCMOS Clear(BIOSリセット)のスイッチとか
ジャンパピンが無いのかな?(マニュアル見ると無さそうだが)
わからなければ電池を10分くらい外してみればリセットされるかと。
そして初めから設定しなおし。
あと電池交換、まあ新しそうなマザーだから関係ないかな。

RAIDボードから起動するなら1stは[RAID:(Bus 04 Dev 0)]で。
マザーBIOSのboot device priorityには
マザーに接続したデバイスしか出てこないです。
マザーに接続したドライブか、
マザーに接続したストレージコントローラ(RAIDボードとか)を選ぶんです。
RAIDボードのデバイスはマザーBIOSで[RAID:(Bus 04 Dev 0)]を選んだ上で
RAIDボードBIOSでRAID構成とか起動順とかを設定するのでは。

以下、余談。
>>複数HDD(SSD)の場合、別項目でHDDの中での順番設定があるのでは。
>すみません。この意味が分かりません。
マザーBIOSで複数HDD(SSD)を認識していると、
[boot device priority]の下に[Harddisk Priority]みたいなのが
現れるのではないでしょうか。
今はマザーBIOSで認識しているのはSM-ST31000528の1台だけだから
表示されていないのかと。

投稿日時 - 2011-05-21 04:01:24

お礼

>それでintel SSD2台はRAIDボード接続でRAID0?

言うのが遅くなってすみません。そうなんです。

>ST31000528も2台?RAIDボードに?オンボードに?

そうなんです。5台、ボードでRAID 0です。データ専用です。
それ以外にST31000528 1台をマザーボードに直結してバックアップ用に使っています。

>SMの1台だけがRAIDじゃなく単独ドライブで
>認識されているってことか?
>よくわからん。

そのとおりでした。マザーボードに直結しているST31000528 1台があることを忘れていました
BIOSの「Boot Device Priority」で「1st boot device SATA:SM-ST31000528」と表示されるのはこの1台のST310005281だったんですね。やっと分かりました。(アー、遅い!!)

>RAIDボードの認識が不安定なのが治れば解決しそうですね。
>マザーのBIOSが不安定っていうより何かハード的不安定かも。
>電源不足とか地震でRAIDボードの挿しとか何かが緩んでるとか。
>RAIDボードを挿すスロットを変えてみるのもいいかも(空きあれば)。
>マザー自体が不安定ならBIOS設定のリセットかな。

こんな風に問題を切り分けていくんですね。とても勉強になりました。
RAIDボードの挿しの確認とRAIDボードを挿すスロットを変えるのはしてみました。
「BIOS設定のリセット」をしても多分直ったんですね。

>マザーBIOSのboot device priorityには
>マザーに接続したデバイスしか出てこないです。

そうなんですか。知りませんでした。
本当に、よくこれで自作機を作ったと思います。でも、一発で完全に動いたんです。ホントです。

>RAIDボードBIOSでRAID構成とか起動順とかを設定するのでは。

これはRAIDのBIOS画面で確認しました。RAID自体は何も問題ないようです。(「ようです」というのは、素人がRAIDのBIOS画面を見て判断したからです。)

>マザーBIOSで複数HDD(SSD)を認識していると、
>[boot device priority]の下に[Harddisk Priority]みたいなのが
>現れるのではないでしょうか。

よくこんなことが分かりますね。でも、全くそのとおりでした。

本当にたくさん教えていただきました。とても勉強になりました。
有り難うございました。

投稿日時 - 2011-05-21 13:30:09

ANo.1

77m

一度CMOSクリアをしてBIOSを設定し直してみてはどうでしょうか?

投稿日時 - 2011-05-20 23:42:18

補足

早速の御回答有り難うございます。

CMOSクリアは知りませんでした。
マザーボードはASUSのP6X58D-EですがASUSにやり方を教えて貰って是非やってみます。
有り難うございました。

投稿日時 - 2011-05-21 02:17:27

お礼

No.2の方の御礼に書かせていただきましたが、何とか直りました。
「CMOSクリア」をしたら、多分同じように直ったんですね。
有り難うございました。

投稿日時 - 2011-05-21 13:18:35

あなたにオススメの質問