こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

動画編集ソフト「AviUtl」でエンコードした際に音がなくなる…

動画編集ソフト「AviUtl」でエンコードした際に音がなくなる…

タイトルの通りなのですが、エンコードすると音が完全に消えてしまいます。エンコードする前は音がちゃんとあります。この動画は自作したものなのですが、44,1kHzでwaveファイルで出力したものを動画と合成させてwmvファイルにしたものです。
AviUtlでも波形は表示されているので読み込んではいると思うのですが、なぜか完全に動画のみのファイルとして出てきます。エンコード設定も以前と同じで行っているのですが・・・。他の症状として、mp4ファイルだけでなくmp4.outというファイルが出るようになりました。諸事情により可能な限り早く適切な回答を求めます。どうかアドバイス、改善方法をお教えください。よろしくお願いいたします。

投稿日時 - 2010-09-30 00:25:52

QNo.6217284

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

2人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.2

Aviutl単体でMP4動画の出力は不可能なはずなので,
何かプラグインを入れているのでしょうか?

私はニコニコ用の動画を
AviutlとFLV or MP4プラグインでエンコードしています.

私の使用しているMP4出力プラグインでは
動画部分を先にエンコードし,次に音声をエンコード,
最後に一つのMP4コンテナに格納する(mux)という動作をしているようです.

質問者様がご使用のプラグインも同様の動作であると仮定すると,
動画部分のエンコード終了後に
音声エンコードの開始に失敗しているか,
音声エンコード後のmuxに失敗しているのでしょう.
(.outファイルは中間ファイルであると思われます)

私の使用しているプラグインは音声エンコードを
Nero AACエンコーダに渡すようになっていました.
プラグインの設定で,外部エンコーダの関連付け,
muxerの設定等を見直してみてください.

ちなみに私は以下のページを参考にMP4エンコードの環境を構築しました.
http://nicowiki.com/aviutl_h264.html

最悪の場合は,このページを参考にして
プラグインを入れなおすのがいいのかもしれません.

投稿日時 - 2010-09-30 14:21:25

お礼

詳しい回答本当にありがとうございました。wave形式からmp3に変換したからか、ひとつだけ間違えていた設定がありそれを直したことでかは分かりませんが解決いたしました。教えていただいたリンクも、また何か問題が発生した場合に参考にさせていただきます。本当にありがとうございました。

投稿日時 - 2010-09-30 20:32:44

ANo.1

Aviutl単体ではwmvファイルの出力は不可能なはずですが…

何かプラグインやコーデックを追加しているのであれば
それについても記載された方が回答を得やすいと思います。

投稿日時 - 2010-09-30 00:34:33

補足

説明不足でした。大変申し訳ありませんでした。変換前の元のファイルがWMVファイルで、aviutlでエンコードした後のファイルはMPEG-4 AVC/H.264というコーデックを使ったmp4ファイルです。ニコニコ動画に一般会員としてアップロードするためにこのソフトを用いて今までアップしておりました。他にも回答をいただくために不足している点がある場合はご指摘お願いします。
先ほどまで「44.1kHz、24bit」のwaveファイルがいけないのかと考え、いったんパソコンで作ったwaveをCDに焼いて、「44.1kHz、16bit」で取り込み挑戦してみました(今までは16bitで成功していたため)が変化ありませんでした。どうかアドバイスお願いします。

投稿日時 - 2010-09-30 06:39:07

あなたにオススメの質問