こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Opensolaris2009.06のzpoolバージョンアップ

Opensolaris2009.06のzpoolバージョンアップ

お世話になります。
Opensolarisのzpoolをバージョン24にアップグレードしたいのですが、

# zpool upgrade
This system is currently running ZFS pool version 14.

となり、バージョン14までしかアップグレードすることができません。
どのような処理を行えばよろしいでしょうか。

何かパッチを当てる必要があるのでしょうが、それらしきものを配布しているサイトがないためこちらで質問させていただきました。

投稿日時 - 2010-09-12 14:47:26

QNo.6177053

暇なときに回答ください

質問者が選んだベストアンサー

Opensolaris2009.06だとZFS 14まででしたね。失礼しました。
それ以上のバージョンが欲しい場合は、http://pkg.opensolaris.org/dev/en/index.shtmlの手順に従い、開発版をインストールしないとダメなのではないでしょうか。

投稿日時 - 2010-09-13 23:32:21

お礼

これでできました。
http://www.genunix.org/dist/indiana/osol-dev-134-x86.***

投稿日時 - 2010-09-16 09:16:52

このQ&Aは役に立ちましたか?

11人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.1

zpoolをアップグレードするコマンドは"zpool upgrade デバイス名"あるいは"zpool upgrade -a" (すべてのデバイス) かと思います。デバイス名をつけない"zpool upgrade"は現在のzpoolのバージョンを表示するだけだと思います。

"zpool upgrade -v"したときに出てくる最大のバージョンはいくつですか?14以上だったら、上記コマンドでアップグレード出来るはずです。
14だったらもっと新しいOpenSolarisを使わないといけないと思います。

投稿日時 - 2010-09-12 18:14:38

補足

回答、ありがとうございます。
言葉足らずで申し訳ありません・・。オプションをつけた時の事を申し上げておりました。
オプションをつけたときの結果は以下になります。

#zpool upgrade -v
This system is currently running ZFS pool version 14.

The following versions are supported:

VER DESCRIPTION
--- --------------------------------------------------------
1 Initial ZFS version
2 Ditto blocks (replicated metadata)
~~
~~
13 snapused property
14 passthrough-x aclinherit support
For more information on a particular version, including supported releases, see:

http://www.opensolaris.org/os/community/zfs/version/N

Where 'N' is the version number.

-aオプションコマンドでも、すべてのデバイスでver.14が適用されている旨のメッセージが表示されます。

OSを更新する必要があると思ったため、pkg image-updateをしたところ以下の結果が返ってきました。

# pkg image-update
このイメージで使用可能な更新は存在しません。

>14だったらもっと新しいOpenSolarisを使わないといけないと思います。
新しいOpensolarisはどこで入手できますでしょうか。
http://hub.opensolaris.org/bin/view/Main/downloads
上記URLからダウンロードできますでしょうか。

お手数おかけしますが、よろしくお願いいたします。

投稿日時 - 2010-09-12 22:32:53

あなたにオススメの質問