こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

LANに接続できません

現在社内でLANを組んでいます。今回、新たに1台追加しようとしたのですがうまく接続できません。どの辺りを確認・変更すればよいのか助言をいただければと思います。

接続できないPC(以下 PC甲)の環境:DELL製 Win98 NICは当初から内蔵されていたものを使用

LANの設定等:スイッチングハブ・リピートハブが混在、PC甲はリピートハブに接続
外部へはルータを使用
DHCP機能は不使用

PC甲に設定したこと:MSネットワーククライアント・プロトコル(TCP/IP、NET BEUI)を追加
TCP/IPのプロパティでIPアドレス・サブネットマスク・ゲートウェイ・DNSを設定
PC名・ワークグループを設定

現在の状況:ネットワーク全体を表示しようとすると「ネットワークを参照できません」とのエラーメッセージ。
PINGを打つと、自身(PC甲)へはリプライがありますが、それ以外はタイムアウト。同じハブに接続しているPCへもタイムアウトになります。


NICのドライバは入れなおしてみました。きちんと接続できているPCからケーブルを挿し直してもダメなのでケーブル・ハブの不具合ではないと思われます。

これだけでは情報不足かもしれませんがご指摘いただければ補足いたします。ヒントだけでもどうかお願いいたします。

投稿日時 - 2003-07-28 17:07:19

QNo.613484

困ってます

質問者が選んだベストアンサー

ご質問内容からすると可能性は、

1)No.1,No.3の方のご回答にあるように、NICとハブ間でのネゴシエーションの問題。
2)NIC自体が壊れている。

に尽きると思われます。
対策は、AUTO -> Manual設定での回避、あるいは別のNICを使うことになります。

あ、もちろんip config で設定の確認はしてありますね?

投稿日時 - 2003-07-28 21:31:42

お礼

設定で回避、できませんでした・・・
スイッチングハブに交換してもダメだったのでやっぱりNICの不具合でしょうか。
そうなるとハブの交換でちょびっとだけ現状が変わったのが不思議です。

ご回答ありがとうございました。

投稿日時 - 2003-07-30 11:06:05

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(6)

ANo.6

NICかな,,,でももう一つの可能性として、何かファイアーウォールソフトがインストールされていませんか?
ping, microsoft network 関係はFWソフトがブロックすることが良くあるので。

投稿日時 - 2003-07-29 20:35:08

補足

ご回答いただいた皆様へ

ご報告が大変遅くなってしまい申し訳ありませんでした。

その後の結果を申しますと、内蔵のNICの使用をあきらめ新しく追加したもので試したところあっけないほど簡単に繋がりました。

お騒がせしました&お付き合いいただきありがとうございました。

投稿日時 - 2003-08-21 17:15:02

お礼

ご回答ありがとうございます。

先の補足にも書きましたが、ファイアーウォールはルータを使っていてソフトは特に入れていないのですよ。ざっと探したところではプリインストールもされていないようですし。

NICがネックだとしたらちょっとめんどくさいことになるのでヤなんですけど、どうやらその可能性が高くなってきました(ーー;)

投稿日時 - 2003-07-30 10:37:48

ANo.5

>NICのドライバは入れなおしてみました。きちんと接続できているPCからケーブルを挿し直してもダメなのでケーブル・ハブの不具合ではないと思われます。
という事なのでハブ側のポート、ケーブルのトラブルは無いということのようですね。

1.他のマシンをそのハブのそのポートに接続した場合、
通信できるかどうかを確認する。

2.そのマシンを他のハブ(可能ならばスイッチングハブ)に接続してみて通信できるか確認する。

1,2両方とも○の場合はNICとハブの相性、
1×2○の場合はハブのポートの不良(あるいは設定ミス:ハブにディップスイッチがついていてポートのモード
を変更できるものの場合)
1○2×の場合はNICの不良
ということでは?

投稿日時 - 2003-07-29 14:55:09

補足

試してみました。

1は○、2は×でした。
ただ、ハブを変えるとエラーは消えて、ネットワーク全体-ワークグループを開くところまではできるようになりました。といっても自分自身だけで他のPCは表示されないのですが。
pingもあいかわらず通りません。
これは一歩前進といって良いんでしょうか(^^;

LANボード、余ってるのあったかなぁ・・・

投稿日時 - 2003-07-30 10:24:55

ANo.3

お疲れ様です。
私の前に経験した内容です。
参考になれば。
hubとnicの規格の通信規格を確認しました。
半二重・全二重・AUTO

解決すると良いのですが、的が外れていたら
シカトして下さい。

投稿日時 - 2003-07-28 18:29:48

お礼

NICの設定をいじっても、規格を自動判別してくれる(らしい)スイッチングハブに変えても解決しませんでした。
どうやらNIC不具合のよかん、、、

>解決すると良いのですが、的が外れていたら
シカトして下さい。

シカトなんてとんでもないです!
今回は残念ながらご回答内容では解決しませんでしたが、今後、チェックできる点が増えました。
ありがとうございました。

投稿日時 - 2003-07-30 11:12:58

ANo.2

 ネットワークがうまくいかない原因は、ほんのちょっとしたことなんだけど、そのほんのちょっとしたことに辿り着くのに、労力を使うんですよね。

 それで、

「MSネットワーククライアント・プロトコル(TCP/IP、NET BEUI)を追加、TCP/IPのプロパティでIPアドレス・サブネットマスク・ゲートウェイ・DNSを設定、PC名・ワークグループを設定

 となるとほぼ完璧のように思います。ただ、ファイアウォールのことは書かれていませんが、その件は大丈夫でしょうか。

 一応、参考URLにネットワークのチェック項目があるので、こちらを参考にされてはいかがでしょう。

参考URL:http://homepage2.nifty.com/winfaq/networkchecklist.html

投稿日時 - 2003-07-28 17:41:37

お礼

>ネットワークがうまくいかない原因は、ほんのちょっとしたことなんだけど、そのほんのちょっとしたことに辿り着くのに、労力を使うんですよね。

ほんと、そのとおりです。今まで社内LANを組むときにもいくつか躓いて、何とか解決して、ってやってきたんですけど、今回はその知識を総動員してもうまくいかなくて、これ以上どこみれってんだよ~(>_<)となってしまいました。

しかも、どうやらNICの不具合というこっちではどうしようもない結果になりそうでさらに ヽ(`Д´)ノウワァァンです

もうちょっとだけあがいてみます。
ご回答ありがとうございました。

投稿日時 - 2003-07-30 10:55:11

ANo.1

NICのドライバの設定でオートネゴシエーションを
無効にして速度をハブの速度に固定してみては?

投稿日時 - 2003-07-28 17:17:07

補足

皆様、いろいろとアドバイスありがとうございます。
再度いじってみたのですがやっぱりダメです。
複数の方からご指摘いただいたネゴシエーションについてもう少し教えていただけませんか。

設定は「ネットワークのプロパティ」の「ネットワークアダプタ」のところで設定すればいいのですよね。それともここから間違ってるんでしょうか・・・

ネットワークアダプタの「詳細設定」の内容は、

802.lp Support:Disable
Down Poll Rate:8
Flow Control:Enable
Media Type:Hardware DEfault
NDIS Driver Version:Auto Serect
Rx Checksum Offload:Disable
Tx Checksum Offload:Disable

となっていました。
この内、Media Typeを「Auto Serect」「10Mb Half Duplex」「10Mb Full Duplex」に変えてみました。ハブが10BASE-T対応(100BASE-T未対応)なので 100Mb Half(Full) Duplex は試していません。
他の項目は意味がわからなかったのでいじっていません。

ほかにどこか変えてみたほうがいいところとかありますか。

ipconfigの確認ではこちらが意図したとおりの設定で表示されましたので問題ないと思います。
ファイアーウォールは、ルータの機能を使っていてXP機以外は入れていません。
今日確認したところ、LANコネクタ脇とハブのアクセスランプは点灯していました。これは少なくともハブまでは何らかのデータが行っているということですよね。
こうなってくるとNICの不具合でしょうか、、、

投稿日時 - 2003-07-29 09:52:39

あなたにオススメの質問