こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

PHPバージョンアップ

PHPバージョンアップ
レンタルサーバにあるPHPのバージョンが古く幾つかの関数が未定義のため
以下の環境にてPHPのバージョンをアップさせたいと思っているのですがどのようにすれば良いのか分かりません。
ご存知の方がいらっしゃいましたらご教授願えませんでしょうか。

OS:CentOS release 5 (Final)

PHP:5.1.6

mysql:Ver 14.12 Distrib 5.0.22

PLESK:psa v8.2.1_build82070918.10 os_CentOS 5

以上、宜しくお願いいたします。

投稿日時 - 2010-08-17 10:24:31

QNo.6115089

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

4人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.4

root権限があると言うことで宜しいでしょうか。
そして、yum環境を構築していると言うことで宜しいでしょうか。
それを前提として、書きます。

wget -q -O - http://www.atomicorp.com/installers/atomic.sh | sh

yum update php

これだけでOKです。

投稿日時 - 2010-10-21 06:56:01

ANo.3

CentOS 5.5 で
普通の repository で
# yum info php
Name : php
Arch : i386
Version : 5.1.6
Release : 27.el5
Size : 5.9 M
Repo : installed
--------------
# yum info mysql
Name : mysql
Arch : i386
Version : 5.0.77
Release : 4.el5_5.3
Size : 7.9 M
Repo : installed
---------------
で、何で mysql が古いのか解りませんが

Utter Ramblings
http://www.jasonlitka.com/
を repository に 追加できるならば
php = 5.2.13
mysql = 5.0.91
に出来ます。

問題は、それが許されるのか
Plesk との関係
この辺が解りません。

Les RPM de Remi - Packages
http://rpms.famillecollet.com/
は、もっと新しい。やってないが。
確か、mysql は、5.1.x
Utter Ramblings くらいまでが
無難なのではないかと思っている。

投稿日時 - 2010-08-18 04:57:39

ANo.2

MySQLのバージョンが低いように思いますが、これはレンタルサーバの仕様でしょうか。
とりあえず、独自のRPMパッケージ等で、PHPのバージョンを5.2.xあるいは5.3.xに上げることができるのであれば、検索すればいろいろ出てきます。
(「centos rpm php 5.2」等で検索)

あとは、レンタルサーバに、上記のことをしても問題無いか確認すべきかと思います。

投稿日時 - 2010-08-17 20:12:14

ANo.1

CentOSならyumが使えるでしょうから、管理者権限を持ってい状態で、
yum update php
とすればPHPはアップデートされると思うのですが、未確認なので間違っていたらすみません。
若干MySQLのバージョンがすごいことになっているのが気になります...

投稿日時 - 2010-08-17 17:21:35

あなたにオススメの質問