こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

apacheが起動しません

本日からLinuxの勉強をはじめて各サーバー関連ソフトのインストールを試みました。
tomcat5.5とapache2をインストールしましたが、tomcatは正常に起動を確認したのですが、apache2が起動してくれません。

ソースからインストールを試みました。
./configureは特にオプションなしで、httpd.confはデフォルトのままです。
ルートでログインしています。

./apachectl start 
を試みると、本来
./apachectl start: httpd started
こうかえってくるのだとおもいますが、
何もかえってきません。

当然、
./apachectl stop
では
httpd (no pid file) not running
となります。

ちなみに
./apachectl configtest
Syntax OK

です。
http://oshiete1.goo.ne.jp/qa973701.html
症状が似ていたのでこちらの記事を拝見し、
1.他に既存のapacheが起動してないか確認(起動していない)
2.#netstat -alt でもhttpは起動していない

以上です。サーバー系は初めての素人ですので、解決の糸口までご協力いただければと存じます。

投稿日時 - 2010-03-23 22:38:15

QNo.5774483

すぐに回答ほしいです

質問者が選んだベストアンサー

エラーログにはなんと出てますか?
エラーログの場所はhttpd.confの「ErrorLog」の行に書いてあります。

投稿日時 - 2010-03-24 09:11:19

補足

回答ありがとうございます。

見たところ、
(70023)This function has not been implemented on this platform: Couldn't create a Thre
ad Safe Pollset. Is it supported on your platform?Also check system or user limits!

とありました。・・・ひょっとしてCentOS3.9だとapache2.3.5は使用できないのでしょうか?

投稿日時 - 2010-03-24 09:45:02

お礼

2.0.63を入れたらスンナリできてしまいました。
原因はわかりませんが、CentOS3.9に対応していなかったのかもしれません。

エラーログの件勉強になりました。ありがとうございました。

投稿日時 - 2010-03-24 10:22:21

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(1)

あなたにオススメの質問