こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

インターネット接続の共有がうまくできません。解決法、原因探索の方法をご

インターネット接続の共有がうまくできません。解決法、原因探索の方法をご存じの方がいらっしゃいましたら、教えていただけませんでしょうか?

状況は下記のようなものです。
サーバ側:
・Windows Vista Business
・PPPoEでインターネットに接続
・上記の接続に関して接続を共有し、クライアント側からの接続制御を可能にする
・クライアント側からの接続要求に対し、ダイアルアップする設定
・有線でルータに接続
・ローカルエリア接続のIPアドレスを192.168.0.1に設定

クライアント側:
・Windows XP Home Edition
・有線でルータに接続
・ローカルエリア接続のデフォルトゲートウェイを192.168.0.1に手動で設定

現状、できているのは下記の通りです。
サーバー側でPPPoE接続を有効にして、サーバ側がインターネットに接続できる状態で、
クライアント側のネットワーク接続の表示において、
サーバ上のPPPoE接続のアイコンは表示されます。

しかし、クライアント側でインターネット閲覧はできず、
サーバー上のPPPoE接続も切断することは可能なのですが、
切断状態から接続状態にしようとすると失敗します。

また、ファイルの共有、プリンタの共有は出来ていますので、
サーバとクライアント間の接続はある程度うまくいっていると考えています。

PC初心者ですので説明が足りない、誤っている点があるかと思いますが、
どうぞ宜しくお願いいたします。

投稿日時 - 2010-03-07 11:00:07

QNo.5731906

暇なときに回答ください

このQ&Aは役に立ちましたか?

2人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.2

手動で192.168.0.1にするとダメなのは仕様のようです。

>ネットで192.168.0.1でないとICSが使えないという記述があったため、
>ルータ自身のIPアドレスも192.168.0.xxxに変更し、
この辺は、ICSが適当に処理しますのでルータのIPはなんでもかまいません。逆に同じにするとルータの管理するIPと衝突する可能性が
あるのでうまくないかもしれません。

投稿日時 - 2010-03-07 15:12:21

お礼

なるほど、IPの衝突の可能性もあるのですね。
大変参考になりました。

どうもありがとうございました!

投稿日時 - 2010-03-07 23:57:08

ANo.1

>サーバ側:
>・ローカルエリア接続のIPアドレスを192.168.0.1に設定
これは手動で行いましたか?
手動で行うとうまくいきません。自動のままでOK

>クライアント側:
>・ローカルエリア接続のデフォルトゲートウェイを192.168.0.1に手動で設定

クライアントもIP,その他自動取得にしてください。

投稿日時 - 2010-03-07 11:50:09

お礼

早速ご回答をいただき、ありがとうございました。

いずれの設定も手動で行っていました。
自動取得にしてサーバ→クライアントの順に立ち上げると、
接続の名前が正しく表示されなかったため手動にしてしまいましたが、
ホームネットワークの設定時に何か誤ったことをしていたのかもしれません。

また、ルータが配布するIPアドレスが192.168.1.xxxだったのですが、
ネットで192.168.0.1でないとICSが使えないという記述があったため、
ルータ自身のIPアドレスも192.168.0.xxxに変更し、
サーバPCに自動配布されるIPが192.168.0.1になるようにしています。

なお、質問後にクライアント側ローカルエリア接続の
DNSサーバアドレスが空欄のままになっていたことに気付き、
サーバPCのIPアドレスを手動で入力したところ
クライアント側PCもインターネット閲覧可能になりました。

ただ、クライアント側から接続を確立することはできないままですし、
手動だと何かと面倒ですのでやはり自動取得でうまくいくよう設定しなおしてみます。

どうもありがとうございました。

投稿日時 - 2010-03-07 12:23:56

あなたにオススメの質問