こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

サブドメインの追加について

サブドメインの追加について

いつもお世話になっております。

サブドメインの追加について質問させていただきます。
この度サブドメインを追加したのですが内容が反映されず困っております。

今までいくつかサブドメインを追加したのと同じ作業手順でやりました。
同じドメインにサブドメインが複数設定されているので、サブドメインは
設定できるはずなのですが・・・

ローカルPCのTCP/IPの設定でDNSにIPアドレスを設定すると表示されます。
なので設定が間違っている可能性がないかと思っているのですが・・・

よろしくご教示お願いいたします。

<環境>
 OS:Red Hat Linux release 8.0

投稿日時 - 2010-01-12 11:20:57

QNo.5587120

すぐに回答ほしいです

質問者が選んだベストアンサー

これはサブドメインの追加でなくて仮想WEBサーバの追加ですね。

IPベースの仮想WEBサーバを追加したいようですが、サーバ本体にIPアドレスを割り当てましたか? apacheの設定だけではIPベースの仮想WEBサーバは構成できませんよ?

IPアドレスは割り当て済み、というのであれば、apacheのエラーログに何か出力されていませんか?

投稿日時 - 2010-01-13 13:09:08

補足

Toshi0230 さん、ご回答ありがとうございます。

t01.*****.com を追加したいのですが。

エラーログをみると以下ようにエラーが表示されています。
[error] [client ***.***.***.***] user ユーザ名 not found: /
ユーザ名は追加済みなのですが。

投稿日時 - 2010-01-14 10:36:10

このQ&Aは役に立ちましたか?

4人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.3

> [error] [client ***.***.***.***] user ユーザ名 not found: /

これは仮想サーバの設定で指定したエラーログファイルに出力された内容ですか?
であればユーザ認証に失敗しているような感じですね。

もしユーザ認証を設定しているのであれば、一度ユーザ認証をはずした状態でテストしてみては?

投稿日時 - 2010-01-15 14:34:03

補足

Toshi0230さん、ご回答ありがとうございます。
とりあえず、違うサーバでサブドメインを設定することで回避できました。

投稿日時 - 2010-01-19 09:41:55

ANo.1

何をどうやって、どのような結果になったから「サブドメインを追加したのですが内容が反映されず」と言っているのか、まったく情報がないため、答えようがありません。

「今までと同じ作業手順でやった」にもかかわらず、今まではできたのに今回はできない、ということであれば、今回の作業手順がどこか間違えていたのでは?としか言えません。

投稿日時 - 2010-01-12 11:59:03

補足

Toshi0230 さん、ご回答ありがとうございます。

複数のサーバで何度も以下の作業手順で設定をしていて、動作しています。
今までの作業が間違っているということでしょうか。

1)ネームサーバ設定
# vi /var/named/*****.com.zone

↓追加↓
n01INAIPアドレス


2)Apache設定
# vi /etc/httpd/conf/httpd.conf

↓追加↓
<VirtualHost IPアドレス>
ServerAdmin webmaster@*****.com
DocumentRoot /home/n01/www
ServerName n01.*****.com
ErrorLog logs/n01-error_log
CustomLog logs/n01-access_log combined env=!no_logging
</VirtualHost>


3)ネームサーバとApacheの再起動

以上です。
もちろん、n01のユーザは作成しています。

よろしくお願いします。

投稿日時 - 2010-01-12 13:13:38

あなたにオススメの質問