こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

AviUtlでx264出力の際にエラーが発生し強制終了してしまいます。

AviUtlでx264出力の際にエラーが発生し強制終了してしまいます。

AviUtlでx264出力の際にエラーが発生し強制終了してしまいます。
AviUtlにてh.264形式でエンコードする際、kernel32.dllでエラーが発生し強制終了してしまいます。
使用OSはWinXP Home Edition、SP3です。
エンコードしたい動画はAmaRecCoで録画したAVI形式の動画になります。

主なやり方はこちらのサイト(http://nicowiki.com/aviutl_h264.html)を見て行いました。
手順としては
1 AviUtlをDL
2 拡張x264出力(GUI)、MP4Plugin、Lanczos 3-lobed 拡大縮小、ResizeFilter、
PEG-2 VIDEO VFAPI Plug-In 0.6.57、DirectShow File Reader プラグイン for AviUtl 0.26a
をDL(いずれも最新版)、必要なモノをAviUtlフォルダ内に移動
3 Microsoft .NET Framework 2.0 Service Pack 2がインストール出来なかった為3.5をインストール(使用パソコンに既にインストール済みでした)
4 Microsoft Visual C++ 2008 SP1 再頒布可能パッケージ (x86)をインストール
5 Nero Digital Audioをインストール、neroAacEnc.exeをAviUtlフォルダ内に追加

以上の準備を終えAviUtl起動し動画を開きプラグイン出力→拡張x264出力(GUI)を選択。
「名前をつけて保存」ウィンドウの「ビデオ圧縮ボタン」を押すとエラーが発生します。

AviUtl:Application Exception
アドレス"0x7c812afd"で例外"0xe0434f4d"が発生しました
発生モジュール:kernel32.dll
オフセットアドレス:0x00012afd
備考:OUTPUT_PLUGIN_TABLE::func_config0[拡張x264出力(GUI)]
正常な動作が出来ない可能性がありますが処理を継続しますか?
はい いいえ

という警告文が出ます。
「いいえ」を選択するとエラーでそのまま強制終了してしまいます。
「はい」を選択すると強制終了は起こらず、そのまま保存を押すとエンコードがはじまるのですが
音声処理が100%で完了かと思いきやまたビデオ圧縮時と同じ警告文が出ます。
この際「いいえ」を選ぶと音声のないMP4にエンコードされていました。

AviUtlをはじめとしたソフトを再度インストールし直したりシステムの復元を行っても直りません。
インターネットで調べてみたところ同じ症例を紹介しているところが全く無く、
手探りではわかりませんでした。
この状況はどうすれば直すことが出来るのでしょうか?
また、kernel32.dllはパソコンの中枢を成すツールと聞きました、現在kernel32.dllが損傷しており深刻な状況なのでしょうか?

長文申し訳ございませんでした、どなたかアドバイスお願い致します。

投稿日時 - 2010-01-11 05:49:49

QNo.5584069

すぐに回答ほしいです

質問者が選んだベストアンサー

んーー
どうも、エラーの原因を調べると、
NET Framework 2.0 Service Pack 2に関係してるみたいなんですよ。
NET Framework 2.0 Service Pack 2は入れなれなくって
3.5を入れたんですよね。

NET Framework 2.0 Service Pack 2 (x86) 日本語 Language Packの
方はいれましたか?

一回、これを見てバージョンを確認してみてください。
http://www.atmarkit.co.jp/fwin2k/win2ktips/246checkvdnfw/checkvdnfw.html

投稿日時 - 2010-01-12 14:56:48

お礼

ご回答ありがとうございます。

ご指摘を受けNET Framework 2.0をインストールすると
AviUtlでビデオ圧縮が出来ました。

同じ原因になった方の為、以下手順↓
調べた結果、すでにインストール済みのNET Frameworkを一度全て削除し
新たにインストールし直せば入るそうです。
削除したところ、NET Framework 2.0を入れることに成功しました。
詳しくはは下記URLを参照ください
http://wordpress.ddo.jp/seji/kiji/387.html
(システムフォルダやレジストリをいじる過程なので、自己責任でお願いします)

また、私の場合インストールできなかったNET Framework 2.0が
プログラムの追加と削除一覧にあり、
どうやら破損していたみたいでそれが原因だったと思っております。

みなさまいろいろなアドバイス有難う御座いました。

投稿日時 - 2010-01-12 19:06:04

ANo.4

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.3

フィルタ類はかけてますか?
GUIでやる場合、あるフィルタを使うと同様なエラーをはくことがあります。
ちなみに、わたしの場合、プラグインはほとんどAviUtlディレクト
直下に入れてます。というかpluginsフォルダというのはありませんが
x264での出力は出来てます。

XP HOME
Microsoft .NET Framework 2.0

投稿日時 - 2010-01-11 22:49:32

補足

ご回答ありがとうございます。

フィルタは全てオフに設定しているので、
フィルタによってエラーが発生してはいないと思います。

投稿日時 - 2010-01-12 13:22:58

ANo.2

私、テストでDLしなおして新規フォルダー内で
テストして見ましたけど、ちゃんと動きましたよ。

添付画像はそのファイル構成です。

で、あまサイト見ててふっと思ったんですけど
X246コーデックのインストの事が書かれて無い気が・・・

あの~念の為なんですけどX246コーデック、
インストしました?

入れてないと当然、エラーでますよ・・・

まだでしたら、
http://www12.atwiki.jp/lunatilia/pages/70.html
x264vfw_r818ex011_20080414_Jpn.exe をダウンロードして
念の為、ウィルススキャンしてから、クリックして
インストしてください。

これでうまくいくはず・・・

投稿日時 - 2010-01-11 22:03:02

補足

ご回答ありがとうございます。

参照画像と同じ配置にし、URLからX246コーデックを
インストールしてみたのですが、
やはり同様のエラーが発生してしました。

スタート→全てのプログラム→x264vfw→x264vfw encoder configuration
で展開しようとするとpthreadGC2.dllが見つからない、
モジュールが見つからないとエラーが起こり起動できません。
なのでpthreadGC2.dllをダウンロードしシステムフォルダに追加したところ、
x264vfw encoder configurationは起動できるようになったのですが、
やはりaviutlでの「ビデオ圧縮」時にインストール前と同じ警告文が出ます。
お手上げなのでしょうか・・・

ちなみに、aviutlの設定→プラグイン圧縮→拡張x264出力(GUI)→設定
を押しても「ビデオ圧縮」ボタン時と同じ警告文が表示されます。

ご回答ありがとうございました。

投稿日時 - 2010-01-12 13:13:43

ANo.1

サイトの解説がちがってますよ。
拡張 x264 出力(GUI)のプラグインは、readme.txtに書かれているように
>x264gui.auo、x264gui.iniの2ファイルを、AviUtlの説明書に従って
>プラグインディレクトリに置いてください。
なんですよ。
AviUtlの下にpluginsフォルダーを作りその中に入れてください。
neroAacEnc.exeはAviUtlのフォルダーでOKです。
配置はこれが基本で、pluginsフォルダーに入れて
動かない場合に、プラグインがあるときだけ
AviUtl直下に置いて試します。

ちなみにAviUtlはプラグインの読み込み順番で、
うまく読み込め無かったりするので環境設定で
順番を入れ替えたりするのですが、私は面倒なので
もう一つAviUtlをAviUtl2とかのフォルダー名にして
入れ、ショットカットをランチャーにいれ、
AVIの場合はこっちでエンコとかしてます。

投稿日時 - 2010-01-11 06:28:08

お礼

ご回答ありがとうございます。

pluginsフォルダを作りその中にx264gui.auo、x264gui.iniの2つのファイルを入れて試したのですが、
やはり「ビデオ圧縮」のボタンを押すとまた同じ警告ウィンドウが表示され強制終了しました。

また、プラグインの優先度なのですが、他のエンコード支援サイトを参考に行っています
http://www18.atwiki.jp/live2ch/pages/165.html#id_7eab82b7)。
アマレココでは「AVI/AVI2 File Reader」を最上位にすると安定するみたいです。
この他の順番でも試してみましたが、結果は変わらず「ビデオ圧縮」が開けません。
根本的に私のパソコンの性能とx264の機能がマッチしていないのでしょうか・・・
最新版以外の拡張x264出力もいくつか試してみたのですが、それも効果が無く・・・

ご回答ありがとうございました。

投稿日時 - 2010-01-11 07:11:44

あなたにオススメの質問