こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

ルーター2台とスイッチングハブの接続方法で困っています。

現在、E-MOBILEでADSLの契約をしています。自宅にあるパソコン5台をすべてインターネットにつなげるようにして、さらに無線LANも使えるようにしたいのですが、接続方法で困っています。できたら、手持ちの機器だけでどうにかしたいのですが、どなたか教えて頂けないでしょうか。また、どうしても買い足さなければならない物がある場合はオススメの機種も教えていただけると助かります。

【所有機器】
ルータ1:MegabitGear TE4571E(E-MOBILEよりレンタル品モデム内蔵)
     LANポート数1
     DHCPサーバ「使用する」
     IPアドレス「192.168.0.1」(初期値)
ルータ2:NEC製 Aterm WB65DSL(無線LANルータ)
     WANポート1・LANポート3
     DHCPサーバ「使用しない」
     IPアドレス「192.168.0.254」(変更)
スイッチングハブ:Logitec製 LAN-SW05/PA
     LANポート5

希望としましては

[ルータ1]------[SWハブ]------[ルータ2]---[PC4]
                ---[PC1]     ---[PC5]
                ---[PC2]     ---[無線]
                ---[PC3]

上記のような構造で接続したいのです。

パターン1:[ルータ1]---[ルータ2]---[PC1]
パターン2:[ルータ1]---[SWハブ]---[PC1]

この2パターンではどちらでも[PC1]はインターネットに接続できるのですが、

パターン3:[ルータ1]---[SWハブ]---[ルータ2]---[PC1]
パターン4:[ルータ1]---[ルータ2]---[SWハブ]---[PC1]

このように間にハブをはさむとインターネットに接続できなくなります。ネットで調べた情報もいろいろ試してみましたが、専門用語が多くよく理解できませんでした。現在は[ルータ1][ルータ2]ともに一度初期化し、DHCPサーバの使用可・不可の設定と[ルータ2]のIPアドレスのみ変更してあります。

ネットワークに関しては全くの初心者でどの設定をいじれば良いのかも解りません。ほかに必要な情報があれば補足で追記していきますので、どなたか詳しく教えていただけると助かります。

よろしくお願い致します。

投稿日時 - 2009-11-17 23:04:25

QNo.5456459

すぐに回答ほしいです

質問者が選んだベストアンサー

 お尋ねの件ですが、NECの無線ルーターの設定自体は適合している印象があり、ADSLモデムに合わせて無線ルーター側のIPアドレスを変更・DHCP機能を無効化、ハブからの配線を無線ルーターのハブポートへ接続すればOKです。
 ただし、ルーターのNAT変換を介した複数台同時接続を認めていないプロバイダも存在しますので、それが気になる点ですね。
 あと、PC側のセキュリティソフト周りの状況が気になるのですが、セキュリティソフトのファイアーウォール機能での制限、PCのコントロールパネル配下ネットワーク接続、ローカルエリア接続のインターネット接続(TCP/IP)の設定がDHCP自動取得、DNSも自動取得になっているかどうかですね。IPV6Prefix等インストールされていれば無効化して下さい。

投稿日時 - 2009-11-18 09:38:52

補足

早速の回答、ありがとうございます。

ADSLモデム(兼ルータ1)のIPアドレスは192.168.0.1なので無線ルーター側のIPアドレスは192.168.0.254にしました。この設定で
[ルータ1]--[ルータ2]--[PC1]ではつながるのでIPアドレスは大丈夫だと思うのですが。またルータ1のDHCP機能は有効に、ルータ2のDHCP機能は無効に設定しました。PC1のTCP/IPはIPアドレス・DNSともに自動取得になっています。IPV6Prefixというのは見当たらないので多分インストールされていないと思います。……が、

[ルータ1]--[ハブ]--[ルータ2]--[PC1]
[ルータ1]--[ルータ2]--[ハブ]--[PC1]

どちらの構成でもつながりません。
「インターネットやネットワークリソースにアクセスできない可能性があります。ネットワークでコンピュータにネットワークアドレスが割り当てられなかったことが原因です。」と表示が出ます。詳細を見るとIPアドレスが167.254.174.202、ネットマスクは255.255.0.0、デフォルトゲートウェイとDNSサーバーとWINSサーバーは空白です。

ファイアーウォールの設定がよく分からないのですが、セキュリティソフトではなくWindowsファイアーウォールを使っているようなのですがその設定の問題なのでしょうか。

投稿日時 - 2009-11-18 21:25:29

お礼

回答ありがとうございました。
結局、古い無線ルーター(Aterm)を買い換えることにしました。問題は解決しませんでしたが、皆さんのおかげで試すべきことは試したと納得して買い替えができます。ありがとうございました。

投稿日時 - 2009-11-23 14:15:48

このQ&Aは役に立ちましたか?

3人が「このQ&Aが役に立った」と投票しています

回答(6)

ANo.6

[ルータ1]--[ハブ]--[ルータ2]--[PC1]
[ルータ1]--[ルータ2]--[ハブ]--[PC1]

接続方法はどちらでも良いですが、[ルータ2]のDHCPを無効化・ローカルIPアドレスを192.168.*.254(*)は[ルータ1]にあわせる。(0)かな
[ルータ2]のWANポートは使わない。これでいけるはずです。

LANケーブルですが、8極4芯の仕様ですから、1・2・3・6の結線だけチェックして下さい。
残りの結線が切断していても問題ないです。
(Logitec-HUBが100BASE-TXだから、全結線で無くて良い。)
工具があれば、LANコネクタを付け直すだけで直る可能性大。

以前、ADSLルーター2台で接続成功しています。<ここのQ&Aで。。。
http://dell-support.okwave.jp/qa5266396.html これかな。。。

         

投稿日時 - 2009-11-22 03:19:12

お礼

回答ありがとうございます。
[ルータ1]のDHCPを有効にIPアドレスを192.168.0.1、[ルータ2]のDHCPを無効にしてIPアドレスを192.168.0.254に設定しました。その状態でWANは使わずにLANポートで接続しましたがやはり繋がらないようです。
結局、スイッチングハブを変えても効果がなかったので、無線ルーター(Aterm)を買い換えることにしました。問題は解決しませんでしたが、皆さんのおかげで試すべきことは試したと納得して買い替えができます。ありがとうございました。

投稿日時 - 2009-11-23 14:38:01

ANo.5

 追加補足拝見しました。スイッチングハブの相性若しくは、LANケーブルの内部結線の問題が考えられますが、無線ルーターとハブ、ハブとPCのLANケーブルの結線テストをしてみると良いかもしれません。
 ごくたまに、LANケーブルの8芯の内、一部ショートしていたりすると接線不良を起こす為、ハブとの接続に問題が出る場合もありますよ。
 LANケーブルの端子部を交換し、かしめ直すと良いかもしれませんよ。
 基本的にLANケーブルは、最低限4芯の結線が合っていれば通信上問題ないケースが殆どですが、ハブとの相性で8芯ケーブルの場合には全て結線上適合しなければ問題が出る場合も多いですよ。

投稿日時 - 2009-11-19 20:31:36

補足

面倒な問題に付き合っていただいてありがとうございます。

LANケーブルは予備にある何本かを入れ替えて試してみたのですが、ダメでした。スイッチングハブとの相性なのでしょうか。
最近スイッチングハブも安くなっているみたいなので、新しいのを購入して試してみます。

数日ほどかかりますが、結果はまたご報告致します。
お付き合いありがとうございました。

投稿日時 - 2009-11-19 21:28:45

お礼

回答ありがとうございました。
結局、LANケーブルもスイッチングハブを変えても効果がなかったので、無線ルーター(Aterm)を買い換えることにしました。問題は解決しませんでしたが、皆さんのおかげで試すべきことは試したと納得して買い替えができます。ありがとうございました。

投稿日時 - 2009-11-23 14:27:19

ANo.4

ちなみに、

パターン4:[ルータ1]---[ルータ2]---[SWハブ]---[PC1]

の構成でルータ2の余っているポートにPC2等をつけたときに、PC2は通信できてPC1が通信できない状態ですか?
また、この構成でSW-HUBにPC3等をつないだ場合、同じSW-HUBにつながっているPC1とPC3間はpingが通りますか?
もしそうだとすると、これまでのパターンからルータ2とSW-HUBが接続されているときだけ通信ができないので、ルータ2とSW-HUBの接続の相性問題に見えてしまいます......
10年ちょっと前の100BASE-TXが出始めのころは相性問題もたまにあったんですが、最近の機器ではほとんど起こることはないんですけどね

投稿日時 - 2009-11-18 21:41:42

補足

続けての回答ありがとうございます。

[ルータ1]---[ルータ2]---[SWハブ]---[PC1]

ご指摘のとおり、上記の構成で[ルータ2]に[PC2]をつないだ場合、[PC1]は通信できず、[PC2]は通信ができます。
また、[SWハブ]に[PC3]を追加してpingを打ってみました。(pingというものも今まで知りませんでしたのでやりかたが合っているか不安ですが…)
まず、[PC3]のTCP/IPでIPアドレスを192.168.0.3、ネットマスクを255.255.255.0に指定して、[PC1]のコマンドプロンプトから192.168.0.3に向けてpingを打ちました。が数回繰り返して一度も返ってきませんでした。

今まで考えもしませんでしたが、機器の相性や故障の可能性もあるんでしょうか……。確かに[ルータ2]のWarpsterWB65DSLは大分古いモノなのでそういうこともあるかも知れませんね…。
もう少し試してみてダメだったら、機器の買い替えも検討してみます。

投稿日時 - 2009-11-18 23:51:24

お礼

回答ありがとうございました。
結局、スイッチングハブを変えても効果がなかったので、無線ルーター(Aterm)を買い換えることにしました。問題は解決しませんでしたが、皆さんのおかげで試すべきことは試したと納得して買い替えができます。ありがとうございました。

投稿日時 - 2009-11-23 14:24:30

ANo.2

[ルータ2]をHubモードにして、パターン4の接続で行けると思います。
参考URLのPDF:8-28ページ「8-4 HUBとして使う」を確認ください。

参考URL:http://121ware.com/product/atermstation/lib/warpstar/7585_torisetu4.pdf

投稿日時 - 2009-11-18 02:08:13

補足

早速の回答ありがとうございます。

ご指摘の通り、ルータ2をHUBモードにして接続してみました。
……が、やはりつながりません。
[ルータ1]--[ルータ2]--[ハブ]--[PC1]
[ルータ1]--[ハブ]--[ルータ2]--[PC1]
どちらもつながりませんでした。

「インターネットやネットワークリソースにアクセスできない可能性があります。ネットワークで、コンピュータにネットワークアドレスが割り当てられなかったことが原因です。」との表示で、詳細を見ると、IPアドレスが167.254.174.202、ネットマスクが255.255.0.0、デフォルトゲートウェイとDNSサーバーとWINSサーバーは空白になっています。
[ルータ1]はDHCPサーバを使用するようにしているのですが、ハブを通すとうまく動いていないみたいです。

投稿日時 - 2009-11-18 20:54:30

お礼

回答ありがとうございました。
結局、古い無線ルーター(Aterm)を買い換えることにしました。問題は解決しませんでしたが、皆さんのおかげで試すべきことは試したと納得して買い替えができます。ありがとうございました。

投稿日時 - 2009-11-23 14:12:31

ANo.1

ルータ2のWANポートを使用せずにLANポートだけを使うようにしたらどうなりますか?

投稿日時 - 2009-11-17 23:31:32

補足

さっそくお眼に留めていただいてありがとうございます。

どのパターンでもWANポートは使用していません。WANポートを試してみたこともありますが、繋がったことがないので。

投稿日時 - 2009-11-17 23:37:53

お礼

回答ありがとうございました。
結局、古い無線ルーター(Aterm)を買い換えることにしました。問題は解決しませんでしたが、皆さんのおかげで試すべきことは試したと納得して買い替えができます。ありがとうございました。

投稿日時 - 2009-11-23 14:09:04

あなたにオススメの質問