こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

LinuxにJ2EEのインストール

LinuxにJ2EEのインストールが思うように上手くいきません。


# chmod 544 java_ee_sdk-5_08-jdk-6u17-linux-ml.bin
# ./java_ee_sdk-5_08-jdk-6u17-linux-ml.bin

J2EEのbinファイルを格納したディレクトリで、
以上のようなコマンドを打ちました。(root権限を持つユーザで)

しかし、以下のような結果が出力されてしまいました。
2時間以上様子を見ていましたが全く動く気配が無い為、
恐らくエラーになっていると思われるのですが、原因がわかりません。
原因と解決策がご存知の方は教えてください。

------------------------------------
使用可能なディスク容量をチェックしています...
Java(TM) 2 Runtime Environment をチェックしています...
Java(TM) 2 Runtime Environment ファイルを抽出してます...
*** glibc detected *** double free or corruption (!prev): 0x0806df48 ***
一時ファイルを削除しています...

------------------------------------


LinuxのOSはVineの4.2です。
プロジェクトの開発都合上、少し前のOSです。
実際には、Linux(Vine4.2)サーバにJava環境を入れるのですが、
Linuxを操作するのは初めてで、VMwareにLinuxを入れて
インストール方法を勉強中です。

投稿日時 - 2009-11-07 17:59:13

QNo.5429227

すぐに回答ほしいです

質問者が選んだベストアンサー

書き方がまずかったかも知れません
rpm.bin と bin が有ると思います。
rpm.bin の事です。

いずれにしろ、これが影響していると思いますが
これは、良く解りません。
>*** glibc detected *** double free or corruption (!prev): 0x0806df48 ***
// install し直し??

synaptic での install での
java では駄目なのですか。少し古いが

投稿日時 - 2009-11-08 14:44:02

お礼

御回答有難うございます
探したのですが、rpm.binは見つける事ができませんでした。
JDK 6 Update 17 with Java EEのダウンロードで
Linuxを選択しても以下のファイルしか出てきませんでした。
(java_ee_sdk-5_08-jdk-6u17-linux-ml.bin)

投稿日時 - 2009-11-08 16:27:50

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.4

>JDK 6 Update 17 with Java EEのダウンロードで
私が、JDK 6 Update 17 with Java EE と言いました??
バンドル とは、言ってないでしょう。

上から4番目です。

投稿日時 - 2009-11-08 19:23:06

お礼

ありがとございます。うまくいきました。

投稿日時 - 2010-01-16 17:12:02

ANo.2

http://java.sun.com/javase/ja/6/download.html
のページの
Java SE Development Kit (JDK) JDK 6 Update 17
の rpm 版 でやりましたが。
余計なものが無い。
ご希望のものかはどうかは

投稿日時 - 2009-11-08 00:37:11

補足

J2SEでも試してみましたが、同じ現象で上手くいきませんでした。
.binがまずいのでしょうか?
ちなみにrpm版はどうやったらおとせるのでしょうか?
[ダウンロード]でLinuxを選択しても、.binファイルしか落とせませんでした。

投稿日時 - 2009-11-08 11:23:18

ANo.1

VMware Server 1.0.10 にVine4.2がinstall してあったので
試したところ、下記のmessage は出ませんが同じです
>*** glibc detected *** double free or corruption (!prev): 0x0806df48 ***
>一時ファイルを削除しています...
から進みません。
Vine をinstall しなおして、updateして
やりなおしても同じでした。

CentOS5.4 に install すると
install 中 日本語の表示がおかしい以外は簡単にinsttall 出来ました。
GlassFish もinstall されました。

Vine4.2 には、只のJDKなら install 出来ました。

軽々がしくは言えませんので
Vine の Forum に質問されたら如何がでしょうか。
http://vinelinux.org/forum.html

投稿日時 - 2009-11-07 22:59:11

補足

御回答有難う御座います
>Vine4.2 には、只のJDKなら install 出来ました。

只のJDKとは、バージョンが古いものでしょうか?
それともJ2SEでしょうか?
こちらでも試してみたいので教えてください。

投稿日時 - 2009-11-07 23:28:30

あなたにオススメの質問