こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

WMWareゲストOS(Linux)にOracle10gがインストールできない

お世話になります。

VMWareゲストOSにOracle10gがインストールできません。
runInstallerを動かしましたが、以下のように表示され、
インストールせずに終了してしまいます。

>[oracle@******** tmp]$ /mnt/cdrom/runInstaller
>Oracle Universal Installerを起動中です...

>インストーラ要件の確認中...

>オペレーティング・システムのバージョンを確認中: 必須redhat-2.1, redhat-3, SuSE-9, SuSE-8 or UnitedLinux-1.0
> 問題なし


>すべてのインストーラ要件を満たしています

>Oracle Universal Installer$N5/F0$r=`HwCf /tmp/OraInstall2009-10-20_01-10-34PM. お待ちください...[oracle@******** tmp]$ Xlib: connection to ":0.0" refused by serv
>er
>Xlib: No protocol specified

>Exception in thread "main" java.lang.InternalError: Can't connect to X11 window server using ':0.0' as the value of the DISPLAY variable.
> at sun.awt.X11GraphicsEnvironment.initDisplay(Native Method)
> at sun.awt.X11GraphicsEnvironment.<clinit>(X11GraphicsEnvironment.java:134)
> at java.lang.Class.forName0(Native Method)
> at java.lang.Class.forName(Class.java:141)
> at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:62)
> at java.awt.Window.init(Window.java:231)
> at java.awt.Window.<init>(Window.java:275)
> at java.awt.Frame.<init>(Frame.java:401)
> at oracle.ewt.popup.PopupFrame.<init>(Unknown Source)
> at oracle.ewt.lwAWT.BufferedFrame.<init>(Unknown Source)
> at oracle.sysman.oio.oioc.OiocOneClickInstaller.<init>(OiocOneClickInstaller.java:349)
> at oracle.sysman.oio.oioc.OiocOneClickInstaller.main(OiocOneClickInstaller.java:2106)

>[oracle@******** tmp]$

・ホストOS:Windows2003Server
・ゲストOS:RedhatLinuxES3.0

インストールの方法をご存知でしたら、お教え下さい。

以上、よろしくお願い致します。

投稿日時 - 2009-10-20 13:55:35

QNo.5382066

困ってます

質問者が選んだベストアンサー

マニュアルの以下、作業は行なっているでしょうか。

2 インストール前の作業
oracleユーザーの環境の構成
http://otndnld.oracle.co.jp/document/products/oracle10g/102/linux/B19280-02/pre_install.htm#503936

投稿日時 - 2009-10-22 11:40:19

お礼

解決しました。
rootユーザでセットアップを実行していました。
oracleユーザでやったところ、Xも無事起動してきました。
ありがとうございました。

投稿日時 - 2010-01-06 20:02:36

ANo.3

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.2

X-Windowの起動に失敗しています。

マニュアルどおりに行っていますでしょうか。
http://otndnld.oracle.co.jp/document/products/oracle10g/102/linux/B19280-02/inst_task.htm#666716

投稿日時 - 2009-10-20 15:40:58

補足

rootでログインした場合、X-Windowは起動できるようです。
oracleユーザにスイッチすると、X-Windowが上手く起動できません。

$ DISPLAY=workstation_name:0.0
$ export DISPLAY

をやってもダメなようです。
ユーザー毎にX-Windowの環境設定が必要なのでしょうか?

投稿日時 - 2009-10-21 13:06:25

お礼

解決しました。
rootユーザでセットアップを実行していました。
oracleユーザでやったところ、Xも無事起動してきました。
ありがとうございました。

投稿日時 - 2010-01-06 20:05:01

ANo.1

Xserverが動作していないか、DISPLAY環境変数にホスト名やIPアドレスが未設定か間違ったホスト名、IPアドレスが設定されています。
DISPLAY環境変数にゲストOSのホスト名かIPアドレスを設定してみて下さい。

投稿日時 - 2009-10-20 15:38:12

お礼

解決しました。
rootユーザでセットアップを実行していました。
oracleユーザでやったところ、Xも無事起動してきました。
ありがとうございました。

投稿日時 - 2010-01-06 20:05:26

あなたにオススメの質問