こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

無線LANでIP情報が残る??

以前Win7のネットワーク(IPアドレス)関係で質問したものですが単純な構成から順序だてて検証しましたので、皆さんの意見を頂ければと思います。
文字制限ギリなので見にくかったらごめんなさい。
ちなみに、前回の質問内容は、
http://questionbox.jp.msn.com/qa5120003.html
です。

使用機器
PC;自作機 マザボ;MSI DKA790GXPlatinum LANチップはRealtek RTL8111C
Windows7RC評価でをWindowsXPとWin7とでデュアルブートしてます。検証の為、Win7を再インストールし、直後の状態で行いました。この時デバイスマネージャーにはエラーは見られません(各チップを正常に認識していると考えられる)。
ADSLモデム;NEC Aterm WD701CV(ルーター・DHCP内臓、PPPoA接続)
モデム自体のIPv4アドレス(以下IP)は、192.168.0.1 DHCPの設定で192.168.0.20~49(割り当て数30)がリースされるよう設定しています。リース時間24時間。
無線LANルーター;プラネックス NZK-W300NH APモードで使用。ルーター機能OFF、DHCP機能OFF、IP;192.168.0.250
無線子機;プラネックス GW-EC300N5P コンバーターモードで使用DHCP機能OFF、IP;192.168.0.100
無線機器については、メーカーHPでWindows7対応と表記されています。

1、シンプルな環境
Internet-- ADSLモデム --(有線)-- PC
まったく問題なしでした。前回OSがタコといってごめんなさい。
2、次
Internet--ADSLモデム--(有線)--無線LANルーター--(有線)--PC
無線子機は電源切ってあります。この状態では、無線LANルーターは単なる
HUBとして機能しているはず。予想どおりまったく問題なしでした。
3、少し構成いじります。
Internet--ADSLモデム--(有線)--無線LANルーター--(有線)--PC
                        |
                       (無線)
                        |
                      無線子機
無線子機には、何も接続していません。この構成も問題なしでした。
一応、無線間でつながってるか確認しましたが(ping 192.168.0.100)通りました。
4、もう一段階進めます。
Internet--ADSLモデム--(有線)--無線LANルーター
                       |
                      (無線)
                       |
                    無線子機--(有線)--PC
自動構成ではIP取得できませんでした。
IP固定します。とりあえず 192.168.0.2 ネット○。
IP変更します。192.168.0.10 ネット○。
再起動します。IP;192.168.0.10(重複)。ネット×。
IP変更します。IP;192.168.0.2(重複)。ネット×。
IP変更します。IP;192.168.0.110 ネット○。
再度、再起動。IP;192.168.0.110(重複)。ネット×。
IP変更します。IP;192.168.0.2(重複)。ネット×。
IP変更します。IP;192.168.0.10(重複)。ネット×。
IP変更します。IP;192.168.0.15 ネット○。
傾向が見えました。無線をはさんだ状態では、一度つながったIPが、再起動
でも開放?されず、残っている状態とOSが認識しているようです。
では、いつ開放されるか。ためしにOS起動中に無線子機を再起動してみました(現在のIP;192.168.0.15)。
ネットに繋がるのを確認後、IP変更;192.168.0.2 ネット○
さらにIP変更;192.168.0.10 ネット○ IP開放されましたw
再起動します。IP;192.168.0.2(重複)。ネット×。
IP変更します。IP;192.168.0.10(重複)。ネット×。
IP変更します。IP;192.168.0.15 ネット○。
・・・やはり同じ症状です。

念のため、無線ルーター(親機)を再起動した場合も確認しましたが、
IP開放はされませんでした。
さて、ここで問題です。この状態を引き起こす犯人は誰でしょう?

(1)やっぱ、無線子機。無線を介した時IP取得できないのも変だし、子機リセットで症状もリセットがその証拠??。
(2)OSも怪しいかな? まったく同じ機器でXPでは問題なし、Win7で問題ありってのが気になる。IP周りの仕様がずいぶん変更になってるらしいし。
(3)意外とマザボ(LANチップ込み)がハズレだったのでは・・・?
(4)いや、操作してる本人が・・・・(・_・)☆ヾ(^^ )なんでやねん!
(5)その他

一応、マイクロソフト、無線機器メーカーにも報告をしておきますが、
何か参考意見でもいただければありがたく思います。

投稿日時 - 2009-07-18 16:49:29

QNo.5135541

暇なときに回答ください

このQ&Aは役に立ちましたか?

8人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.3

ARPの情報を持っていそうなのがAtermのような気がしたから。

投稿日時 - 2009-07-20 13:27:33

お礼

ARPテーブルっすか、なるほど。確かにルーターであるAtermが
管理してると考えるのもありですね。
勉強になりました、ありがとうございます。

投稿日時 - 2009-07-20 21:33:19

ANo.2

(5)DHCPを管理しているAterm

投稿日時 - 2009-07-18 19:02:29

補足

むむ、そこは盲点だった。
できれば、Atermと考えた理由を教えていただけませんか?

投稿日時 - 2009-07-18 22:32:34

ANo.1

私には質問内容がさっぱりわかりませんが、
 
1.IP変更後すべての機器の電源を切って1分後に機器の電源をいれた場合にはどうなるんですか?。
重複が発生しないのなら、そのような使い方をすればいいと思う。
というよりも、固定IPアドレスをわざわざ変えなければいけないのかよくわからない。
その様な必要があるなら、私ならNICを2枚にする。
 
2.重複IPのまま15分放置したらどうなるんですか?。
15分後に重複がなくなるなら、ネットのIPアドレスはすぐに反映されない事になる。
まだ、重複したままなら、私ならNICを2枚にする。

投稿日時 - 2009-07-18 18:13:56

補足

まずは、回答ありがとうございます。

1ですが、たぶん正常に動くでしょう。ですが、ネットに接続している機器を
使うたびにすべてリセットするなどという使い方は、普通じゃないですよね。
今回の検証では無線子機にPC1台で検証してますが、実際にはほかにも
ネット家電とかつながってて、そちらは正常に動いているのに。
また、IPアドレスは、検証の為にコロコロ変えてます。発端が、通常、XP環境
では、192.168.0.10固定で使用しています。そのPCにWin7をインストールし、
IPをXPと同じ192.168.0.10で固定しようとしたら、重複と出たので、いろいろ
調べてみたら、今回の様な状況になっていた、ということです。

2は、15分どころか、1時間放置しても変わりません。

だいたい、変な挙動だとは思いませんか?
同じPCでXP環境で起動(192.168.0.10)は問題なし、再起動してWin7環境で
起動(192.168.0.10)するとIP重複、IP変更して(例えば192.168.0.20)使用後電
源切る。翌日Win7環境で起動すると192.168.0.20が重複となって使えなくなっ
てる。192.168.0.10も重複と出る。ところがXP環境で起動しなおすと192.168.0.10
で問題なく使用できる。明らかに問題ありでしょ。

逆に、NIC2枚挿しに優位性見えませんが?
2枚目挿してどこに繋ぐんですか?ADSLモデムや無線LANルーターに繋ぐ
なら検証1,2で確認済みで、無線を使う必要性がなくなります。無線使わない
でOKなら、わざわざ検証しませんよ。私はLAN配線が面倒・大変だから無線
を使いたいんです。
仮に、2枚目も無線子機につなぐのなら、私個人の考えですが、同様な症状が
予想でき、まったくの無意味なものとなるのではないかと。

投稿日時 - 2009-07-18 23:40:05

あなたにオススメの質問