こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

Win7のIPネットワークってタコ??

以下のような構成で使用しています。

Internet----ADSLモデム------無線親機・・・(無線)・・・無線子機----PC A
            |                        |
            |(無線)                    |-------地デジTV
            |
          PC B


ADSLモデム;NEC Aterm WD701CV (プロバイダ イーーアクセス)
DHCP、ルーター機能を使用
無線親機;プラネックス NZK-W300NH APモードで使用
無線子機;プラネックス GW-EC300N5P コンバーターモードで使用

PC Aは自作機 マザボ;MSI DKA790GX LANチップはRealtek RTL8111C
PC Bはメーカー品
OSはともにWindowsXP sp3

Windows7RC評価でPC AをWindowsXPとWin7とでデュアルブートしてます。
今回ネット関係でWin7側に問題が発生しました。

まず、PC Bでは、IPアドレスを自動取得にしても固定しても問題なく
ネットに接続できていることを申し上げておきます。
また、TVもIPアドレスを自動取得できることも言っておきます。

PC AはIPを固定しています。(自動取得にすると、なぜか取得できない
が、固定することで問題なく使用できるので、今回は問題にしない)


問題はPC AでのWin7のIPアドレスに関してです。

まず、標準状態(IPv4アドレス自動取得)ではIPアドレスが正常に
DHCPから取得できずAPIPAにより169.254.0.0/16 のアドレスが割り
当てられ、ネットに接続できません。この時のネットワークプレイス
は「パブリック」から変更できません。

まぁ、これは許せる。問題はここから。

1、IPアドレスを手動で設定し再起動する。これでAPIPAが無効に
なり、正常に機能するはず・・・と思いきや・・・・
手動で設定したIPとAPIPAによって設定されたIPの「2つ」が1枚
のNICに付きます(°口°;) !!。APIPAのアドレスのほうが優先さ
れるのか、ネットに接続できません。この時のネットワークプレイス
も「パブリック」から変更できません。

2、レジストリいじってAPIPAを強制的に無効にします。
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\Tcpip\Parameters
にDWORD値「IPAutoconfigurationEnabled」を作成、値を0に設定後再起動。
つながりません。<(T◇T)>  Windows7上ではメッセージでませんが、
IPCONFIG /ALL で確認するとIPアドレスの重複となってます。ちなみに、
この時のIPアドレスはXPで起動した時と同じにしました。確実に使っていない
IPアドレスにも関わらず重複とでるということです。

仕方ないので、重複しないアドレスを探します。適当な番号を付けてやると
つながる値が見つかりました。この時ネットワークプレイスが「パブリック」
だったので「ホーム」に変更しました。
(後で分った事ですが、この時ネットワークプレイスが変更できる場合と
できない場合がありました。また、自動にパブリックからホームに切り替
わる時もあります)

3、再起動します。すると・・・・
つながりません。Windows7上ではメッセージでませんが、IPCONFIG /ALL で
確認するとIPアドレスの重複となってます。
再起動する前までは使えてたIPですよ。なんで?
仕方ないので再度値を変更・・(この時、確実に使用していないのに重複と
でるIPが複数確認できました)・・・するとつながる。

4、・・・以下、(再)起動ごとに・・IP重複・・・IP変更・・・つながる
のループです。



ルーターとPC A とを直結した場合の検証は後日行う予定ですが
現状、何がいけないのか、まったく見当がつきません。何か意見を
いただければと思います。
とにかく、この問題が解決しない限りWindows7にする気になれません。

投稿日時 - 2009-07-12 19:16:04

QNo.5120003

困ってます

このQ&Aは役に立ちましたか?

4人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.4

> この問題が解決しない限りWindows7にする気になれません。
使わなくてもいいんじゃないですか。
誰に強制されるわけでもなし。
    
そもそもRC版とは評価版なので、使ってみて不具合を洗い出して報告してください、それを製品版に反映しますよ。というものです。
不具合が見つかったらマイクロソフトに報告してください。
「タコ」呼ばわりするような事ではないかと。

投稿日時 - 2009-07-13 13:06:51

お礼

すみません、タコとは確かに言い過ぎました。

一応、マイクロソフトにも無線機器メーカーに報告は入れてます。

投稿日時 - 2009-07-13 19:05:58

ANo.3

冷静になって現象を再確認して下さい。
#1の回答にもありますように切り分けで問題点を整理して下さい。
1.PC-AをWin7起動の単独で無線LAN接続の場合は正常に動作しませんか?
2.PC-Bを同時に無線LAN接続し、地デジTV切り放しではどうですか?
3.地デジTVを有線LANでルータに追加接続したときはどうですか?
このように順次追加接続すれば原因を絞ることができます。

私はノートPCにWin7RCを単独でインストールし、内蔵無線LANで利用しています。
同時にMacも無線LANで同時接続していますが特に問題ありません。
MacはWinVistaとデュアルブートにしてありますのでWinVistaとWin7RCが同時に無線LAN接続でもトラブルありません。

投稿日時 - 2009-07-13 09:59:11

お礼

一応、冷静ですが^^;;
問題の切り分けは、おっしゃる通りで、参考にさせていただきたいと
思います。
ただ、まとまった時間がなかなか取れないので、問題の切りわけ
には時間がかかりそうです。

投稿日時 - 2009-07-13 19:11:18

ANo.2

お使いのWindows7は販売されている製品ですか?
もしWindows7がRC版なら評価版であり、お試し版ではありません。
そう言った不具合を含めて動作を検証・評価しマイクロソフトに報告するためのものです。
マイクロソフトは報告された情報を元に製品版での改善を行います。

また、LANを含めたWindows7用のマザーボードオンボード機能及びチップセットなどのドライバーのインストール、最新BIOSの更新などは行っているのでしょうか?

投稿日時 - 2009-07-13 09:50:13

お礼

すみません、タコとは確かに言い過ぎました。

一応、マイクロソフトにも無線機器メーカーに報告は入れてます。
ただ、無線機器メーカーのHPではWin7RCでの動作報告があり、対応と
うたわれてます。
また、ドライバ関係はWin7上デバイスマネージャーで見る限りでは正常に
認識しております。チップセットメーカー配布のドライバでも試しましたが
状況は変わりませんでした。むろんWin7上では正常に認識されています。
ともあれ、回答ありがとうございます。

投稿日時 - 2009-07-13 19:17:39

無線子機はWindows7に対応しているのですよね?
ドライバとか非対応の物使ってるなら、Win7をタコ呼ばわりするのは筋違いでしょうし。

うちは有線でCTU(西フレッツ機器、ルータ機能内蔵)からIP払い出ししてますが、普通にIP割り当てられてネットも快適に使えてますよ。

もし、ルータに有線直結の場合に問題が出ないようなら、無線機器に問題があるって事になりますね。
とりあえず、騒ぐ前に問題の発生している部分の切り訳を行うべきだと思いますよ。

投稿日時 - 2009-07-12 21:49:40

お礼

すみません、タコとは確かに言い過ぎました。

一応、マイクロソフトにも無線機器メーカーに報告は入れてます。
ただ、無線機器メーカーのHPではWin7RCでの動作報告があり、対応と
うたわれてます。
ちなみに、私の構成だとPC-Aからみると無線部分は単なるブリッジなので
OSに依存するものではないのです。
まぁ、もう少し細かく問題の切り分けをしなきゃ、とは思ってるので、
問題点の絞り込みができたら、再度質問させていただこうと思います。

投稿日時 - 2009-07-13 19:29:02

あなたにオススメの質問