こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

eclipsからのtomcatの起動について

最近、web開発に興味を持ち、参考書を購入し始めたのですがわからないことばかりで困っているのでご教授お願いいたします。
参考書を購入し、tomcatプラグインを追加して、eclipsのtomcatの設定のところで、tomcatのバージョンとpathの設定まで完了しました。*注1
*注1設定パス「C:\Program Files\Apache SoftwareFoundation\Tomcat」
そこまでの設定で、eclipsからtomcatの起動をクリックしても反応が
ありません。(エラー等も出ません)
開発環境は下記に示す通りです。
・eclips 3.4
・tomcat 6.0
. jdk1.6.0_7
以上の情報では、わからないかもしれませんがどなたかお願いします。

投稿日時 - 2009-07-01 20:55:23

QNo.5090573

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

2人が「このQ&Aが役に立った」と投票しています

回答(6)

ANo.6

>言われた通り、Eclipse 3.5 Galileo のWTPが最初から入っているやつにしました。

それならOKです。
Eclipse Java 3.5 EE IDE for Web Developers
のコードネームは
Eclipse Java EE IDE for Web Developers Glileo
です。
version 3.2 からEclipseにつけられ始めました。

投稿日時 - 2009-07-06 23:21:54

ANo.5

ALL IN ONEタイプの正確なコードネームを補則に書いてください。
初期の段階なので設定なんてすぐにできるので
極力”Eclipse 3.5 Galileo”を使ってください。
なおEclipseのインストールは好きな場所に
フォルダを置くだけなので今のEclipseをアンインストールしなくてもいいのです。
単にDLした”Eclipse 3.5 Galileo”の圧縮ファイルを解凍して解凍してできたディレクトリを配置するだけです。
実装する時にワークスペースをそれぞれ別にしておけばいくつEclipseを配置していても独立に動かすことができます。
ただし、同時実行はできません。
私の場合は
”Eclipse 3.5 Galileo”を3つ配置しています。

投稿日時 - 2009-07-05 22:52:53

お礼

またまた回答が遅くなり申し訳ありません。
結局、reimanさんの言われた通り、Eclipse 3.5 Galileo の
WTPが最初から入っているやつにしました。
ALL IN ONEはさすがに重すぎたので・・・。
ちなみに コードネームって「pleiades-e3.5-java-jre_20090629」
これですか?

投稿日時 - 2009-07-06 22:05:29

ANo.4

>さっそく導入したんですが、ALL IN ONEタイプでよかったですか?
ダメです。
”Eclipse 3.5 Galileo”です。

投稿日時 - 2009-07-05 17:02:57

お礼

reinmanさん、ご回答ありがとうございます。
Eclipse 3.5 Galileo の、ALL IN ONEタイプを導入してしまいました・・・。
ほとんどの設定を終えてしまったのですが、やはり、ALL IN ONEタイプとはかなり違ってくるのですか??
動作が重たいという程度の問題ならこのまま学習を進めていきたいと
考えているのですが・・・。
質問ばかりで申し訳ありません。

投稿日時 - 2009-07-05 22:35:25

ANo.3

eclipse 3.5 Galileo
使いなさい。
WTPの機能は入っていてWTPを意識する必要も調べる必要もありません。
Tomcatプラグインは不安定なので使うのは止めた方がいいでしょう。
eclipse 3.42 EE もやや不安定です。

投稿日時 - 2009-07-04 13:21:19

お礼

さっそく導入したんですが、ALL IN ONEタイプでよかったですか?

投稿日時 - 2009-07-04 20:02:46

ANo.2

Tomcatプラグインなんて使ってたのは数年前だから、ちょっと記憶があいまいだが……。

まず、Tomcatプラグインの設定が正しいか再確認する。それからTomcat単体で起動・終了などが問題なくできるかを確認する。たとえば、「実はTomcatをサービスとしてインストールしてたのでTomcatは最初からずっと起動しっぱなしだった」なんてオチもよくある。Eclipseから起動したいなら、それ以前にTomcatが起動していたら駄目。あと、コンテキスト定義の更新が正しくされているか。そのへんかな。

ただ、おそらくその参考にしている本は、数年前のものじゃないだろうかね。今は、Tomcatプラグインなんて使ってる人はほとんどいないだろう。今はWTP(Eclipse純正のWeb Tools Platform)というのでWeb開発をするのが基本だろうと思う。どうせなら、そちらのほうを使って勉強したほうがいいだろう。

投稿日時 - 2009-07-02 10:26:15

お礼

返事が遅れてすみません。
確かに、参考書は古いのかもしれないです。下の回答にあるように、
単体では動きますので、そちらを起動しながら、学習を進めたいと思います。後、WTPについて、少し調べてみます。
ありがとうございました。

投稿日時 - 2009-07-04 11:44:23

ANo.1

eclipsではなく、"Eclipse"ですよね?

Tomcatプラグインは何を入れましたか?
Sysdeo Tomcat プラグインぐらいしかないと思いますが…。

EclipseからTomcatを起動できなくても、Tomcatフォルダ配下のbinフォルダの中にある startup.bat でTomcatが起動できれば問題ないですよ。

投稿日時 - 2009-07-02 01:24:42

あなたにオススメの質問