こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Nvidiaのドライバインストール

ドライバーインストール後、Xwindowがエラーで立ち上がりません。
検索をかけてみたところかなりの件数がヒットするのでよくあるトラブルだとは思うのですが、自己解決できなかった為質問させて頂きます。

環境
PC;http://www.frontier-k.co.jp/desktop/XZ/index.asp?c=spec#top (スタンダードモデル)
OS;centos 5.2 84_64
使用したドライバ;NVIDIA-Linux-x86_64-100.14.19-pkg2.run

現象
nvidiaのドライバを使用するとXwindowが立ち上がらない

xorg.confの内容
<--ここから
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder26) Wed Sep 12 14:29:17 PDT 2007

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
EndSection

Section "Module"
Load "glx"
EndSection

Section "ServerFlags"
Option "AllowMouseOpenFail" "yes"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mice"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 110.0
VertRefresh 50.0 - 150.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1280x960" "1280x800" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
EndSubSection
EndSection
<---ここまで

xorg.0.logの内容
(EE) Failed to initialize GLX extension (Compatible NVIDIA X driver not found)

おそらく上記のエラーが原因だと思うのですが、思う所があれば識者の方々アドバイスの程宜しくお願いします。

投稿日時 - 2009-03-12 21:47:53

QNo.4791525

困ってます

質問者が選んだベストアンサー

> NVIDIA(0): Please see the COMMON PROBLEMS section in the README for
ドライバをダウンロードするときに、
何か、注意が記載されていなかったでしょうか。

nvidiaは、持っていないので何ともいえないですが、
ディスプレイの仕様で、
> HorizSync 30.0 - 110.0
> VertRefresh 50.0 - 150.0
こんなに幅は広いですかね。
仕様どおりに手直ししてみるとか。

投稿日時 - 2009-03-12 23:06:47

お礼

本当に申し訳ないです。
どうやらドライバが古かったみたいで・・・
最新のドライバをインストールしたとこ、無事に正常動作致しました。
度々の回答を参考にし、今後このような事にならぬよう精進していきます。
ありがとうございました。

投稿日時 - 2009-03-12 23:21:21

ANo.2

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.1

/var/log/Xorg.0.log
あたりに何か手がかりはありませんか。

投稿日時 - 2009-03-12 22:22:34

補足

大変恥ずかしいのですが質問にて書いたxorg.0.logの内容はvesaでXを起動しようとした時のエラーでした。
xorg.0.log.oldの中を覗いてみるとどうもそれらしいエラーが出ているのでが、まだ解決には至っていません。
nvidiaのbug-report等も載せた方が参考になりますでしょうか?

xorg.0.log.oldの内容
<--ここから
~~
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0): enabled.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device PCI:6:0:0.
(EE) NVIDIA(0): Please see the COMMON PROBLEMS section in the README for
(EE) NVIDIA(0): additional information.
(EE) NVIDIA(0): Failed to initialize the NVIDIA graphics device!
(II) UnloadModule: "nvidia"
(II) UnloadModule: "ramdac"
(II) UnloadModule: "wfb"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found
<--ここまで

投稿日時 - 2009-03-12 22:34:49

あなたにオススメの質問