こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Debian apt-get updateができない

Debian初心者です。

これからLinuxの勉強を始めようと思い、いろいろとテキストを買ってきて勉強をし始めましたが、早速つまずいてしまいました。
Debianのインストールまではできたのですが、apt-get updateができません。

以下のようになります。
KURO-BOX:/home/tmp-kun# apt-get update
Get:1 ftp://ftp.dti.ad.jp woody/main Packages
Err ftp://ftp.dti.ad.jp woody/main Packages
Unable to fetch file, server said '/pub/Linux/debian/dists/woody/main/binary-p
owerpc/Packages.gz: No such file or directory. ' [IP: 202.216.228.228 21]
Get:2 ftp://ftp.dti.ad.jp woody/main Release
Ign ftp://ftp.dti.ad.jp woody/main Release

省略

Get:8 ftp://ftp.dti.ad.jp woody/contrib Release
Ign ftp://ftp.dti.ad.jp woody/contrib Release
Hit ftp://ftp.dti.ad.jp woody/non-US/main Sources
Hit ftp://ftp.dti.ad.jp woody/non-US/main Release
Hit ftp://ftp.dti.ad.jp woody/non-US/contrib Sources
Hit ftp://ftp.dti.ad.jp woody/non-US/contrib Release
Failed to fetch http://security.debian.org/dists/woody/updates/main/binary-power
pc/Packages 404 Not Found [IP: 212.211.132.32 80]
Failed to fetch http://security.debian.org/dists/woody/updates/contrib/binary-po
werpc/Packages 404 Not Found [IP: 212.211.132.32 80]
Failed to fetch ftp://ftp.dti.ad.jp/pub/Linux/debian/dists/woody/main/binary-pow
erpc/Packages Unable to fetch file, server said '/pub/Linux/debian/dists/woody/
main/binary-powerpc/Packages.gz: No such file or directory. ' [IP: 202.216.228.
228 21]
Failed to fetch ftp://ftp.dti.ad.jp/pub/Linux/debian/dists/woody/contrib/binary-
powerpc/Packages Unable to fetch file, server said '/pub/Linux/debian/dists/woo
dy/contrib/binary-powerpc/Packages.gz: No such file or directory. ' [IP: 202.21
6.228.228 21]
Failed to fetch ftp://ftp.dti.ad.jp/pub/Linux/debian/dists/woody/main/source/Sou
rces Unable to fetch file, server said '/pub/Linux/debian/dists/woody/main/sour
ce/Sources.gz: No such file or directory. ' [IP: 202.216.228.228 21]
Failed to fetch ftp://ftp.dti.ad.jp/pub/Linux/debian/dists/woody/contrib/source/
Sources Unable to fetch file, server said '/pub/Linux/debian/dists/woody/contri
b/source/Sources.gz: No such file or directory. ' [IP: 202.216.228.228 21]
Reading Package Lists... Done
Building Dependency Tree... Done
E: Some index files failed to download, they have been ignored, or old ones used
instead.

いろいろと調べてみたりしたのですが、まったくとっていいほど解決策が見つかりません。
この後sambaのインストールも行いたいのですが、進まずじまいです。
以上、解決方法教えて頂きたいです。

投稿日時 - 2009-03-11 22:55:18

QNo.4788921

困ってます

質問者が選んだベストアンサー

woody用のバイナリパッケージはアーカイブ内にある様です。
ディストリビューションアーカイブ
http://www.jp.debian.org/distrib/archive

>もし APT を使っているのでしたら、必要な sources.list
> のエントリは以下のとおりです。

> deb ​http://archive.debian.org/debian/​ hamm contrib main non-free
#hamm → woody に置き換えて下さい。

投稿日時 - 2009-03-14 22:42:22

お礼

解決しました。ありがとうございました。

投稿日時 - 2010-06-22 10:57:22

ANo.2

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.1

Debian 3.0(Woody)のサポートが終了していてftpサイト
にもアップデート用のパッケージは既にありません。
#woody(3.0), sarge(3.1), etch(4.0), lenny(5.0)
現在、サポートされているのはetch とlenny です。
#lenny は2009 年 2 月 14 日リリース

投稿日時 - 2009-03-12 00:26:16

あなたにオススメの質問