こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

JAVA実行環境が見つからない?

WindowsXP上で、FreeMindというマインドマップを作成するフリーソフトをインストールしたところ、
FreeMind requires version Java 1.4.0 or higher (your version:1.3.1_01, installed in C:\Program Files\Oracle\jre\1.3.1).
というメッセージが表示されて、起動できませんでした。

そこで、ネット上から最新のJRE SE v1.4.2_19をインストールしたのですが、状況は変わりませんでした。

プログラムの追加と削除のインストール済みソフトのリストを見たところ、JAVA関係のRuntimeモジュールが
J2SE Runtime Environment 5.0 Update 10
J2SE Runtime Environment 5.0 Update 11
J2SE Runtime Environment 5.0 Update 6
J2SE Runtime Environment 5.0 Update 9
Java 2 Runtime Environment, SE v1.4.2_03
Java 2 Runtime Environment, SE v1.4.2_19
Java(TM) 6 Update 2
Java(TM) 6 Update 3
Java(TM) 6 Update 5
Java(TM) 6 Update 7
Java(TM) SE Runtime Environment 6 Update1
と多数表示されていました。

まず、インストールするJava実行環境を間違えていますでしょうか?
また、なぜJavaの実行環境は、こんなにたくさんインストールされているのでしょうか?(同名の古いUpdateを削除しても問題ないでしょうか?)
どなたかご教示願えますでしょうか?

投稿日時 - 2009-02-07 23:05:26

QNo.4698200

困ってます

質問者が選んだベストアンサー

「コントロールパネル」の「Java」の「Java Runtime Environment設定」画面で、バージョンごとにJavaの有効、無効を切り替えられるようになっています。

まず、最新のJREを残して、その他を無効にして動作確認し、何を有効にし、何を無効にするとちょうどよいのかを見極めてはいかがでしょうか。

参考URL:http://freemind.asia/faqs/trouble/save.html

投稿日時 - 2010-06-18 16:53:38

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.2

こんにちは

そのエラーメッセージはv1.4以上のjavaが必要と言うだけで
1.4が必要と言うわけではないですね。
またJavaのバージョンですけど、古いのは特に必要ないですよ。
http://www.java.com/ja/download/faq/remove_olderversions.xml

確かに旧バージョンに依存するケースはあるとのことですけど
Java(TM) 6 Update 7とJava(TM) 6 Update 11
しか入れていないXP(古いのは削除済み)で、テスト的に、
FreeMindのv0.81をこのXPにインストールし、起動して見ました
が問題なく、起動できましたよ。

pathの設定は特に必要ないものですけど、javaの再インストール
http://java.sun.com/javase/ja/6/download.html
されてはどうですか?(今確認するとUpdate 12になってますね)

では。

参考URL:http://www.freemind-club.com/

投稿日時 - 2009-02-08 08:01:48

ANo.1

>(your version:1.3.1_01, installed in C:\Program Files\Oracle\jre\1.3.1).

あなたの場合、ココにパスが通っているんだと思います。
つまり JRE 1.3.1 が使われている…

コントロールパネルの
「システム」「詳細設定」「環境変数」で PATH の値を希望するJavaのバージョンに切り替えてください。

たぶん PATH に C:\Program Files\Oracle\jre\1.3.1\bin とかが指定されていると思いますので、これを JAVA6 だったら C:\Program Files\Java\jre6\bin に変えます。あなたが過去にインストールした Java のパスを確認してくださいね。

>同名の古いUpdateを削除しても問題ないでしょうか?

通常はそうなんですけど、古いバージョンでないと動かないソフトもあったりするので、なんとも言えないです。

投稿日時 - 2009-02-08 00:29:39

あなたにオススメの質問