こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

MU1000,XGworksの音程がおかしく

MIDI製作に、MU1000とXGworks4,07を使っているのですが、ネット上のあるMIDIファイルをXGworksに読み込んで以来、
自分の作ったMIDIのギター音の音程がずれてしまいました。
このギターの音はYAMAHAのギターからG1D→G50→MU1000につないでXGWORKSに録音したもので、はじめはちゃんと音程もストロ-クの音もあっていたのですが、ネット上の誰かのMIDIをXGWORKSに読み込んでいらい、なんだかギターの音程がおかしくなりました。自分とは違う製作者のMIDIを読み込むと、MU1000のチャンネルの割り当てが変わってしまうので、そのチャンネルも元に戻したり、MU1000を初期化したりしたのですが、ギターの音だけは元に戻りません。なぜでしょうか。
他のピアノの音や、ベース音はMIDIキーボードで打ち込んだので音程がずれることはなかったのですが、G50で録音したギター音だけは未だに、音程がずれたままです。
どうしたらよいでしょうか。ご回答よろしくおねがいします。

投稿日時 - 2009-01-12 22:54:02

QNo.4625638

すぐに回答ほしいです

質問者が選んだベストアンサー

YAMAHAのG50という製品を使ったことはありませんが、
ギターの演奏をMIDIデータに変換して、ソフトへ入力する機器だと思います.
…なので、質問者様の言う「ギターの演奏」=MIDIデータという前提で書きます.

音程がおかしい、とのことですが、音程に限らず、MIDIデータの演奏がおかしい場合、
原因は、やはりMIDIデータの不備です.
音程がおかしい場合は、その曲のMIDIデータのどこかに、ピッチベンドのデータが
入っているのではないでしょうか?
あるいは、音程を変えるSysEx(システム・エクスクルーシブ・メッセージ)が
入っているとか…(滅多にありませんが)

また、MIDIデータは、基本的に曲の一番始めにリセットデータを入力する必要があります.
(YAMAHAの音源を使っているのなら「XGリセット」になります)
このように、まずはMIDIデータを疑ってみて下さい.
ソフト(XGWORKS)に関しては、演奏時にキーを変化させるような設定が無いのなら、
問題無いと思います.

投稿日時 - 2009-01-13 15:23:54

お礼

ありがとうございます。
やはりピッチベンドがおかしくなっておりました。

投稿日時 - 2009-02-08 15:28:41

ANo.4

このQ&Aは役に立ちましたか?

3人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.3

あと、MIDIドライバを入れ直してみるのも手です。

投稿日時 - 2009-01-13 05:05:14

ANo.2

>これは、XGWORKSの設定が他のMIDIを読み込んだ際に変わってしまったからでしょうか。

その様な設定はないですよ。同じMIDIデータで音色が変わるのは音源が原因です。
試しにWMPなどを使ってMIDIを再生してみて下さい。音源はMU1000を指定しておいて下さい(コントロールパネルで)。

投稿日時 - 2009-01-13 05:00:12

ANo.1

MIDIを読み込んでその時おかしくなったのは理解できますが、その後システムを再起動(システムというのはパソコンとMIDI音源の両方)してもおかしくなっているのですか?
だとしたら音源の故障が疑われますね。
コンセントを抜いてしばらく放置したらどうですか?

投稿日時 - 2009-01-13 03:32:42

お礼

MIDI音源のほうも電源を抜いてみたのですが、どうにも直りません。
工場出荷状態にイニシャライズと設定したのですが、やはり、G50で読み込んだギター音だけがおかしいです。
これは、XGWORKSの設定が他のMIDIを読み込んだ際に変わってしまったからでしょうか。XGWORKSの設定を戻すにはどうしたらいいのでしょうか。再インストール以外にはないのでしょうか。

投稿日時 - 2009-01-13 04:29:21

あなたにオススメの質問