こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

FTPサーバーにWAN側からログインできない

お世話になっております。
どなたかお詳しい方、アドバイスよろしくお願いいたします。

FTPサーバーを建てて、プライベートIPアドレスで接続すると接続できるのですが、グローバルIPでアクセスすると、パスワードを求められて接続できません。どうすれば外部から接続できるようになるでしょうか?

現在の状況を箇条書きにしてみます。

・ルータ名はWeb Caster v110、OSはVista Ultimate SP1です。
・以前に今と同じルータで、とくに設定をいじらずFTPサーバーを建てられた記憶があります。その時はXP Pro SP2だったと思います。
・FTPサーバーソフトはQuick'n Easy FTP server 3.1を使っています。
・VistaのサービスのFTPも試しましたし、ほかにフリーのサーバーを5~6個試しましたが上手くいきません。ローカルでは接続できるのでサーバー自体は動くようです。
・ルータではポート20、21は解放しております。
・PFWも開放したり、無効にしてみましたがだめでした。
・現在、HTTPサーバーは外部に公開することができます。

・無関係だと思うのですが、WindowsにログインするアカウントとパスワードをFTPアカウントと同じにしてみましたが、やはりだめでした。

よろしくお願いいたします。

投稿日時 - 2008-10-28 06:22:21

QNo.4435586

すぐに回答ほしいです

質問者が選んだベストアンサー

取扱説明書にFTPサーバーを公開する場合の設定解説があります。

http://www.ntt-west.co.jp/kiki/download/flets/v110/v110_detail0804.pdf
の14ページ目

この設定は正しくされていますか?

投稿日時 - 2008-10-28 11:08:06

補足

ありがとうございます。

もう一度確認しましたが、ルータはマニュアルにある通り設定できています。個人的にはルータの問題ではなさそうだと思うのですが、どのFTPサーバーソフトを使ってもダメなので、やはりルータなどのほうに原因があるんでしょうかね。またはWindowsの設定が悪いのでしょうか。

anonymousアカウント、パスワード認証付アカウント、どちらも接続できないのですが若干返されるエラーが違います。anonymousアカウントで接続すると、FFFTPは「接続できません」というエラーを返し、認証付きアカウントで接続すると、パスワードを求められます。当然パスワードはちゃんと入力していますが、接続できません。

FFFTP側でpassiveをオンオフ切り替えてみましたが同じでした。FTPサーバーのほうは、passiveモードなどの設定項目はみあたらなかったです。
外部ポートスキャンで20と21が開いているか確認したところ、21は開いています。20は失敗しました。しかしルータでもPFWでも開いているので単に20を使うアプリケーションが起動していないからだと思います。どのFTPクライアントで接続しても認証エラーがでます。

投稿日時 - 2008-10-28 22:10:22

お礼

ありがとうございました。
実はちゃんと設定できていたのですが、同じIPからではいくらグローバルIPアドレスでアクセスしてもルータの設定画面に入ってしまうんですね。

HTTPサーバーの場合はブラウザでアクセスするのですぐにわかるし、プロキシを通せばいいってのがわかるのですが、FTPサーバーの場合はなぜ繋がらないのかわからず、FTPクライアントにプロキシの設定なども見当たらなかったため気づくことができませんでした。

外のPCやプロキシサーバー経由でアクセスしたところ、ちゃんとFTPサーバーに繋がりました。盲点でした。

投稿日時 - 2008-11-02 00:03:21

ANo.1

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.2

こんにちは。

ちょっと危険ですが、一時的に以下を試してみてはいかがでしょうか。

1) ルータのポートについて
現在20、21のみの開放とされているかと思いますが、
これに1024~65535を追加してみてください。

2)パソコンのセキュリティソフトについて
Vistaのファイアーウォールの設定はいかがでしょうか。
詳しくはわからないのですが、一度無効にしてみて、接続できるかご確認を
とってみてはいかがでしょう。
(アンチウィルスソフトがあれば、それも無効に)



最後に、、、FTPサーバのログは確認されましたか?
一度見てみれば、ヒントとなるものがあるかも知れません。

投稿日時 - 2008-10-29 15:49:16

お礼

ありがとうございました。
実はちゃんと設定できていました。同じIPからではいくらグローバルIPアドレスでアクセスしても、ルータの設定画面に入ってしまうんですね。

HTTPサーバーの場合はブラウザでアクセスするのですぐにわかるし、プロキシを通せばいいってのがわかるのですが、FTPサーバーの場合はなぜ繋がらないのかわからず、FTPクライアントにプロキシの設定なども見当たらなかったため、気づくことができませんでした。

外のPCからつないで初めて気付きました。盲点でした。

投稿日時 - 2008-11-02 00:05:01

あなたにオススメの質問