こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

家庭内LANで1ホストだけつながりません。

家庭内LANに複数のPCがハブを介してつながっています。
このたびLAN内の1台のPCを入れ替えました。
入れ替えたと言っても、CPUをAthlon XPからAthlon64に替え、それにともなってマザーボードを替えたものです。
ネットワークチップも変わりました。
元々そのPCにUbuntu8.04とVine4.2が入っていましたが、幸いにもすぐにログインできました。
LAN内の各PCに固定アドレスを割り振り、それぞれからpingを送ると、このPCだけ"Destination Host Unreachable"となります。

IPアドレス、ネットマスクは次の状況です。

ホスト名 IPアドレス ネットマスク
pc1 192.168.1.1 255.255.255.0 正常
pc2 192.168.1.2 255.255.255.0 正常
pc3 192.168.1.3 255.255.255.0 異常

自分自身へのpingは(127.0.0.1、192.168.1.3とも)正常でした。

ケーブルを、通信できているPCにつないでいるものに代えても同じでした。
ディストリビューションをVine、Ubuntu、Knoppixで試しましたが、同じでした。
ネットワークカードを増設してみましたが、同じでした。
クロスケーブルでつないでみましたが、同じでした。

関係無いと思いますが、外部との入口にあるルーターにMACアドレスで信号をはじくような設定はしていません。

どんな異常が考えられるでしょうか。

2008年8月9日

投稿日時 - 2008-08-09 14:27:07

QNo.4239181

困ってます

質問者が選んだベストアンサー

>ネットワークカードを増設してみましたが、同じでした。
私の誤解ですが、どの時点で、nic が1枚か2枚か解らなかったので
結果は、全て 1枚なのですね。

Live-CD で、認識するDisribution と認識しないものが
ある事が、解りましたので
>的を絞りませんか
>konppix5.0 で 通信出来れば
>問題解決なのですか
vine か ubuntu での状態を言ったつもりですが
細かく設定できる vine での結果をお願いします。
$ /sbin/ifconfg -a
$ dmesg | grep eth
通信が出来ないので、難しいかも知れませんが

また、認識したもので
$ dmesg | grep eth
の結果をお願いします。

投稿日時 - 2008-08-17 09:04:10

補足

cynthia4様、ありがとうございます。
Vine4.2を再インストールしたらネットワークが正常に動きました。
ただ、再インストールに不特定の場面で何度も失敗し、やっとインストールできたと思ったら、不特定にしょっちゅうハングアップしています。
何がおかしいのかわかりません。

通信関係の状況は次のとおりです。
$ /sbin/ifconfig -a
eth0 リンク方法:イーサネット ハードウェアアドレス xx:xx:xx:xx:xx:xx
inetアドレス:192.168.1.1 ブロードキャスト:192.168.1.255 マスク:255.255.255.0
inet6アドレス: xxxx::xxx:xxxx:xxxx:xxxx/64 範囲:リンク
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RXパケット:1026 エラー:0 損失:0 オーバラン:0 フレーム:0
TXパケット:1132 エラー:0 損失:0 オーバラン:0 キャリア:0
衝突(Collisions):0 TXキュー長:1000
RX bytes:626128 (611.4 Kb) TX bytes:265211 (258.9 Kb)
割り込み:23 ベースアドレス:0xe800

lo リンク方法:ローカルループバック
inetアドレス:127.0.0.1 マスク:255.0.0.0
inet6アドレス: ::1/128 範囲:ホスト
UP LOOPBACK RUNNING MTU:16436 Metric:1
RXパケット:256 エラー:0 損失:0 オーバラン:0 フレーム:0
TXパケット:256 エラー:0 損失:0 オーバラン:0 キャリア:0
衝突(Collisions):0 TXキュー長:0
RX bytes:12960 (12.6 Kb) TX bytes:12960 (12.6 Kb)

sit0 リンク方法:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RXパケット:0 エラー:0 損失:0 オーバラン:0 フレーム:0
TXパケット:0 エラー:0 損失:0 オーバラン:0 キャリア:0
衝突(Collisions):0 TXキュー長:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

2008年8月23日

投稿日時 - 2008-08-23 16:35:42

お礼

Vine4.2を再インストールしてからいろいろやったところ、BIOS設定でIOAPICをEnableにすると、ネットワークできなくなったり、サウンドがおかしくなったりするようで、これをDisableにすると正常になります。

2008年8月23日

投稿日時 - 2008-08-23 23:28:57

このQ&Aは役に立ちましたか?

7人が「このQ&Aが役に立った」と投票しています

回答(10)

ANo.10

install 時
boot: linux noapic
などで良いかも知れません。
または
boot: linux noapic noacpi

Vine4.2 で、boot: 時 Function Key で option を
見ても、書いてない。
普通は、もう少し親切だと思うが。

投稿日時 - 2008-08-24 03:29:13

ANo.8

>その状態でネットワークが使えない状態が続いています。

何は、ともあれ
$ /sbin/ifconfig -a
と言ったと思いますが。

結果を書くのが難しければ
ethx が存在するか。
存在する場合、
RX,TX の packets が 0 かどうか。
存在しない場合、仕様から NIC の chip 名 が解れば

投稿日時 - 2008-08-13 14:49:53

補足

ANo.3の回答への補足に
$ /sbin/ifconfig -a
を書いています。

2008年8月17日

投稿日時 - 2008-08-17 07:32:57

ANo.7

私の一つの仮説は、こうです。
M/B 上 の NIC と 増設した NIC が
競合している。例えば、irq

/*****
そんな馬鹿なと、思われるが
一度経験している。
同じく、M/B に NIC を 1個増設したところ
通信が不安定、又は不能になった。
これが、Distribution によって違う。影響ないのも有った。

Windows で、見てみると、irq が同じだった。
それでも、Windows は関係なかった。
Solaris もあったから、見方が解らなくて
Linux/Solaris で 本当にirq が同じだとは確認していないのだが
その時は、NIC を変えて誤魔化しで解決した様に
記憶しています。

network manager の線も有るのだが

投稿日時 - 2008-08-12 12:19:57

補足

cynthia4樣、ありがとうございます。
増設NICは既に取り外していますので、M/B 上 の NIC とのirq競合はありません。その状態でネットワークが使えない状態が続いています。

2008年8月13日

投稿日時 - 2008-08-13 11:49:46

ANo.6

network manager で 調子が悪いこともあるし
( Knoppix5.0 に あるかどうか解らないが )

的を絞りませんか
konppix5.0 で 通信出来れば
問題解決なのですか

投稿日時 - 2008-08-12 00:06:44

補足

cynthia4様、ありがとうございます。
VineもしくはUbuntuでの通信が希望です。
真の目的は、cx23415チップが載ったITVC15-STVPCIというmpeg2ハードエンコードTVカードでivtvとmythTVというTV関連ソフトが使えさえすればよいのですが、私の経験ではこの2つのディストリビューションになるというだけです。

いろいろアドバイス頂いて申し訳ないのですが、本日から1週間程留守にするので、しばらく本件はお預けです。

2008年8月12日

投稿日時 - 2008-08-12 00:36:05

ANo.5

>通信のできないKnoppixr5.0のものです。
>$ /sbin/ifconfig -a

>eth1 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
>inet addr:192.168.1.3 Bcast:192.168.1.255 Mask:255.255.255.0
>inet6 adder : xxxx::xxx:xxxx:xxxx:xxxx/64 Scope:Link
>UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
>RX packets:0 errors:0 dropped:0 overruns:0 frame:0
>TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
>collisions:0 txqueuelen:1000
>RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
>Interrupt:3 Base address:0x4c00

Knoppix で
RX,TX の packets が 0 なので
nic が 活性化されていないのでしょう。
これでどうですか
$ sudo ifdown eth1;ifup eth1

他の、Distribution の
ifconfig はどうなっていますか。

>いろいろLive CDを試していたら、Ubuntu7.10でLAN内の他ホストとpingが通りました。
意味が解らないところがあります。
DHCP で やっているのか
Static で 設定しなおしてやった結果なのか
設定したなら、NETWORK を 再起動しないといけないのでは
ないでしょうか。

投稿日時 - 2008-08-09 23:31:24

補足

cynthia4様、ありがとうございます。
Knoppix5.1では通信できました。(pingもhttp通信もできました)
Knoppix5.0では通信できませんでした。
どちらも、Knoppix起動後、KDEメニューのネットワーク設定で固定アドレスを指定しています。
Knoppix5.1ではそれだけで通信できました。

通信のできないKnoppix5.0で
# /etc/init.d/networking restart
とすると
* /etc/network/options is deprecated.
Setting up IP spoofing protection...done (rp_filter).
Reconfiguring network interfaces...ifup: interface lo already configured
SIOCADDRT: File exists
Failed to bring up eth1.
done.
と表示されました。

2008年8月11日

投稿日時 - 2008-08-11 23:27:56

>いろいろLive CDを試していたら、Ubuntu7.10でLAN内の他ホストとpingが通りました。

とあるので、ハブやケーブルなどの物理的損傷はないものと思われます。

Knoppixでちゃんと認識しているeth1がなぜ駄目なのかは分かり兼ねますが、Ubuntu8.04とVine4.2の場合は「kudzu」のサービスがoffになっていたからじゃないかと、思いますけども。

@IT総合トップ > テクノロジー > Linux Square > Linux Tips Index >
Linuxの起動時間を短縮するには
http://www.atmarkit.co.jp/flinux/rensai/linuxtips/200fastbootlinx.html

ヘルプデスク > Tips > Linux Tips > 環境設定 >
Kudzuで認識されたハードウェア情報が知りたい
http://www.itmedia.co.jp/help/tips/linux/l0680.html

「kudzu」をonにしてから、Linuxの再起動ですね。

投稿日時 - 2008-08-09 22:54:46

補足

choconamacream様、ありがとうございます。
Ubuntuを再インストールしたところ、gdmのパスワード認証までできるのに、gdmが起動せずgdm画面に戻ってしまいます。テキストモードでのログインはできます。lsmodコマンドを使うとnic(8139cp)の組み込みが確認できています。dmesgコマンドでも確認できています。ネットワーク設定のテキストでの変更がよくわからないので、ここでは通信の可否は確認していません。

Vineは再インストールしていたら途中でこけてしまい消えてしまいましたが、再インストールする前のVineの起動時にハードウェアの構成が変わったので再構成する旨のメッセージが出て、nicを変更した記憶がありますので、ハードウェアは認識されていると思います。

誰にでもインストールできそうなUbuntuとVineの再インストールがうまくできないところを見ると、ハードがおかしい?

2008年8月12日

投稿日時 - 2008-08-12 00:15:57

ANo.3

何は、ともあれ
$ /sbin/ifconfig -a
の結果

NIC を追加して、distribution も変えても
接続出来ないとは、今の所解らない。

投稿日時 - 2008-08-09 16:26:09

補足

通信できないので、手書きします。

通信のできないKnoppixr5.0のものです。
$ /sbin/ifconfig -a

eth1 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
inet addr:192.168.1.3 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 adder : xxxx::xxx:xxxx:xxxx:xxxx/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:3 Base address:0x4c00

lo  省略

sit0 Link encap:IPv6-inIPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)


いろいろLive CDを試していたら、Ubuntu7.10でLAN内の他ホストとpingが通りました。

どうすればよいかはわかりません。

2008年8月9日

投稿日時 - 2008-08-09 19:28:10

ANo.2

よく見えないのですが、
マザーボードが、NICを認識してないって感じですかね?
再インストールをしていないのが気になったのですが
KnoppixをCD起動で見ても駄目だったのですよね?
(NICのIP設定とかは出来てる?)

インストール時にNICを認識させるのと違って後から入れるのは結構難しいです。
勿論、増設したNICも同じことが言えます。この時、KnoppixなどではオンボードのNICしか見に行かないような気もしますし。
dmesgでNICが見えているならドライバー入れ直しかカーネルのコンパイルですかねぇ。
どちらも敷居が高いです。
見えていないのならMBになにがしかの設定あり?または、初期不良ですかね?

投稿日時 - 2008-08-09 15:47:08

ANo.1

デフォルトゲートウェイは設定してありますか?

投稿日時 - 2008-08-09 14:38:38

補足

g_liar様、ありがとうございます。
デフォルトゲートウェイアドレスは、ルーターのLAN側アドレス192.168.1.254にしています。
でも、pingでLAN内ホストが通信しあうだけなら関係ないのでは?

2008年8月9日

投稿日時 - 2008-08-09 14:42:28

あなたにオススメの質問