こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

★無線LAN接続が定期的に切断されてしまいます

DELLに聞いても手に負えず困っています。
どなたか適切なアドバイスをお願いします(やや長文)。
●環境
PC側
 ノートPC:DELL Inspiron1720
 OS:WindowsVista(最新アップデート)
 アンチウィルス:キングソフト(但し、外しても同じ症状)
 無線子機:Intel Next-Gen Wireless-N(802.11a/b/g/n)DELL純正品
 子機ドライバは最新
 クライアントマネージャV(Ver.1.3.4)

アクセスポイント側
 バッファローWZR2-G300N(ファーム1.53β)
 子機との接続:AOSS(たぶんWPA-PSK)
 チャンネル:10chに固定
 IPアドレス:DHCP非使用(192.168.**.1~で固定割り振り)

素人なので、上記がわかる範囲です。この状況で、無線LAN接続を行っています。アクセスポイントの設定は初期値から殆ど変更していません。PPPoE接続設定とファーム更新くらいです。

上記の状況で、『InspironをAC電源で使っているとき』は、何も問題なく無線LAN、インターネットを楽しめています。802.11nにしては遅い(最大でも20Mbps程度)感じもしますが、実害はないですし実力としてはそんなものかなと思っています。

ところが、不思議なことに『Inspironをバッテリー駆動』すると、接続が定期的に切断、自動復活を繰り返します。バッテリーがフル充電であってもです。切断の周期はおおよそ1分ごとですが、ぴったり1分というわけではありません。また、切断している時間は5~10秒程度です。そのため、バッテリー駆動時は、頻繁にネット接続できなくなり、非常に使いづらく困っています。アクセスポイントとPCとの間に障害物はありません。同じ部屋のすぐ近くで使っても症状は変わりません。

家の中に親子電話はありますが、電源オフにしても症状は変わりません。無線検索すると、周囲でいくつかアクセスポイントがあるようですが、2,3個ですし、これが原因とも思えません。事実、AC電源の場合は問題なく通信できますので。

素人考えでは、バッテリーか無線子機、子機ドライバのどれかに問題ありそうなんですが、DELLサポートに電話すると、僕より素人の女性が、「AOSSはサポート対象外です。とにかく、子機ドライバを再インストールしてください」とヒステリックに叫ぶばかりで、一向にサポートになりません。

子機ドライバは最新が入っていますし、ACでは問題なし、バッテリーだと問題あり、という症状がドライバ再インストで解消するとはとても思えません。

手当たり次第に入れ替えや交換をする余裕がないので、最も怪しいと思われる部分に手を付けたいのですが、DELLにはそれが理解できません。バッファローにはまだ聞いてないのですが、バッファローの問題ともあまり思えません(余談ですが、他のPC(SOTECやIBM、OSはWinXP。クライアントマネージャー3で54Mbpsの無線カードを駆動)では、バッテリー駆動の際も何も問題は生じていません。)

再度、DELLかバッファローに問い合わせをする前に、自分なりに見当を付けたく、同じような症状の経験のある方や解決策の予想の付く方からのアドバイスをお待ちしています。よろしくお願いいたします。

投稿日時 - 2008-07-28 10:35:12

QNo.4209525

すぐに回答ほしいです

質問者が選んだベストアンサー

明確な回答ではないのでご容赦ください

システムユーティリティ
チップセットドライバ
ネットワークドライバ
これの最新モジュールが質問者さんがそのパソコンを購入された時点より新しい日付ならば更新するのもありです
ただし、更新内容の有効性は必ず確認してください

http://supportapj.dell.com/support/downloads/driverslist.aspx?c=jp&l=ja&s=dhs&ServiceTag=&SystemID=INS_PNT_PM_1720&os=WLH&osl=jp&catid=&impid=

投稿日時 - 2008-07-28 11:04:39

お礼

早速のご回答ありがとうございます。先ほどDELLのHPにアクセスしてみましたが、どうも繋がらないので後でまた試してみます。ただ、これらのドライバやユーティリティは、なんとなく更新するのに勇気がいる気がしますがそんなことはないのでしょうか。アップデートで、別の問題が発生したりしそうでちょっと恐いです。

投稿日時 - 2008-07-29 11:46:43

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(3)

PC側の無線LANアダプタはBAFFALO製ではないのにAOSSで設定できるのだったかな?できないはずだが?これが第一の疑問です。それと一度、AOSSでの設定ではない手作業で、有線で親機に接続し設定を確認され、PC側の設定がそれのと整合性が取れているか(特にSSIDと暗号化キーについては重要)確認されてはどうでしょう?。?LANアダプタのドライバは最新かどうかも。
なお、「アクセスポイントがIEEE 802.1X認証に対応していないのにクライアント側の設定でこれを有効にしている」という場合や「有線LANについて明示的に無効にしていない」場合とかも、要注意らしいです。

投稿日時 - 2008-07-28 12:02:16

お礼

早速のご回答ありがとうございます。WinXPでは無理ですが、WinVistaは、AOSSをサポートしていますので、子機がバッファローでなくてもクライアントマネージャさえインストールすればAOSS接続ができるんです。
ご指摘のAOSS自動設定でなく、自分でSSIDや暗号化キーを入力しての接続、は私も最初に疑ったので試しました。が、状況は一緒でした。ただ、アクセスポイントのAOSS機能そのものを無効にしたわけでないので(接続確率の際に、手動設定を選択して、SSIDなどを入力しただけ)AOSSが原因でない、とはっきり言い切れるかどうか疑問は残りますが。。。

投稿日時 - 2008-07-29 11:54:59

ANo.2

的はずれかもしれませんが、省電力機能をOffにしてみてはどうでしょうか。
デバイスマネージャで無線LANアダプタのプロパティを開き、設定に
power save modeの項目があれば、offとかdisableにしてみてはどうでしょうか。

投稿日時 - 2008-07-28 11:47:04

お礼

早速のご回答ありがとうございます。おっしゃる通りデバイスマネージャでアダプタのプロパティ内にいろんな設定箇所がありました。今、PCが手元にないので詳細をご報告できませんが、802.11*を無効にしたり、省電力機能を無効にしたり、パワーの設定を最大・中・最小にしてみたり、とりあえず元に戻せる範囲でこわごわいろんな設定を変えてみましたが、まったく状況は変わりませんでした。省電力機能にはちょっと期待しただけに意気消沈です。ありがとうございました。

投稿日時 - 2008-07-29 11:50:25

あなたにオススメの質問