こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

Microsoft .NET Framework 3.5 のインストールができない

Microsoft Visual C# 2008 Express Edition のインストールの際 Microsoft .NET Framework 3.5 のインストールができません。Visual Basic, Visual C++, Visual Web Developer のインストールの際も同じです。
WinXP Pro を使っています。
何とかインストールしたいのでよろしくお願いします。

投稿日時 - 2008-05-07 16:31:48

QNo.4004464

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

3人が「このQ&Aが役に立った」と投票しています

回答(8)

ANo.8

だめでしたか。
Framework 3.5の情報は少ないですね。

> 誰かが「すべてのプログラム」からショートカットの入ったフォルダを削除したようなのです。

これで、3.0もUpdateも出来ないのは変な感じがしますね。
また情報を収集みてみます。

なかなか回答にならず申し訳ないです。

投稿日時 - 2008-05-13 19:44:41

お礼

いえ、いつもありがとうございます。
C:\Program Files\Microsoft Visual Studio 9.0
の中のフォルダを誰かがいじくったのかもしれません。
または4月の始めに「システムの復元」で今年の3/31に戻したのも原因かもしれません。

投稿日時 - 2008-05-13 21:04:22

ANo.7

ふと、

Windows Updateすれば、どうなのでしょうか。

投稿日時 - 2008-05-13 02:59:51

お礼

やはりだめでした。。。。

投稿日時 - 2008-05-13 12:21:03

ANo.6

何かレジストリにゴミが残っているのでしょうか。

ちなみにMicrosoft .NET Framework 3.0はインストールできますか。

投稿日時 - 2008-05-12 09:55:00

お礼

いつもありがとうございます。
3.0はインストールできませんでした。
よろしくお願いいたします。

投稿日時 - 2008-05-12 12:06:22

ANo.5

Service Pack がないと言うのは、
インストールされていないと言うことでしょうか。

ちなみに、「完全な再頒布可能パッケージ」で
.NET Framework 3.5をインストールする際には、
どこで、どの様なエラーが発生したのでしょうか。

参考URL:http://www.microsoft.com/japan/msdn/netframework/downloads/20_30_sp1.aspx

投稿日時 - 2008-05-09 22:40:58

お礼

お世話になっています。

Microsoft .NET Framework 2.0 はインストールされていますが SP1はインストールされていない状態です。

エラーはすべてのダウンロード終了後、Microsoft .NET Framework 3.5 のインストール中にエラーが発生し、「セットアップは以下のコンポーネントをインストールできませんでした」とのメッセージが出てきます。

投稿日時 - 2008-05-10 13:36:56

ANo.4

NET Framework 2.0は、Service Pack 1でしょうか。

または、前述リンク先の「完全な再頒布可能パッケージ」でも
同様でしょうか。

投稿日時 - 2008-05-09 03:26:41

補足

どちらも Service Pack はないようです。
よろしくお願いいたします。

投稿日時 - 2008-05-09 14:57:28

ANo.3

あやふやで申し訳ないですが、
.NET Framework 2.0が入ってないと.NET Framework 3.5が
入らなかった時があったような・・・

投稿日時 - 2008-05-08 15:36:57

お礼

ありがとうございました。
.NET Framework 2.0はインストールされています。
3.5のインストールの段階で不具合が出るのです。
またご回答お願いします。

投稿日時 - 2008-05-08 21:01:42

ANo.2

.NET Framework がまったくインストールされていないのでしょうか?

.NET Framework 2.0とかはインストールできてますか?

投稿日時 - 2008-05-08 15:31:18

お礼

ありがとうございました。
.NET Framework 2.0はインストールされています。
3.5のインストールの段階で不具合が出るのです。
またご回答お願いします。

投稿日時 - 2008-05-08 21:02:35

ANo.1

Bate版とか入ってませんか。
リンク先の「追加情報」が参考にならないでしょうか。

参考URL:http://www.microsoft.com/downloads/details.aspx?FamilyID=333325fd-ae52-4e35-b531-508d977d32a6&displaylang=ja

投稿日時 - 2008-05-08 10:49:08

お礼

Program Files の中を調べてみましたがBeta版は入っていません。ただしMicrosoft Visual C# 2008 Express Editionは前にインストールしていましたが、誰かが「すべてのプログラム」からショートカットの入ったフォルダを削除したようなのです。それで使えなくなって再インストールを試みました。
追加情報を参照しましたがあてはらまらないようです。
どうかこれからも継続してご回答をお願いします。

投稿日時 - 2008-05-08 14:35:52