こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

KNOPPIXへのインストールについて。

はじめまして、MIA-chanといいます。よろしくお願いします。
Linuxについて何ですが、グラフィックチップの関係から、KNOPPIXに落ち着きまして、ハードディスクにインストールしました。(自己責任)教えて欲しいことなんですが、OOo2.1なので、OOo2.3にしたいと思って、OOoの公式ページのFAQとかを探してるのですが、分かりません。ダウンロードしようとすると、「office/openoffice/localized/ja/2.30/OOo_2.3.0_LinixIntel_install_wJRE_ja.ta.gzを読み込めませんでした。」と出てしまいます。
そこでお尋ねしたいのが、もともとKNOPPIXは1CDLinuxということで、インストーラがないのでしょうか?それともインストールする方法があったら教えて下さい。よろしくお願いします。

投稿日時 - 2008-03-31 23:22:35

QNo.3911629

困ってます

質問者が選んだベストアンサー

#1及び#2さんの回答は、KNOPPIXをHDDにインストールする際の話ですから、お間違えなきよう。

で、KNOPPIXをインストールして使ったことが無いのですが、本来CDから起動して使うことを想定したディストリビューションで
HDDにインストールすることも可能・・・というものですから、アプリの追加やバージョンアップは
他のディストリビューションのように、ディストリビューターが用意しているものを
ネットワーク経由で簡単にインストール&バージョン管理ができるようにはなっていないと思います。

ということで、自分で目的のパッケージを探してきてインストールする必要がありますね。

質問に書かれている「OOo_2.3.0_LinixIntel_install_wJRE_ja.ta.gz」はrpm形式のパッケージですので
KNOPPIXにインストールできなくは無いですが、かなり苦労すると思います。
OOoのサイトからdeb形式のパッケージを探してきて、それをインストールしましょう。
http://download.openoffice.org/other.html#ja
ここから、英語版の2.4.0のdebパッケージをダウンロードしてインストール後
日本語ランゲージパックを追加すると日本語版になります。

なお、最新版は2.4.0です。

投稿日時 - 2008-04-01 21:40:34

補足

回答していただいてる皆様へ。どうもありがとうございます。
ちょっとしたトラブルで、IDが変更になり、nekoyama_miaになりました。
ですので、お礼などに書き込むようになりましたので、申し訳ありませんが、よろしくお願いします。

投稿日時 - 2008-04-02 01:28:38

お礼

回答ありがとうございます。
お話に書かれてるように、解凍の件で困ってます。
フラッシュのインストールもできません。
tar -xvzf OOo_2.3.0_LinixIntel_install_wJRE_ja.ta.gzでやってみましたが、なぜかパッケージ1しか解凍されません。
set upの項目があったので、押したら英語以外はみんな豆腐でした。
簡単に解凍できると思っていましたが、勘違いでした。
いま、ネットをさまよってます。何か良い知恵が有りましたら教えていただきたいと思います。

投稿日時 - 2008-04-02 00:18:53

ANo.5

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(7)

ANo.7

#5です。

えっと、書いたことをご理解いただけなかったようですので、もう一度。

質問者さんがダウンロードされた「OOo_2.3.0_LinixIntel_install_wJRE_ja.ta.gz」というパッケージは、
rpm形式といって、fedoraなどredhat系で使われているパッケージ管理ソフト用のものです。

KNOPPIXはdebian系ですので、deb形式という別のパッケージ管理ソフト用のものを使わないと
うまくいかないですよ・・・ということを書いたのですが。

どうしてもというのなら、alienコマンドで解凍されたrpmパッケージをdeb形式に変換し、
その後dpkgコマンドでインストールという流れでなんとかなる・・・かもしれません。

それから、KNOPPIXは、あくまでもCDから起動して使うように考えられたものですので、
HDDにインストールして使うこともできますが、いろいろなソフトを追加したり、
ソフトをバージョンアップしたりして使うことは想定されていないと思います。
そういう場合は、新バージョンのKNOPPIXを再インストールするというのが前提でしょう。

どうしてもKNOPPIXでなければならないのなら別ですが、グラフィックチップの認識だけの問題でしたら、
最新版のdebianやubuntuを試して見るというほうが良いように思いますよ。

投稿日時 - 2008-04-02 06:04:31

お礼

ご回答ありがとうございます。
ちょっとまとまった休みがとれたので、日曜の晩から色々なディストリビューションをためしました。そのなかでUbuntuも試したのですが、
http://www.dff.jp/index_t.php
に、Firefoxでアクセスすると、フラッシュの関係か分かりませんが、Firefoxがフリーズしてしまうことが多く、システムまで巻き込んでしまうこともあり、ちょっと保留中です。
あと、rpm形式のことも、何処で見たか忘れましたが、.rpmを確認しました。今は、ブラウザにフラッシュプレイヤーを入れるのに解凍がうまく出来ずに悩んでるところです。

投稿日時 - 2008-04-02 10:55:58

ANo.6

下記に、2.4.0 のdeb がありますね。
OpenOffice.org 独自ビルドプロジェクトLinux deb版 (x86,glibc2.3.4以降)
http://waooo.sourceforge.jp/wiki/index.php?Download

Ubuntu での例
rpm では、alien を使うとか
dpkg とか、それ以外は参考にしないほうが良いと思うが
http://forum.ubuntulinux.jp/viewtopic.php?id=812

投稿日時 - 2008-04-02 05:58:14

お礼

ご回答ありがとうございます。

上記のやつを試してみたいと思います。

あとUbuntuはFirefoxを使うと、画面描写がおかしくなり、下手をするとシステムまで巻き込んでフリーズしてしまいます。
これについては、別のところでヒントをいただいたので、後で試してみたいと思います。

投稿日時 - 2008-04-02 10:40:53

ANo.4

> ルート権限が必要ですとメッセージがでてきているところです。
ルートとは何か。
管理者です。管理者パスワードが必要です。
suコマンドで管理者になれます。
パスワードを聞いてきます。
こうしたことは、Linuxでは基本の中の基本です。

tar.gzとは何か。展開するためにはどこにコピーすればよいか。
展開するためのコマンドは何か。
展開した後実行するためには、シンボリックリンクをどう張ればよいか。
Linuxについて、勉強することはたくさんあります。
Windowsのようには、易しくないというか、とっつきにくい
ところはあります。

投稿日時 - 2008-04-01 14:33:54

補足

OOoのインストールコマンドを勘違いしていました。
よく調べてみます。

投稿日時 - 2008-04-01 16:28:51

お礼

ご回答ありがとうございます。
なんとか、OOo2.3は落とせました。
インストール時に、名前を2カ所、パスワード2カ所要求されました。
それぞれ一つずつは、usrで使いましたが、残りの名前は使えず、もう一つのパスワードはたぶん管理者パスワードだと思うのですが、使っても失敗ですと出るので、たぶんIDが違うんだと思います。ちなみにrootもやってみましたが、「roorログインは許可されてません」とでます。

tar.gzは圧縮ファイルということだけはわかります。マックのように、ダブルクリックすればいいと思ってました。ちょうど、そこの部分を調べてたとこでした。インストールするコマンドはwest130さんの教えてくれた方法でやってみるつもりです。

どうもありがとうございます。また分からないことが出たらしつもんしますので、その時はまたよろしくお願いいたします。

投稿日時 - 2008-04-01 16:24:12

ANo.3

> OenOffice のバージョンを上げたっかたのですが、端末がSUを
> 要求してきて、すぐに端末が落ちてしまってる状態です。
どういうインストール方法をしているか不明ですが、
基本的には、OpenOfficeが今入っているところに入れないと、
パッケージ管理に問題が出るのではないかと思われます。

> GURBはデュアルブートの時に出るメッセージだって
> ような気がしまして、もう一度確認したいと思ってるところです。
いいえ、GRUBは、Linuxを動かせば、MBRを読み、GRUBへきます。
GRUBの中のカーネル情報で、システムを立ち上げようとします。
GRUBは、Windows XPのboot.iniと同じくらい重要なものです。
もう少し、knoppixと、OpenOfficeの知識の取得をした上で、
バージョンアップにチャレンジした方がよいと思われます。

knoppixのどこにOpenOfficeが入っているか、パッケージ管理を
knoppixはどうしているか、knoppixのサイトに行って調査して
ください。
また、/boot/grub/grub.confの中を見たり、Linuxの基本の勉強
も必要です。
そうあせらずに一歩一歩理解していってください。

投稿日時 - 2008-04-01 14:03:30

お礼

ご回答、ありがとうございます。
インストール方法は、west130さんの教えてくれた方法をおこなおうとしてます。
展開先は、ノーマルのKNOPPIXのとおり、application/officeにしようと思ってます。
GRUBの方は、どうして良いか分からなかったので、Ubuntuを上書きインストールして消しました。
どうもありがとうございます。
前々から興味を持っていたのですが、まとまった休みが取れたので、始めたばかりで、右も左もわからない手探り状態です。ご助言のように基本からしっかりと始めたいと思います。

投稿日時 - 2008-04-01 15:38:03

ANo.2

> それともインストールする方法があったら教えて下さい
WEBで検索されましたか。
「knoppix HDDにインストール」
で出てきますけど。
どういったインストールがご希望か、windowsとデュアルブートか、
単独か、windowsの中に取り込むのかで決められたらと思います。

KNOPPIX インストールマニュアル
http://it.open.ed.jp/school_lan/siryou/knoppix/How-HDD-Install.pdf

投稿日時 - 2008-04-01 09:57:39

補足

端末についてですが、起ち上がろうとして
「suがエラーを返しました」と出て端末が使えません。

投稿日時 - 2008-04-01 13:56:36

お礼

回答ありがとうございます。
単独での、HDDにインストールしています。
ネットで、yakan9さんの教えてくれたマニュアルと同じ物を見て
インストールしました。
OenOffice のバージョンを上げたっかたのですが、端末がSUを
要求してきて、すぐに端末が落ちてしまってる状態です。
いま何回目かのインストールをしてきたところ、急にGURBと
言う文字が出てきて、内蔵ハードディスクから起ち上がらなくなり、
CDで起動し、ハードディスクにもう一度インストールしようと
したら、ルート権限が必要ですとメッセージがでてきているところです。
たしか、GURBはデュアルブートの時に出るメッセージだって
ような気がしまして、もう一度確認したいと思ってるところです。

投稿日時 - 2008-04-01 12:10:23

ANo.1

確かにインストールのメニューはあります。
ペンギンマークをクリックしてRootShellを選択します。
ターミナル上でknoppix-installerと打ってエンター
後はインストールの画面が出るのでOKで進みます。
詳しいことは書ききれないので書店でクノーピクスの本を見てください。

投稿日時 - 2008-04-01 02:53:59

補足

すみません、勘違いがありました。
端末が、suがエラーを返しました。となり、端末が起ち上がりません。

投稿日時 - 2008-04-01 13:59:08

お礼

すいません、お返事が遅くなりまして。
他の人の所にも書いてるように、Root Shellで売っても
suが必要ですとなって、すぐにおわってしまうので、
別の名前(管理者)で入ろうとしてもパスワードが違うと行って
KNNOPIXにログインできません。
何回かCDインストールしているのですが、今度はGRUBというのが
出てきてCDでしか起動できなくなりました。
CDで起動して、ハードディスクにインストールしようとしたところ
ルート権限が必要です、と言うメッセージが出ているのが、今の状態です。

投稿日時 - 2008-04-01 12:20:28

あなたにオススメの質問