こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

おかしい/エラーが出る ネットワーク接続のエラー。エラーメッセージ:「予期しないエラーが発生しました。」

ネットワーク接続のエラー。エラーメッセージ:「予期しないエラーが発生しました。」

製品名:デスクトップ OS、サーバー OS/Windows XP

現象:おかしい/エラーが出る

PC の配線整理をした結果、これまで1年間使用していた回線が不通になってしまいました。Bフレッツをプロバイダ@niftyで利用しているのですが、NTTに点検してもらった結果、VDSL装置には問題がなく、使用しているLANケーブルも使用可の状態であることが確認できています。別PCでの回線は正常に動作するので、モデムやケーブルなど、周辺機器の問題ではなく、PC側の問題と考えています。

そこで、問題となる箇所なのですが、私は WindowsXP(HE)を使用しているのですが、ネットワーク接続の項目で「ローカルエリア接続」が赤の×印が付いており、右クリックでプロパティを開くと「予期しないエラーが発生しました。」というエラーメッセージのダイアログが出現する状況です。

LANケーブルの抜き差しをした際に。PC側のLANポートを傷つけてしまったのか、システムの問題なのかがわかりません。

また、「http://support.microsoft.com/kb/824923/ja」にある「ファイル名を指定して実行」する手順を踏もうとすると、「LoadLibrary("%システム")に失敗しました - 指定されたモジュールが見つかりません。」というエラーのダイアログが表示されます。

以上が私の抱える問題と現状です。よい解決策とアドバイスを頂けたら幸いです。

投稿日時 - 2008-02-14 01:37:23

QNo.3773960

すぐに回答ほしいです

質問者が選んだベストアンサー

書き込んで貰った結果を見る限りでは、LANカードのドライバに異常が有りOSに対して正確な情報を伝えていないか、ハード障害の可能性を示唆しています。

まずは、LANドライバをデバイスマネージャ画面で削除し、ドライバCDから再度ドライバをインストールしてみましょう。
ちなみに、「ネットワークアダプタ」というところの配下に居るデバイスになります。
(ショップブランドPCならマザーボードのオンボードLANを使っている筈。マザーボードのドライバCDにオンボードLANのドライバが入っています)

それでも状況が変わらないようなら、PCのLANケーブルを差し込む口を近くに寄って良く見てください。
LANケーブルの8線に対応する細いL字型に曲がったピンが出ているはずです。
その内の1本か2本のピンが折れていたり、存在しないということが無いか確認して下さい。

ピンを確認しても特に異常が見られないようなら、バックアップをとった後にOSのクリーンインストールを行って様子を見て下さい。

投稿日時 - 2008-02-16 22:56:12

補足

>まずは、LANドライバをデバイスマネージャ画面で削除し、ドライバCDから再度ドライバをインストールしてみましょう。ちなみに、「ネットワークアダプタ」というところの配下に居るデバイスになります。(ショップブランドPCならマザーボードのオンボードLANを使っている筈。マザーボードのドライバCDにオンボードLANのドライバが入っています)

私の知識乏しく、ドライバCDというのがどれになるのかがわかりませんm(_ _)m

差込口はライトをあて、入念に観察しましたが、傷や破損などは一切見受けられませんでした。

PC DEPOでいろいろ相談・アドバイスを受け、最終的に「答えてねっと for Business」なるサイトにていただいたご助言をもとに、LAN端子をUSBアダプタを介して接続する方法と、LANポートを新たに増設する方法を試し、この両方がうまくいきました。最終的に今増設したLANポートにて動作させています。今回質問させていただいた件に関してはこれで解決を見たということにしたいと思います。自作PCの作製経験のある方や、PCに詳しい方にも相談した結果、「原因を究明しきれなかったLANの異常は経験がある」と聞きます。
最後にご助言いただいたドライバのインストール作業は今後暇を見て試します。

投稿日時 - 2008-02-17 03:31:23

お礼

これまでの手厚いご協力に
大変感謝致しますm(_ _)mありがとうございました。

投稿日時 - 2008-02-17 03:41:28

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.3

ネットワーク構成やPCを取り巻く環境が分かったので、順を追って調べていきましょう。

>>・LANケーブルをPCとモデム等と繋いだ際に、モデム等にあるLANと書かれたLEDランプは点灯しますか?
>ランプは正常に点灯しています。モデムの以上は見つかりません。
 これに関して、こちらの意図が十分に伝わっていない可能性があるので補足しておくと、LEDのランプはOSI参照モデルで言う所のデータリンク層レベルで接続しているかを確認する為のものです。
 LANケーブルを挿した瞬間に、このLEDが点灯するなら相手側(PCのLANカード側になると思うが)はデータリンク層レベルで生きている事を意味している。
 そして通常であれば、LEDが点灯するのと同時にローカルエリア接続のアイコンの赤い×印が消え、100Mbps(又は10Mbps)で接続した旨のポップアップメッセージが出てくる。

 症状としては、LEDランプはLANケーブルを指した瞬間に点灯するが、ローカルエリア接続のアイコンにある赤い×印は消えないままという事で間違いないですか?

現時点で予想される原因は、

 ・LANカードのドライバが破損している
 ・TCP/IPプロトコルスタックが破損している
 ・OSのネットワークに関連するファイルが破損している

です。
その為、以下の作業を行いどの辺が壊れているのか見極める必要があります。

 ・問題のPCでコマンドプロンプト画面を開き、その中で
   ping 127.0.0.1
  というコマンドを入力して、結果を確認する。
 ・デバイスマネージャ画面でLANカードのデバイスに!や×や?といったマークが付いていないか確認する。
 ・ルーターを元に戻し、PCとルーターを接続した後コマンドプロンプト画面を開き、その中で
   ipconfig
  というコマンドを入力して、結果を確認する。

上記3つの確認結果を補足に書き込んで下さい。
あと確認ですが、もう一台のPCは問題のPCが不調の時もルーター経由で正常にネットに接続できていたという事で間違いありませんか?

投稿日時 - 2008-02-15 02:28:54

補足

>・問題のPCでコマンドプロンプト画面を開き、その中で「ping 127.0.0.1」というコマンドを入力して、結果を確認する。
-------------------
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.
C:\Documents and Settings\hitosi>ping 127.0.0.1

Pinging 127.0.0.1 with 32 bytes of data:

Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128

Ping statistics for 127.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms
----------------------
上記がping 127.0.0.1の結果です。


>・デバイスマネージャ画面でLANカードのデバイスに!や×や?といったマークが付いていないか確認する。

具体的に、「LANカード」とは「ネットワークアダプタ」のことなのでしょうか??デバイスマネージャ内では、「イメージングデバイス」の「PC Camera」に「!」マークがあるだけで、それ以外には何のエラー記号も付加されていませんでした。


>・ルーターを元に戻し、PCとルーターを接続した後コマンドプロンプト画面を開き、その中で「ipconfig」というコマンドを入力して、結果を確認する。

-----------------
Microsoft Windows XP [Version 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\hitosi>ipconfig

Windows IP Configuration


Ethernet adapter ローカル エリア接続:

Media State . . . . . . . . . . . : Media disconnected

Ethernet adapter ローカル エリア接続 3:

Media State . . . . . . . . . . . : Media disconnected

C:\Documents and Settings\hitosi>
------------------
上記が「ipconfig」の結果です。


>あと確認ですが、もう一台のPCは問題のPCが不調の時もルーター経由で正常にネットに接続できていたという事で間違いありませんか?

現在、BBR-4MG(Buffalo)を使用し、有線でVAIO(SONY)が正常に動作しております。問題のPCはfusion(パソコン工房)です。

「ipconfig」というコマンドは以前にも使用したことがあるのですが、今回実行したような簡単な結果しか返ってこないものなのでしょうか??正しく提示できているのか心配です。

宜しく御願いします。

投稿日時 - 2008-02-15 18:53:28

ANo.2

まず

 ・ネットワーク構成を教えて欲しい
  (有線なのか無線なのか、ルーター,ハブ,他のPCの存在の有無)
 ・LANケーブルをPCとモデム等と繋いだ際に、モデム等にあるLANと書かれたLEDランプは点灯しますか?

辺りから情報提供願います。

投稿日時 - 2008-02-14 14:07:07

補足

早速の回答に感謝します。

>・ネットワーク構成を教えて欲しい
>  (有線なのか無線なのか、ルーター,ハブ,他のPCの存在の有無)

ネットワークは全て有線で、以前の通常動作時には、他のPC(SONY:VAIO)と現状問題となっているPCでルータ(BUFFALO:BBR-4HG/4MG)を使用していましたが、今この問題を対処している中ではルータは使用していません。

>・LANケーブルをPCとモデム等と繋いだ際に、モデム等にあるLANと書かれたLEDランプは点灯しますか?

ランプは正常に点灯しています。モデムの以上は見つかりません。


宜しく御願い致します。

投稿日時 - 2008-02-14 16:58:34

ANo.1

>また、「​http://support.microsoft.com/kb/824923/ja​」にある「ファイル名を指定して実行」する手順を踏もうとすると、「LoadLibrary("%システム")に失敗しました - 指定されたモジュールが見つかりません。」というエラーのダイアログが表示されます。

regsvr32 %システム ルート%\system32\netshell.dll

regsvr32 %システム ルート%\system32\ole32.dll
とやってもダメですよ。

regsvr32 %SystemRoot%\system32\netshell.dll

regsvr32 %SystemRoot%\system32\ole32.dll
とやらないと。

投稿日時 - 2008-02-14 09:12:06

補足

ありがとうございます。

ご指摘の箇所を訂正し、実行したところ、「予期しないエラーが発生しました。」のダイアログがでなくなり、プロパティが開けるようになりました。

投稿日時 - 2008-02-14 17:10:44

お礼

無事に回線が開通しました、ありがとうございました。

投稿日時 - 2008-02-17 03:42:32

あなたにオススメの質問