こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Linuxでmakeが実行出来ません

Linuxの素人です。
RedHatLinux7jをインストールして、PostgreSqlを実行したいと考えています。
(Apache+PostgreSql+PHP)
そこで、本を見ながらPostgreSqlのソースを展開した後に、
シェルで「make」を入力してみましたが、正しく実行してくれません。
メッセージは下記の様に表示されました。
[postgres@server1 src]$ make
You must use GNU make to use Postgres. It may be installed
on your system with the name 'gmake'.

NOTE: If you are sure that you are using GNU make and you are
still getting this message, you may simply need to run
the configure program.
[postgres@server1 src]$ gmake
「gmake」を入力しても、同じメッセージが表示されます。
コンパイルを可能にするにはどうしたらよいでしょうか?

宜しくお願いします。

投稿日時 - 2001-02-07 15:11:04

QNo.37625

困ってます

質問者が選んだベストアンサー

表示されたメッセージに、「gmakeを使ってもうまくいかなければ、configureを実行してくれ」と書いてありますが、すでにconfigureは実行済みですか?

投稿日時 - 2001-02-07 15:16:29

お礼

有難うございます。
configureは実行していると思っていました。
でも、エラーが出ていたのを見落としていたみたいです。
環境を整えて再度チャレンジしてみます。

投稿日時 - 2001-02-07 17:09:47

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(2)

ANo.2

userの環境がちゃんとなっていないんじゃないでしょうか?

このメッセージはよく/bin/sh以外のシェル環境で実行すると出ますよ。
自分のルートの環境変数をよく見てみてください。

投稿日時 - 2001-02-07 15:34:56

お礼

有難うございます。
少し先に進めそうです。
素人なので、又分からなくなると思います。
その時は、宜しくお願いします。

投稿日時 - 2001-02-07 17:14:41

あなたにオススメの質問