こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

symfonyのインストールでエラー

ローカルなWindowsXP マシンに、
Apache 2.0.59
mySQL 5.0.18
PHP 5.2.5
をインストールし、
PEARをアップグレードして、1.7.0 です。
symfony を学習するつもりで、PEARインストールを
実行しましたが、エラーとなります。
----------------------------------------------------------------
C:\php>pear version
PEAR Version: 1.7.0
PHP Version: 5.2.5
Zend Engine Version: 2.2.0
Running on: Windows NT 800M7-070117-02 5.1 build 2600

C:\php>pear channel-discover pear.symfony-project.com
Adding Channel "pear.symfony-project.com" succeeded
Discovery of channel "pear.symfony-project.com" succeeded

C:\php>pear install symfony/symfony
No releases available for package "pear.symfony-project.com/symfony"
Cannot initialize 'channel://pear.symfony-project.com/symfony', invalid or missi
ng package file
Package "channel://pear.symfony-project.com/symfony" is not valid
install failed
----------------------------------------------------------------
自分では、解決策がわかりません。
アドバイスを頂ければ、うれしいです。
よろしくお願いします。

投稿日時 - 2008-02-04 12:03:12

QNo.3743323

困ってます

質問者が選んだベストアンサー

試していないのでチャンネルの存在確認はしていませんが、
一度symfonyのファイルをダウンロードしてきて、それを
インストールしてみてはいかがでしょうか。

pear install symfony-stable.tgz

こんなことして、直接ファイルからインストールできたと
思いましたが。

投稿日時 - 2008-02-04 21:37:58

お礼

アドバイス、ありがとうございます。

実は、PEAR のバージョンに問題があったようです。
PHP5.2.5 を再インストールして、
C:\php>pear version
PEAR Version: 1.6.1
PHP Version: 5.2.5
Zend Engine Version: 2.2.0
Running on: Windows NT 800M7-070117-02 5.1 build 2600
としましたら、正常にインストールできました。
pear upgrede PEAR
で、PEAR Version: 1.7.0 にすると、ダメみたいです。
原因はわかりません。
ですが、とりあえず、symfony は、使えそうなので、
これで、良し!とします。
ありがとうございました。

投稿日時 - 2008-02-05 09:53:16

ANo.1

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(1)

あなたにオススメの質問