こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

Vine Linuxの"apt-get upgrade"の不具合

Vine4.1を使っています。
"apt-get upgrade"で次の現象が出ていますが、解決策がわかりませんでしょうか。
2008年1月12日

# apt-get update
# apt-get upgrade
パッケージリストを読みこんでいます... 完了
依存情報ツリーを作成しています... 完了
以下のパッケージがアップグレードされます:
kernel-doc kernel-source
以下のパッケージが新たにインストールされます:
kernel-devel#2.6.16-0vl76.28 kernel-module-madwifi#0.9.3.3_2.6.16_0vl76.28-0vl0.42.1
kernel-module-ndiswrapper#1.27_2.6.16_0vl76.28-0vl2
アップグレード: 2 個, 新規インストール: 3 個, 削除: 0 個, 保留: 0 個
E: 問題を解決することができません。こわれたパッケージがあるようです。

$ uname -a
Linux vine.myhome 2.6.16-0vl76.3 #1 SMP Sun Jun 17 14:32:18 JST 2007 i686 athlon i386 GNU/Linux

$ rpm -qa | grep -e kernel-doc -e kernel-source -e kernel-devel -e kernel-module-madwifi -e kernel-module-ndiswrapper

kernel-doc-2.6.16-0vl76.3
kernel-source-2.6.16-0vl76.3
kernel-devel-2.6.16-0vl68
kernel-devel-2.6.16-0vl76.3
kernel-module-madwifi-0.9.3_2.6.16_0vl68-0vl2.r1770
kernel-module-madwifi-0.9.3_2.6.16_0vl76.3-0vl4.r1770
kernel-module-ndiswrapper-1.27_2.6.16_0vl68-0vl2
kernel-module-ndiswrapper-1.27_2.6.16_0vl76.3-0vl2
以上

投稿日時 - 2008-01-12 15:28:56

QNo.3672958

困ってます

質問者が選んだベストアンサー

小生も、4.1でapt-get upgradeを実行したところ、”こわれたパッケージがあるようです”との表示がありましたが、Vine Linuxは、2007年12月に4.2にバージョンアップされていますので、気にせずそのままバージョンアップしました。いまのところ特に問題はありません。バージョンアップされればよいのではないでしょうか。

投稿日時 - 2008-01-13 16:38:34

補足

本日、"apt-get upgrade"したところ、問題なくアップグレードできました。
質問から5日ぶりですが、その間何もしていません。
2008年1月17日

$ apt-get update
$ apt-get upgrade
以下のパッケージがアップグレードされます:
kernel-doc kernel-source mkinitrd
以下のパッケージが新たにインストールされます:
kernel#2.6.16-0vl76.28 kernel-devel#2.6.16-0vl76.28
kernel-module-madwifi#0.9.3.3_2.6.16_0vl76.28-0vl0.42.1
kernel-module-ndiswrapper#1.27_2.6.16_0vl76.28-0vl2
アップグレード: 3 個, 新規インストール: 4 個, 削除: 0 個, 保留: 0 個
77.0MB のアーカイブを取得する必要があります。
展開後に 62.8MB のディスク容量が追加消費されます。
続行しますか? [Y/n]

投稿日時 - 2008-01-17 06:37:15

お礼

mtaka_2007樣、ありがとうございます。
現在、問題のPCが手元にないのですが、別のVine4.1のPCに"apt-get upgrade"すると、同じようなアップグレード内容となりながら、何ら異常なメッセージはなく作業できました。
リポジトリの4.2への移行の中で一時的におかしかったのかもしれません。
2008年1月13日

投稿日時 - 2008-01-13 22:38:25

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.2

Synapticでアップデートしてみて破損パッケージが
見付かるようであれば

編集(E)→破損パッケージの修復

を試してみてはどうでしょうか?

投稿日時 - 2008-01-13 01:42:04

お礼

don_go樣、ありがとうございます。
しばらくの間、該当の機種をいじれないので、確認が数日後になります。
2008年1月13日

投稿日時 - 2008-01-13 12:53:57

ANo.1

これを見る限り、なんとなく正しくアップグレード、インストール
されているようですけどね。
あとは、logで確認されるか、システム管理から
Synapticパッケージマネジャのカーネルで確認されることでしょうね。

もうひとつ、/bootで、カーネル更新を確認されて、正しく更新され、稼動できていればよいとは思います。

> E: 問題を解決することができません。こわれたパッケージが
> あるようです。
このエラーメッセージが気になるところですが、上記のことを
確認され、0vl76.28 と0vl76.3の関係を、Synapticパッケージ
マネジャのカーネルで確認すればよいと思います。

私の場合、4.2に上げてしまっているので、同じではないのですが、
0vl76.28 になっております。

投稿日時 - 2008-01-12 23:46:36

お礼

yakan9樣、ありがとうございます。
しばらくの間、該当のPCから離れているので、確認が数日後になります。

使っているカーネルが2.6.16-0vl76.3なのに、apt-getが2.6.16-0vl76.28関連にupgradeしようとしているのがおかしいように思います。
2008年1月13日

投稿日時 - 2008-01-13 12:57:37

あなたにオススメの質問