こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

スリープから復帰すると、CPU使用率が下がらない。

【パソコン環境】
 機種: DELL Inspiron 530S
 OS: Windows Vista Home Premium
 CPU: Intel Core2Duo E6750 2.66GHz
 メモリ: 2GB
 セキュリティーソフト:Mcafee SecurityCenter7.2
【症状】
Vistaは「スリープ機能」が使い勝手が良いとのことで、日々使用しています。しかし、パソコンをスリープ状態にしてその後復帰すると、使用率が常に上昇しています。(ガジェット:CPU&ME merter2数値です)

通常の電源投入(再起動含む)では問題ありません。

インターネットを複数画面開いてて
・通常起動時・・・CPU1:0%~5% CPU2:CPU1:0%~5%
・スリープ復帰時・・・CPU1:40%~60% CPU2:CPU1:80%~90%

こんな状況です。

知識的に強く無いなりに、どのプロセスがCPUを占有しているのか調べてみましたが、特に負担になっているものはなさそうな感じです。

いろいろサイト検索してみましたが、みなさんはあまりこの症状が出てないのか、情報が少なく解決には至りませんでしたので、こちでお助けいただければと思います。

Q1:どうすればこの症状は解決するのでしょうか?
Q2:これは個体(DELL530S)の問題なのでしょうか?

ご回答よろしくお願いします。

投稿日時 - 2007-12-23 10:35:55

QNo.3620794

暇なときに回答ください

質問者が選んだベストアンサー

もしもご貴殿がUSB接続でキーボードやマウスを使っておられるようでしたら、
・「コントロールパネル-マウス」を選択
・「ハードウェア」タグをクリック
・更に「プロパティ」ボタンをクリック
・マウスのプロパティ表示で「電源の管理」タグをクリック
・「このデバイスで、コンピュータのスタンバイ状態を解除できるようにする(D)」のチェックを外して「OK」する。

更に「キーボード」も上記と同じ要領でチェックを外します。

(もし上記項目がなければドライバをいったん削除して手動でWindows標準のドライバをインストールしなおせばこの項目が表示するはずです。)

この設定にすると、「スリープ」からの復帰は本体の電源ボタンを押さなければなりませんが、私はこれでご貴殿とまったく同じ症状が解消できました。
(ちなみに私はDELLのInspiron530です)

以上、よければダメもとで一度お試しください。

投稿日時 - 2008-01-02 01:16:04

お礼

Funky875さん ありがとうございます。

おっしゃるとおり、ものの見事に解消しました!
ありがとうございます!

正直、スリープを使うのはあきらめて、毎回電源を落として使用しておりましたが、これでスリープ機能を使えそうです。
助かりました。

ただ、先の例も(また症状が戻ってしまう)ありますので
しばらく様子を見てみようと思います。

ありがとうございました。

投稿日時 - 2008-01-03 00:31:59

このQ&Aは役に立ちましたか?

6人が「このQ&Aが役に立った」と投票しています

回答(3)

ANo.2

ガジェットや常駐ソフトをひとつひとつ外していって、症状が改善されるか調べてみてください。
(サイドバーの上で右クリック→プロパティ→「Windowsの起動時にサイドバーを開始します」のチエックを外す。常駐ソフトはファイル名を指名して実行→msconfigと入力→スタートアップタブ→チェックを外して再起動)
原因特定のためにレジストリは元に戻しておいたほうがいいと思います。

あと、症状がCPU使用率が高いことだけならあまり関係がないと思いますが、USBやiLINK機器などを接続している場合、Vistaではスリープからの復帰時に不具合があるようです。

投稿日時 - 2007-12-23 13:53:30

お礼

azzurraさん 返事が遅くなり申し訳ありません。

ご指示の通り試してみましたが、改善はされませんでした。
通常電源の投入では問題なく、スリープからの復帰時のみ症状がでるのがシロウトの私には理解できないところです。

http://oshiete1.goo.ne.jp/qa3288831.html
(4)余談
現在DPCはマルチCPU、つまりCore 2 Duo等との相性があまり良くない為、質問者と同じ症状で困っている人は多くいると思われます。マルチCPUやそれと連携するシステムの更なる向上を待つのが現状です。

でコメントされてますように、“待ち”しかないのでしょうか・・・。

アドバイスありがとうございました。

投稿日時 - 2007-12-25 01:47:56

ANo.1

このあたりが参考になるかもしれません。
http://okwave.jp/qa3288831.html

投稿日時 - 2007-12-23 11:00:10

お礼

azzurraさん ありがとうございます。

回答を参考に対処してみました。

→HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\NDIS\ParametersにあるProcessorAffinityMaskの値を0にする

を行った結果、直後のスリープからの復帰の際にはCPU使用率が下がり、「おぉ~スゲーっ!」って思ったのですが、その後何度か繰り返すうちに、同じ症状に戻ってしまいました。

→再発の際は再度同作業を行う。

も、効果(症状の改善)はありませんでした。

さらに何かご指南いただけることがありましたらよろしくお願いします。

投稿日時 - 2007-12-23 11:51:51

あなたにオススメの質問