こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

ビデオカードのドライバーを入れると不具合が

今まで使っていた自作PCのCドライブのHDDが突然壊れて起動しなく
なったので、新しいHDDを購入してOS(WinXP Home)の再インスト
ールをしました。OS、M/B付属のチップセットドライバ、XP SP2、
無線LANクライアントソフト、M/B付属のユーティリティ(ドライバの
自動更新ソフト)のインストールとそれを使ったチップセットドライ
バの最新版への更新という順序でインストールを行い、ここまでは
何のトラブルも無く再インストールが出来ていました。
次にOSもSP2をあてたし、チップセットドライバも更新したからと、
ビデオカードのドライバをカード付属のCD-ROMからインストール
して、指示に従い再起動したところ、800×600ピクセル・色は最低
(4ビット)でしかWindowsが起動しません。デバイスマネジャーで
ディスプレイドライバを削除して再起動すると色は32ビットに戻り
ます。OSを頭から再インストールするなど、手順を確認して3回程
繰り返しましたが、いつもビデオカードのドライバをインストール
して再起動すると、同じ現象です。また、ATIのサイトから、直接
Catalystドライバをダウンロードしてみましたが、インストールす
ると、同じ症状が出てアンインストールしました。
対策をご教示下さい。

OS:WinXP Home + SP2(CD-ROMは別)   
CPU:Pen4 2.6G(Northwoodコア)
M/B:MSI 865PE Neo2-FIS2R (BIOSは最新版へ更新済み)  
V/C:GIGABYTE R96128D(Radeon 9600チップ AGP8X)

投稿日時 - 2007-11-18 21:10:18

QNo.3528937

すぐに回答ほしいです

質問者が選んだベストアンサー

気になる点を幾つか・・・

1)
>M/B付属のチップセットドライバ
>それを使ったチップセットドライバの最新版への更新

ならば最初から最新verをインストールすれば宜しいと思いますが?
http://downloadcenter.intel.com/Product_Filter.aspx?ProductID=816&lang=jpn

2)
Radeon 9600ですから最新(7.9/7.10等)のcatalystは避けた方がいいでしょうね。
5.5あたりが適していると思われます。
http://support.ati.com/ics/support/default.asp?deptID=894&task=knowledge&questionID=19460
ドライバは
Low Speed項のDisplay Driver(1of4)
日本語対応cccは
Low Speed項の
Also available in a bundle supporting English, French, German, Japanese,
Simplified Chinese and Spanish.のリンクをクリック。
(インストール前にMS.NET Frameworkをインストールの事)

しかしながら、付属CDからのドライバインストールで症状が出る事と
>ディスプレイドライバを削除して再起動すると色は32ビットに戻り
の事から、SP2付属のドライバがインストールされているものと思われます。
>ドライバのバージョン情報などが、さも正常に~
そのverから、自分がインストールしたものか勝手に認識したものか判断つきませんか?
とはいえ、当方のRADEON9600ではこのような現象は起こらないので・・・?です。

http://www.daw-pc.info/windows/inst.htm
の手順で今一度インストールしては如何でしょう?
XPのあとにSP2にするか統合CDを作るかでしょうか。
http://wikiwiki.jp/faqwinsppm/
RADEONの場合は手順が重要のようです。

投稿日時 - 2007-11-21 21:04:45

補足

返信が遅くなりまして済みません。帰宅時間が遅くて平日は殆ど
PCをさわれませんので。
1)に関してですが、M/B付属のCDを使って、必要なドライバ
を一括でインストールしたのですが、チップセットドライバはかな
り古いバージョンが入ってしまったので、それだけはとりあえず
すぐ更新したという次第です。

昨日は休みだったので、時間をかけて再度OSのインストールから
やり直しました。MS .NET Framework2.0も
入れてからディスプレイドライバを入れてみたのですが、結果は
変わらずでした。

投稿日時 - 2007-11-24 12:43:01

このQ&Aは役に立ちましたか?

1人が「このQ&Aが役に立った」と投票しています

回答(4)

ANo.4

>付属のCDから当時のバージョンのディスプレイドライバ

ですから#2でも書きました通り、旧verのほうが適していると・・・。

>当時の9.0bを入れ

無印XPの元は8.1ですが、SP2にすると9.0cになります。
なのでこれも無くてもいい作業ですけど。

順番が違いますが、納得できたのならそれでいいですが(汗
結局グラフィックドライバが原因だったようですね。

投稿日時 - 2007-11-28 14:43:26

お礼

度々ご回答、済みません。

>ですから#2でも書きました通り、旧verのほうが適していると・・・。

というよりも、SP2を先に入れたのが原因のような気がします。
ここに相談する前に付属CDの当時の旧Verのドライバは、繰り返し
入れてみては失敗してましたので。ただし、今まではディスプレイ
ドライバを入れる前に必ずSP2とWindowsUpdateをインストール
済みの状態で、作業していたという事が唯一の違いです。

教えて頂いたOSインストール順を解説したサイト、私もここに
相談する前に偶然検索して見つけていたので、ディスプレイドライバ
を入れる前にはSP2やパッチを悉く入れていたわけなのですが、
SP2を先に入れることは私の環境ではやめたほうが良いという
事のようです。

投稿日時 - 2007-11-28 15:11:51

ANo.3

Intel Chipset Driverの更新は不要な作業。
付属CD-ROMは使わず最初から最新版入れればいいです。

>MS.NET Framework2.0

グラフィックドライバに必要なのではなく、c.c.c.の動作に必要なだけです。

>結果は変わらずでした

その時のデバイスマネージャのディスプレイアダブタの表記は
問題ないようですから、インストールされていると思います。

モニターは何をお使いですか?
モニターのデバイス情報は読み込ませたのでしょうか?
画面のプロパティ>設定>詳細設定>モニタタブの
モニタ名は何と表記されていますか?

また「このモニタでは表示できないモードを隠す」のチェック外したら
解像度変更出来ますか?

投稿日時 - 2007-11-26 15:54:54

お礼

今まで、色々とアドバイスを頂きましてありがとうございました。
バタバタしてこのサイトにアクセス出来なかったのですが、月曜の
深夜、パソコンが復旧出来ました。

今まで、OS、SP2、チップセットドライバ、ダイレクトX、
様々なWindows関係の更新パッチなど、ディスプレイドライバ
をインストールする前に、更新しておくべきと思われるものは、全て
最新版を入れてからディスプレイドライバを入れていたのですが、
ふと思いついてこのPCを初めて組み立てた2004年1月当時の
手順をなぞってみたら、モニターが綺麗に使えるようになりました。
当時はSP2もダイレクトX9.0cも無かったなあと思い出した
事から試してみたんですけれど。

OSを入れたあと、SP2やWindowsUpdateは一切後回しで、M/Bに
付属のユーティリティCDから、当時のバージョンのチップセット
ドライバを入れ、ダイレクトXもビデオカード付属のCDから
当時の9.0bを入れ、たったそれだけを入れた状態で、次に
ビデオカード付属のCDから当時のバージョンのディスプレイ
ドライバを入れたら、これが見事に成功しました。
モニターがうまく使える事を確認し、ATiのコントロールパネル
で色も解像度も最適に調整してから、SP2やOSのパッチ、ディス
プレイドライバの更新など、現在更新しておくべきものを更新しま
した。以来、故障する前と同様に全く問題無く使えております。

投稿日時 - 2007-11-28 10:56:50

ANo.1

リブート後の800*600の時、デバイスマネージャではどのような表示になっていますか?
RADEON9600と認識されているなら、削除せず単に解像度を
手動で変更保存できませんか?

またモニター*.infを読み込ませ、正式なモニター情報を
認識させてどうか。
(モニター情報ファイルは製品添付またはメーカーサイトにあると思います)

認識されていない場合は、
http://www4.zero.ad.jp/Angel.Omega/Tips.htm#inbox
を参考にドライバを入れ直してみては?

投稿日時 - 2007-11-19 14:24:56

補足

ご助言を頂きながら、御礼遅れて大変失礼致しました。

取り急ぎ、ご報告しますと、リブート後のデバイスマネジャーは
RADEON9600と表示されており、デバイスのプロパティを開くと
「このデバイスは正常に作動しています」と表示され、ドライバ
のバージョン情報などが、さも正常にインストールされたように
表示されています。
また、リブート後の画面のプロパティを開きますと、解像度の調整に
ついてはスライダが800×600の位置から全く動かせません。
一応、スライダの表示は出ているのですが、マウスでクリックしても、
スライダが左端の800×600の位置に張り付いていて、動かせ
ません。
また、画面の色のほうも、プルダウンメニューを開くと「最低(4
ビット)」以外の選択肢が表示されないので、手動での変更が不可能
という状況です。

投稿日時 - 2007-11-21 18:31:38

あなたにオススメの質問