こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

締切り済みの質問

pearが機能しない

いつもお世話になっております。
今回は自宅サーバーにてPHPを使用したいと思い、yumでインストールしました。phpinfo()や簡単phpは問題なく動作するのですが、pearを使用しようと思ったので、まったく動作しません。
サンプルソースでは一番上に「クラスのテスト」としか表示されません。
php.iniの設定箇所[include_path]を
/usr/share/pearとしました。
yumでインストールやアップデートをするとpear関連はここにはいっていると思われるのでそうしましたが、ダメでした。

下記がサーバーの状態です。
os:CentOS 4
php:5.1.6
apache:2.0
phpinfo()でのinclude_pathの値:.:/usr/share/pear

以下サンプルソース
<html>
<head>
<title>クラスのテスト</title>
<meta http-equiv="Content-Type" content="text/html;charset=Shift_JIS">
</head>
<body bgcolor="#FFFFFF" text="#000000">
<font size="4">クラスのテスト</font>
<br><br>
<?php
require_once "XML/RSS.php";
$xmlrss = new
XML_RSS("http://pcweb.mycom.co.jp/haishin/rss/index.rdf");
$xmlrss->parse();
$info = $xmlrss->getChannelInfo();
$info['description'] = mb_convert_encoding($info['description'],'EUC','UTF-8');
?>

<h1><a href="<?=$info['link']?>"><?=$info['title']?></a>記事ヘッドライン</h1>
<font size="2"><?=$info['description']?></font><br>
<hr><font size="2"><ul>
<?php
foreach($xmlrss->getItems() as $item){
$title = mb_convert_encoding($item['title'],'EUC','UTF-8');
?>
<li><a href="<?=$item['link']?>"><?=$title?></a></li>
<?php
}
?>
</ul></font>
</body>
</html>
以上になります。
どうすればpearが機能するようになりますでしょうか?
ご助言いただけたらと思います。
宜しくお願いいたします。

投稿日時 - 2007-10-08 03:44:01

QNo.3410512

すぐに回答ほしいです

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(1)

ANo.1

インストールの状況がよくわからないのですが、pearをインストールした後、pearコマンドで個々のライブラリをインストールされているのでしょうか。単に、pearをインストールしただけで、pearコマンドを実行していない、ということはありませんか。

投稿日時 - 2007-10-09 10:45:54

あなたにオススメの質問