こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

mySQLのインストール関連

phpを勉強しております。mySQLのインストールまわりでの質問です。
インストール手順
(1)php-5.0.4-Win32 ・・ok
(2)mySQL V4.1.13  ・・ok
(3)php.iniに、extension=php_mysqli.dllを追加して、Apache再起動・・ok
(4)php-5.2.4-Win32をインストール
(5)php.iniに、extension=php_mysqli.dllを追加して、Apache再起動
Apache再起動時に下記ポップアップエラーが出てしまいました。
「プロシージャエントリポイント mysql_get_charactor_set_infoがダイナミックライブラリLIBMYSQL.DLLから見つかりませんでした。」
このポップアップのOKボタンを押すと、またすぐ、同じエラーメッセージのポップアップがでます。もう一度OKボタンを押すと、Apacheは立ち上がり、phpinfo等は、動きます。

php.iniの設定は、mysql関連は上記(5)の1行だけではないのでしょうか。
よろしくお願いします。

投稿日時 - 2007-10-02 23:41:35

QNo.3396399

困ってます

質問者が選んだベストアンサー

見つからないという関数(charactor は character のtypoですよね?)は
5.0以降のものにあるAPI関数のようです。

MySQL AB :: MySQL 4.1 リファレンスマニュアル :: 11.1.2 C API 関数の概要
http://dev.mysql.com/doc/refman/4.1/ja/c-api-function-overview.html

MySQL AB :: MySQL 5.1 リファレンスマニュアル :: 23.2.3.26 mysql_get_character_set_info()
http://dev.mysql.com/doc/refman/5.1/ja/mysql-get-character-set-info.html

5.2.4のほうのPHPがMySQL5を要求していたりしませんか?

投稿日時 - 2007-10-03 00:26:52

補足

具体的な回答、ありがとうございました。
MySQL V5をインストールすべきなのですね。

確認1
MySQL V5というのは、製品安定度(品質)は問題ないのでしょうか
確認2
PHPとのバージョン組み合わせ面は問題ないのでしょうか
 PHP-5.2.4 ←→ MySQL-5.1
以前、バージョン同士の組み合わせの整合性には注意が必要・・
とか言ったことを聞いたことがあるので、質問しました。
よろしくお願いします。

投稿日時 - 2007-10-05 00:11:41

お礼

MySQLの件、V5のインストールが、ほぼ、できました。
回答ありがとうございました。

「ほぼ」というのは、DBツールからですと、内容が見えますが、PHPから、まだ connectで、エラー状態です。
もう少し、頑張ってみます。

投稿日時 - 2007-10-17 21:40:59

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(1)