こんにちはゲストさん。会員登録(無料)して質問・回答してみよう!

解決済みの質問

自宅サーバを設置したいですが

当方が現在、24MbpsのAフレッツを使っております。自宅でwindows(192.168.1.2)とLINUX(192.168.1.19)が一台ずつあります。ルータのDHCPがONにしました。windowsはIPを自動取得、LINUXのIPは固定です。
WINとLINUXをスイッチでLANを組んで、そのLANをルータ(型番:ADSLモデムNV)につないでおります。WINでもLINUXでもインターネットへアクセスできます。
でも、Linuxをサーバとして使いたいのですが、WANからなかなかアクセスできません。
ルータのNATをちゃんと設定しました。WAN側の80ポートを192.168.1.19の80ポートへ、WAN側のFTP、telnet、SSHポートもちゃんと192.168.1.19のポートへ指しました。それにしてもだめです。
他のサイトで自分のWAN側のIP(例えば1.2.3.4)を取得し、ブラウザーにhttp://1.2.3.4にしてみたらだめです。FTPクライアントを開いて1.2.3.4へ接続してみたらだめです。SSHでつないでみたら相変わらずだめです...(LINUXのサービスはちゃんと動いています。HTTP、FTP、SSH何れも192.168.1.19へ接続できます)

tracertで調べてみたら、
Tracing route to www.l.google.com [66.249.89.104]
over a maximum of 30 hops:
1 <1 ms <1 ms <1 ms modemnv-***** [192.168.1.1]
2 15 ms 15 ms 16 ms 61.207.30.102
3 15 ms 15 ms 14 ms 61.207,30.97
4 18 ms 17 ms 17 ms 122.1.165.213
......
ですが、あるネットサイトで見た自分のIPは219.162.33.*です。全く迷ってしまいました。

例えばインターネットのどこかから自分のLinuxへアクセスとする場合、そこから自分のルータまで必ずNTTさんのネットを経由するわけだと思います。そこで質問です:
NTTさんのネットで、何かゲートウェイみたいのがあって、自分のサーバへのアクセスリクエストはそこで捨てられたという疑いがありますが、本当ですか?
それとも、自分のどこかの設定不当ですか?

同じ問題で二年以上も困ってます。いろいろ調べましたが結局だめです。
どなた手伝ってください。

投稿日時 - 2007-08-24 22:40:10

QNo.3283713

困ってます

質問者が選んだベストアンサー

疑うと問題と思われる範囲が広がりますが、結構少ない要素で
WEBサーバは機能します。

それと問題を広げ無い様に、WEBサーバに絞って、ポートも80の
みでテストするのがいいと思います。

まず、linuxのWEBサーバがちゃんと動いているとのことですが、
Winodowsマシンから、ローカルIPアドレスでブラウズからアクセ
スして表示が出来るのであれば問題が無いでしょう。

その上で、ルータのポート80をLinuxのポート80にNATしてWEBサーバ
がインターネットで見れないハズは無いでしょう。

質問の中にも書かれていますが、LAN内で自分のグローバルアドレス
へのアクセスはプロキシの設定が必要です。なので外部からアクセス
してみるのが一般です。

それで見れないのであれば、私はルータの設定がどうなのかな?と
思います。

それ以外に、考えないといけない要素は無いのではないでしょうか。

私は細かいところまで分からないのですが、WEBサーバをOpenSUSEで
実現したときには、どうも自動でプロキシの設定がされていたようで
LAN内で自分のグローバルアドレスへアクセス出来ていました。
現在はWEBサーバはWindowsで、携帯電話で最終確認はすることもあり
ますが、大体、兄弟にアクセスして貰って確認しています。

投稿日時 - 2007-08-24 23:37:27

補足

早速のご回答ありがとうございます。
ルータで確認しましたが、NATではなく「静的IPマスカレード」という機能を使っています。ブラウザーでルータのセッティングページを開いて、NATを設定してみますと「複数固定IPサービスを有効にしないとNATを使えない」というウォーニングメッセージがでました。ネットで調べてみたら、NATはローカルIPを丸ごとグローバルIPへ変換、IPマスカレードはポートまで変換するものであるらしいです。自分の場合では「IPマスカレード」のほうを使用すべきですよね?

私もTasuke22さんと同じ思いがしております。ルータで「静的IPマスカレード」をちゃんと設定しましたのに、インターネットで見れないはずは無いと思いますね。必ずどこかで遮断されたと思います。今考えれば、自分のルータのところと、ルータより一つ上のNTTさんのサーバのところのいずれかだと思います。
先ほどもう一度やってみましたが、インターネットで自分のIPを表示できるサイトを開いて、自分のIPは222.145.54.133であるらしいです。ブラウザーで222.145.54.133を開いてみたらやはりだめですが、pingはOKです。ここでまだ疑いがあります:自分のルータの「ping応答機能」がOFFになっているのに...この222.145.54.133は本当に自分のルータですか?もしかして一つ上のところ(NTTのサーバ)ですか?そこでまだNAPTしているのでしょうか?

沢山の質問申し訳ございませんが、ご意見やヒントなどをぜひ伺いたいと思います。
よろしくお願いいたします。

投稿日時 - 2007-08-26 02:14:41

このQ&Aは役に立ちましたか?

0人が「このQ&Aが役に立った」と投票しています

回答(1)

あなたにオススメの質問